Link to home
Create AccountLog in
Avatar of natrat22
natrat22

asked on

Cannot print to local printer in remote desktop / terminal services session

hi all,
I have an issue that is frustrating me immensely.  A client cannot print to a local printer when in a remote desktop / terminal services session.
The local PC is a new Dell Vostro 1500 laptop with Vista Business.  It has connected to it a HP Laserjet P1006 and Dell 984 multifunction, both USB printers.  Both printers work locally.  It's internet connection is a Telstra Mobile Wireless adapter, this is a connection up to 3Mbps/sec which gives the laptop a public facing IP address (no NAT).
The remote PC is a new Dell Vostro running Vista Business.  Both the printers have been previously installed on the machine to ensure drivers are present for the remote session.  The internet connection for the remote PC is ADSL2 via a Netgear DG834G modem/router.
When the laptop initiates the remote session, it connects and the printers appear on the remote machine, as you would expect (ie. "Laserjet P1006 on LAPTOP").  The properties of the printer can be brought up as well.
However when you print to either printer, the job queues, but nothing happens.  Checking the queue status shows 4kb of the job has been sent but nothing else happens.  Minimising the remote session and checking the print queue locally shows a remote desktop session print job in the queue, but again doing nothing.
If you then disconnect the session and then reconnect, an additional printer appears inthe printer list of the form "Laserjet P1006 on LAPTOP (Copy 1)".  If you disconnect and reconnect a Copy3 is created.  You can't vidw the printer properties for any of these copies .
Trying to eliminate different things I popped an XP Pro box in as the remote machine, and exactly the same thing happens when connecting from the laptop.
I also connected from a different PC (my office PC running Vista Business) and two of my local printers came through into the remote session and I could print to both, so I'm surmising it's something to do with the laptop and/or the 3G wireless broadband connection.
Other strange things happen when trying to overcome the problem.  Attempting to delete the job in the queue (at either end) fails, and if you try and logout after attempting to dlete the job in the remote queue it takes about 5-8 minutes to log off the session.  Sometimes when the session is logged off, the local printer then starts to get repeated remote jobs put into its print queue, up to several hundred before I killed the spooler and deleted them.  None of them actually print though.
I'm about to test the Laserjet P1006 on my own laptop which runs XP and Vista to eliminate the printer itself as the problem (unlikely as the same issue occurs with two different printers).
I also want to get the laptop onto a different internet connection to see if that has any effect but it's tricky as its in use by my client
Needless to say I have disabled all firewall software on both PCs during this testing, and eanbled all available sharing options.
Does anyone have any pointers as to where I could continue to troubleshoot?

thanks
nathan
Avatar of Brian Pierce
Brian Pierce
Flag of United Kingdom of Great Britain and Northern Ireland image

Avatar of natrat22
natrat22

ASKER

Thanks, I'll give it a shot tomorrow but it seems to imply that its useful when the printers aren't appearing at all in the remote session, where for the above problem they both do appear.  Will let you know.
ASKER CERTIFIED SOLUTION
Avatar of Rob Williams
Rob Williams
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
None of the above worked :(     I have checked the event log and there are no errors relating to either of the printers that aren't working (there are plenty of entries relating to missing drivers for other printers I have on my laptop, which is expected, but no mention at all of the printers that show up ok in the printer list but then have the problem originally described of not printing).

I've now tried one of the printers on two different PCs (the Laserjet P1006) so I am wondering if I have just had bad luck in that two of my clients printers are both not compatible with remote desktop?  I will take one of my printers that does work to the clients and see if that is the issue.

As an aside, does anyone know of a resource that lists current printers that do work with remote desktop?

nathan
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Ok i've finally resolved this.  Was a combination of things.  Firstly, neither of the printers I was trying (the Dell 984 Multifunction or the HP Laserjet P1006) work in a remote session even when drivers are loaded manually on the server.  I've confirmed this on three PCs now.

Secondly, while the Dell printer was installed on the client PC, no other local printer would be pulled through to the remote session (I had installed a couple of printers I know work in RDP, a Canon IP5000 and HP Officejet 6310).  I deleted the Dell printer from the client, killed and started the spooler again, reconnected to the server and both printers then appeared and could be printed to.

thanks for all input!
nathan
Excellent ! Glad to hear and thank you for posting your findings.
Cheers !
--Rob
Just to say that that I was having this issue, and adding the registry value in the Microsoft KB link posted above solved my problem.
I dont agree with the solution as i had the same problem and solved it.  I  ran multiple Termainl Server domain, and I've been doing the "terminal servers" since NT 3.51 (winframe) it was called back then.  Anyway, the problem you are having is the rpinter itself. The p1006 is NOT a PCL printer and is using the winprint device the format the print jobs.  If you switch to a PCL based printer you will have no more problems.  IE HP LJ 1020 was good any laserjet 3 4 5 6 any of them work or many brother have the proper PCL LJ emulation - they work great and are cheap.  It would seem that HP has drop it's cheap LJ PCL line of printers.   But anyway, this is fact!  I once had a p1006 type printer and even got it working once where it would print 1 sheet of a 5 sheet doc... things like that.  Good Luck and I hope this thread gets revisited.
I had a similar issue and I ensured that the server 2003 and the XP client had the newest RDP offered by Microsoft and it worked perfect.  

XP SP3 already has a newer one, but incase you haven't moved up.

http://www.microsoft.com/downloads/details.aspx?familyid=26F11F0C-0D18-4306-ABCF-D4F18C8F5DF9&displaylang=en

Server 2003 uses this one...

http://www.microsoft.com/downloads/details.aspx?familyid=CC148041-577F-4201-B62C-D71ADC98ADB1&displaylang=en

I spent the last week and about 25 hours researching this, and finally got the hp p1006 printer to print with no issues or "Redirection Printer..." queues of thuosands...

I had this exact problem. I started looking in the HP forums and found that the way they have set up the lower cost printer drivers would not work with Microsoft remote.  I also found that they were working with a product called thinprint.  I purchased thinprint and it solved the problem. The other thing that it solved was having to install printer drivers on the host. This is a nice feature as I am new to RDP. It was worth the money (not expensive) to me. Thought I'd pass this on.