Link to home
Start Free TrialLog in
Avatar of suran78
suran78

asked on

Debugger not running in ASP.NET

I am trying to execute asp.net 1.1 web project and I get this error in VS .NET 1.1

While trying to run project: Unable to start debugger on the webserver.  The project is not configured to be debugged.  

I don't know what is wrong here.  Please help me troubleshoot it.

Thanks.
Avatar of RDdice
RDdice
Flag of United States of America image

Make sure you have <compilation debug="true"></compilation>


Turned on in your Web.Config

i'm guessing you have .net 2.0 installed as well and the virtual directory in IIS must be running under .net 2.0

IIS5.1 (windows XP):
go to IIS configuration (Control Panel > Administrative Tools) and right-click on the virtual directory, in the ASP.NET tab you can set the .net version to run the app under.

IIS6 or 7 (Windows 2003 & Vista)
put the app in a 1.1 app pool (not sure on the specific steps - i work with IIS5.1 on my dev machine :))
asp.net is in the virtual directory's properties window, not the context menu :)
Avatar of suran78
suran78

ASKER

I have <compilation defaultLanguage="vb" debug="true" /> in webconfig.

And I went to admin tools. and I already have 1.1 in default websites properties, ASP.NET tab.  Don't know what else can go wrong.
Do you have Execute Permissions set to Scripts only?
.NET 1.1 was always very flaky for me. Biggest reason to move to 2.0 you will be glad you did.

A good trick to try is to reset .NET in IIS.

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis -i

If this doesn't work, in the past if i had issues i could not fix, reinstalling IIS resolved them. Remove IIS, reboot, then reinstall. Make sure you reboot.
also see if you can't identify your problem here:
http://support.microsoft.com/kb/306172
Avatar of suran78

ASKER

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322>aspnet_regiis -i  
I am getting wrong path error.  Is it possible that this file does not exist and that's the problem.  Where can I get it?
Avatar of suran78

ASKER

I di dfind it and executed with - i.  But the error persists.
Avatar of suran78

ASKER

Getting differrent error :   Debugger failed because integrated windows authentication is not enabled.

In web.config:

 <authentication mode="Windows" />
    <!--  AUTHORIZATION
          This section sets the authorization policies of the application. You can allow or deny access
          to application resources by user or role. Wildcards: "*" mean everyone, "?" means anonymous
          (unauthenticated) users.
    -->
    <authorization>
try enablind it on the IIS side as well.
You need to turn windows authorization on for iis on the site.

it's in IIS, Directory Security->Edit->Integrated Windows authentication
Avatar of suran78

ASKER

Ah!  I could move 1 step forward with selecting window authen.  But when I am running my application and teh browser opens up : I am getting this message:

Access to the path "c:\windows\microsoft.net\framework\v1.1.4322\Temporary ASP.NET Files\webapplication2\37f71cbe\939c5907" is denied.
does the ASPNET user have access to your app's physical folder?
Restart iis with iisreset

By default ASP should have access to the temp folder, but as Velio stated, make sure you set ASPNET, Network and Network service to the Temporary ASP.NET files folder.

It would probably be a good idea to delete everything in that folder as well.
Avatar of suran78

ASKER

I restarted IIS and also looked for teh temp folder. It does not exist.  But everytime I run teh debugger it gives me that same Access denied error.
c:\windows\microsoft.net\framework\v1.1.4322\Temporary ASP.NET Files\
I believe that is a hidden folder.

Make sure you can see it, in Explorer, tools->Folder Options->View->Show hidden files and folders. click it.

hit ok.

now go delete everything in the folder.

then set permissions on the folder as stated above.

Avatar of suran78

ASKER

I deleted all the directories and files in this folder.  But still getting the same error.
Did you set the permissions on the folder?

Some times it a good idea to do a reboot and make sure everything is all set.

This reminds me of why i hated 1.1 so much.
Avatar of suran78

ASKER

yes, and also rebooted, but still getting that stinky error.  
Avatar of suran78

ASKER

any other way.  Help! Cannot upgrade it, company policy to keep it in 1.1.
Did you try uninstalling IIS yet?

Uninstall IIS, reboot, Install IIS.

Run aspnet_regiis -i
SOLUTION
Avatar of Velio
Velio
Flag of South Africa image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of suran78

ASKER

What a pain.  I uninstalled, rebooted installed and also tried checking the Replace owner on subcontainers and objects in temporary folder's property.  But nothing works.  When I check the Replace owner on subcontainers and objects in folder property, and click apply button, it unchecks it.  I don't know if it's accepting it.  Any more suggestions.
Avatar of suran78

ASKER

I noticed that this temp folder is read only.  I  removed readonly and clicked apply.  But it's still not accepting it.  How can I remove read only permission from this folder?
Avatar of suran78

ASKER

Also at this point installing 2.0 won't help becuase teh temp folder for 2.0 is also read only.  I don't know how to remove read only permission.  
A bad hack sometimes when all else fails is to give "everyone" full control on your temp folder.
Avatar of suran78

ASKER

But I checked permission on my coworker computer and temp folder is read only jus like mine.  That computer is running asp.net1.1 without any issues.  So what is wrong with mine work station?
Do you have local Admin access?
Avatar of suran78

ASKER

no,  i don't login as admin, and cannot.  But my cowokers don't login as admin either.
not as admin, are you apart of the admin group for your local box?
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Absolutely worse case, and I've had to do this before is to complete uninstall and reinstall Visual Studio.

Before doing that you may want to try and start a completely new web project to see is your still getting the issue.

ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial