Link to home
Start Free TrialLog in
Avatar of DaveEE
DaveEEFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Wizard continuously attempting to install device.

I have XP Home Edition Version 2002 Service Pack 2
Until a few days ago I had my HP Deskjet 895Cxi attached to a USB port. I was sharing it on my LAN and it was running with NO problems at all.
I attempted to add a wireless router with built in print server, but after many frustrating hours gave up, as it would not work with my printer. So I decided to go back to just using the printer on USB and sharing it on my LAN.
I now find that no matter what I do, every time I turn either the printer OR the compute on or off XP sees a NEW DEVICE and starts the ADD NEW DEVICE wizard for the printer. Even when it is APPARENTLY installed.
However the add new device wizard never actually works properly.
Even on it's first run, it gets as far as copying files from c:/windows/inf/nprint.inf says it is copying files, the green progress line moves across, the wizard ends as follows:

 Found New Hardware Wizard

Cannot install this Hardware

There was a proble, installing this hardware:
HP Deskjet 895Cxi
An error occurred during the installation of the device
The system cannot find the file specified.

The weird thing is that the printer appears in the printers & Faxes list, and works just fine.
The problem is that because the system thinks the installation has failed, it keeps re-detecting the printer on every re-boot or when the printer is turned off or on.

I've done everything I can think of. I've totally removed ALL reference to the the printer and started from scratch, but the same thing happens.
Avatar of Delphineous Silverwing
Delphineous Silverwing
Flag of United States of America image

Did you try removing the printer from Device Manage, while the printer was connected?  To do this, have the printer connected and turned on, then go into Device Manager and locate the printer.  Right-click on the printer and select "Uninstall".  Now disconnect the printer.  Double check your add/remove programs for HP printer programs and uninstall them.

Download the latest driver from HP and install, being sure not to connect the printer until prompted by the software install.
Just to confirm (not after any points) - The above should work. I've had this same problem before, and you should be able to locate the printer in Device Manager, beneath the 'Universal Serial Bus Controllers' title.

Make sure you uninstall it from there (as already said above) then reinstall as if brand new, and the problem should go away...
Avatar of DaveEE

ASKER

Hi.
There wasn't any actual mention of my printer in the USB devices. But between the USB host controllers & the root hubs there was an entry: "USB Printing Support"
I uninstalled that & deleted the printer from the Printers & Faxes window.

I then tried re-installing everything - I don't have specific installation software from HP, but my printer model IS in the list of HP printers when you use the add new printer wizard.

Exactly the same thing happens. The wizard fails to work, but the printer appears in the list of available printers and works just fine. But every time I turn on or off in jumps the "FOUND NEW DEVICE" wizard. Plus the "USB Printing Support" returns to the list of USB devices in the device manager.

Maybe I need to find the correct HP Deskjet 895Cxi software & drivers. But a quick search tells me it should install from windows without that.

I'll have another look for a download of the drivers.
Avatar of DaveEE

ASKER

I've just been to the HP site & they only supply drivers for windows versions previous to XP.
For XP it says:
"The driver solution for this product is included in your Windows XP operating system and is already on your computer. There is no need to download anything."
Avatar of DaveEE

ASKER

If what HP are saying is true, then why is the install wizard failing?
I'm repeating myself, but it says:

"Cannot install this Hardware
There was a problem installing this hardware:
HP Deskjet 895Cxi
An error occurred during the installation of the device
The system cannot find the file specified."

So something is missing, but it doesn't tell me WHAT or Where...
Avatar of DaveEE

ASKER

Hmmmmm... I'm wondering if the silence now means I've reached the same brick wall that I reached with HP.
They sent me 4 or 5 emails telling me how to use the automatic install using windows XP, and an attempt to fool XP into not trying to re-install, but they weren't able/willing to look into the REAl problem which is that the Microsoft installation procedure is looking for a file that it ISN'T finding and so is failing.
They said I need to re-install the operating system!!!!!!!!!!!

I put my laptop (also XP) next to the printer & used the USB cable and set-up in an identical way.
It found the device, foind the ".inf" file and copied & installed everything without any problems at all.
When you turn the printer on & off you get the usual 'dong ding' & 'ding dong' but XP does NOT try to re-install the device. Plus it appears in the device manager, and if you look at its properties, it is being driven by the 'USB printing Support' in the USB device list.

I can't find any way of finding out exactly which files the installation program uses and what version & where it gets them from, so I guess I have to give up?

Unless anyone else knows something about this subject?

Avatar of DaveEE

ASKER

Weird... is anyone actually seeing this now or are my messages dissapearing somewhere?
If no one can help, how do I know?
How long do I wait?
I've gone as far as I can with HP, they just say I either need to reinstall the OS or contact Microsoft about the problem.
Microsoft want to charge me $59 before I even tell them what the problem is!

As far as I can see the windows installer is missing a file.
Does anyone know how to find out what file is missing? The setup works perfectly on my laptop, so once I know what the file is I can copy it from my laptop and solve the problem.

Should I close this question & open one under a different subject?

Someone please respond to this message.

Thank you.
Sorry Dave,

I should've posted to let you know I was still here! I've been searching high and low for a solution... I'll get back to you a.s.a.p. with something...

I know i've had the same problem before but can't pin down when/where/how it was fixed etc...

Out of interest, have you got any other USB devices that you can uninstall and reinstall to see if they reinstall successfully? It could be a USB driver problem rather than a printer driver problem...

Also, see if you can 'manually' add the printer as well - Go to Printers and Faxes > Add Printer > Select Local (remove 'automatically detect option) > Select Port (probably USB001 or something similar) > Manually locate the correct driver for that printer.

This will still use the built in XP driver, but may force the discovery of the correct driver, rather than Windows searching but failing to find it.

You MAY find that although the printer works etc, Windows is actually using a generic driver for it or something...

Give this a try whilst I keep searching and i'll come back with any more suggestions I can think of!
Might also be worth searching the Microsoft Update Catalog for any updates to the built in drivers for that printer...

It's a big list of deskjets though...

http://catalog.update.microsoft.com/v7/site/Search.aspx?q=hp+deskjet
Avatar of DaveEE

ASKER

Ahh... thanks Pete...
Yeah I tried the manual install, although starting off differently, it eventually leads to the identical bit of code that uses the windows drivers to install.
When it's finished it leaves the same situation:
No printer installed in the device manager, but 'USB printing Support' appears in USB devices.
And again every time you re-boot or turn the printer on or off XP try's to re-install it.

On the laptop - where this all works perfectly - I see the actual Deskjet895Cxi appear in the device manager as well as the USB Printing Support.

So whatever the file is that's missing, it's the one that puts that device under the printers device list.
Hrmmmm... Maybe if you have the original XP CD or Recovery disk, when you add the printer manually, you could tell it to look for the drivers on the disk instead?

That would at least force it to use the drivers from the CD itself, as opposed to the ones on the local HDD which may be the cause of the problem...

To do that, obviously insert the CD, and go through the same processes of manually reinstalling the printer, until you reach the area where you select the driver > There should be a 'Have Disk' button somewhere, click this and tell it to search that CD...

Not sure if that will work, as the drivers on the CD are probably in an archive, but it's worth a shot...
Also, try running a check disk (chkdsk /f /r from a command prompt) on your system drive in case it has any unreadable areas...
Avatar of DaveEE

ASKER

Hi again...
Yeah I did all those things a while ago, in fact almost everything anyone has suggested I did before coming to EE or HP.
I've used the 'ntprint.inf' from my windows CD. Same problem. (file was identical anyway)
I've also run the windows SFC (system File Check) utility plus I also attempted to find the files on the laptop (which works fine), I found a directory C:\WINDOWS\system32\spool\drivers\w32x86\3
even copied those files over to the PC. Still the same problem, so there must be other files being got from somewhere else.

I've not had any problems with other USB devices. But I don't think it's a problem with USB as such. The USB part sets up identically to the laptop. Namely the "USB Printing Support" item.
Like I said what is different to the Laptop, is that on the PC, I don't get a 'Printers' entry and 'Deskjet895Cxi'  appearing in the device manager. Remember that ISN'T a USB entry.
So I'm assuming every time the PC sees the device attaching, it looks to see if there is a printer of that type installed under PRINTERS & there isn't so it tries to install it even though it has general USB Printing Support installed under the USB devices.
Avatar of DaveEE

ASKER

Doesn't look like I'm gonna get any solution doe it?
I tried removing ALL the USB devices from the device manager and re-booting.
The machine booted, detected all the USB controllers & Hubs and one by one detected all my attached USB devices & istalled them perfectly ALL EXCEPT the Deskjet895Cxi ! ! !
Eactly the same problem, as the installation wizard finishes it comes up with the message that it failed because there is a file missing.

Wouldn't you think this would be a simple thing to solve?
If HP won't talk to me & Microsoft want to charge me money what options do I have?

I guess I'll just have to totally re-install the operating system & then spens weeks getting things back as they were.

This sort of thing frustrates me so much.
:¬(

I'll leave this open just in case someone does come up with something,,,
Dave.
Avatar of DaveEE

ASKER

EE just told me to check on this open question.
I was hopefully awaiting an expert to come to my rescue....
Am I supposed to only wait so long?
Not sure if protocol has changed.
But it doesn't look like anyone knows how to find what file is missing in this printer installation problem.
I'll leave it open for a while longer.
Well i'm stumped... If someone else doesn't come up with another idea, I'd say rebuilding your system is the only way to go!

Depends how much it bothers you too of course, if the printer works ok... Sorry I can't be of any more help!

Pete
Avatar of DaveEE

ASKER

Well thanks for trying Pete.
Maybe someone can find a way to get the Microsoft installation wizard to write it's actions to a log?
A green progress bar moves left to right as it copies them, but there are multiple files used & their names flash by far too quickly to note them down.
Maybe also the installer creates a temporary batch file or something?
I'm amazed no one knows anything about this.
Obviously someone at microsoft set this all up, and I guess someone knows all about the wizards & what they do & how, but maybe they aren't involved in EE.
As you say Pete, I can use it, so I'll leave it open here in case some eagre person wants a challenge to get to the bottom of it. Once we find out the hows & why's it could be of great help to others too.

Cheers,
Dave.
ASKER CERTIFIED SOLUTION
Avatar of PeteJThomas
PeteJThomas
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of DaveEE

ASKER

Thank you so much for all your help Pete.
I think your last message did lead to the solutions, the thing I found to remove with the windows installer cleanup utility was something to do with HP Print Drivers. So I removed that using that utility you suggested.
However I did do something else which could also have solved the problem.
I found two instances of 'print server' in the 'add & remove programs' list which I also removed.
On re-boot the problem disappeared.
Thanks again.
Best wishes,
Dave.
Ha! Bloomin' typical eh, the last thing we try and boom! Well whatever fixed it, I'm glad you didn't have to rebuild your machine! That would sort of be like using a sledge hammer to crack a nut... :)

Take care!