Link to home
Create AccountLog in
Avatar of SoftDesignServices
SoftDesignServicesFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Port priority

I have interited a setup which I only have a very limited bit of info about. I have a cisco switch 2950 (from show version). It has a vlan configured on it callled DataVLAN with ID 10. When I do a show interface status i get:
Port      Name               Status       Vlan       Duplex  Speed Type
Fa0/1                        connected    10         a-half   a-10 10/100BaseTX
Fa0/2                        notconnect   10           auto   auto 10/100BaseTX
Fa0/3                        connected    10         a-full  a-100 10/100BaseTX
Fa0/4     *** Link to Greenw connected    trunk        full    100 10/100BaseTX
Fa0/5                        connected    10         a-full  a-100 10/100BaseTX
Fa0/6                        notconnect   10           auto   auto 10/100BaseTX
Fa0/7                        notconnect   10           auto   auto 10/100BaseTX
Fa0/8                        connected    10         a-full  a-100 10/100BaseTX
Fa0/9                        notconnect   10           auto   auto 10/100BaseTX
Fa0/10                       notconnect   10           auto   auto 10/100BaseTX
Fa0/11                       connected    10         a-full  a-100 10/100BaseTX
Fa0/12                       notconnect   10           auto   auto 10/100BaseTX
Fa0/13                       connected    10         a-full  a-100 10/100BaseTX
Fa0/14                       connected    10         a-full  a-100 10/100BaseTX
Fa0/15                       connected    10         a-full  a-100 10/100BaseTX
Fa0/16                       connected    10         a-full  a-100 10/100BaseTX
Fa0/17    Connection to Alca connected    10         a-full  a-100 10/100BaseTX
Fa0/18                       connected    10         a-full  a-100 10/100BaseTX
Fa0/19                       connected    10         a-full  a-100 10/100BaseTX
Fa0/20                       connected    10         a-full  a-100 10/100BaseTX
Fa0/21                       connected    10         a-full  a-100 10/100BaseTX
Fa0/22                       connected    10         a-full  a-100 10/100BaseTX

I'm told that when the switch was previously configured the telephone guys attepted to configure priority to voice traffic using VLANS but due to the age of the switch this was not possilbe. I've been told that instead they gave prioity to a certain port with the phone system was plugged into - this must be "Fa0/17    Connection to Alcatel" i guess.

There only appears to be one vlan DataVLAN and all ports are assigned to it so it which is strange. However can anyone tell me they might have configured a port to have priority over the others?

Apologies for being vague if you need more info please let me know but be clear on the command it should use as I never use cisco equipment.

Thanks
Avatar of Reid Palmeira
Reid Palmeira
Flag of United States of America image

It's possibly they aren't really using priority at L2, check the QoS settings on the device(s) that are connected. If they're makring packets with DSCP code points or maybe IP Precedence values the QoS is likely handlded at the router, not the switch. Usually the "priority" on a switch is merely breaking out voice and data traffic to different VLANS then using the appropriate markings at the router which is where the bottleneck usually is.
Avatar of SoftDesignServices

ASKER

I'll check the phone system itself. However I'm 100% sure nothing is configured on any routers. If any prioritisation is actually happening it must be on the Cisco. It's possible there is actually nothing usful configured on the switch at all. The phone system company that managed it where useless and we terminated the contract.

I would be happy to post any conifg from the switches if it helps.
A running config from the switch and router would tell us more about qos in your environment.
No probs. The link to Greenwich is a Lan extension service link. The link to Alcatel is the phone system. There is another phone system plugged into a cisco swich on the other end for the LES.

Many thanks

Building configuration...

Current configuration : 2120 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Asia_House
!
enable password ******
!
ip subnet-zero
!
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1,10
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 10
!
interface FastEthernet0/2
 switchport access vlan 10
!
interface FastEthernet0/3
 switchport access vlan 10
 mls qos cos 5
!
interface FastEthernet0/4
 description *** Link to Greenwich ***
 speed 100
 duplex full
 mls qos trust cos
!
interface FastEthernet0/5
 switchport access vlan 10
!
interface FastEthernet0/6
 switchport access vlan 10
!
interface FastEthernet0/7
 switchport access vlan 10
!
interface FastEthernet0/8
 switchport access vlan 10
!
interface FastEthernet0/9
 switchport access vlan 10
!
interface FastEthernet0/10
 switchport access vlan 10
!
interface FastEthernet0/11
 switchport access vlan 10
!
interface FastEthernet0/12
 switchport access vlan 10
!
interface FastEthernet0/13
 switchport access vlan 10
!
interface FastEthernet0/14
 switchport access vlan 10
!
interface FastEthernet0/15
 switchport access vlan 10
 mls qos cos 5
!
interface FastEthernet0/16
 switchport access vlan 10
!
interface FastEthernet0/17
 description Connection to Alcatel 4400 PBX
 switchport access vlan 10
!
interface FastEthernet0/18
 switchport access vlan 10
!
interface FastEthernet0/19
 switchport access vlan 10
!
interface FastEthernet0/20
 switchport access vlan 10
!
interface FastEthernet0/21
 switchport access vlan 10
!
interface FastEthernet0/22
 switchport access vlan 10
!
interface FastEthernet0/23
 switchport access vlan 10
!
interface FastEthernet0/24
 switchport access vlan 10
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 ip address 133.0.200.3 255.255.0.0
 no ip route-cache
!
ip http server
snmp-server engineID local 0000000902000007EB1F0B80
snmp-server community nextira0ne RO
!
line con 0
 stopbits 1
line vty 0 4
 password *****
 login
line vty 5 15
 login
!
!
end
ASKER CERTIFIED SOLUTION
Avatar of bfason
bfason
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account