Link to home
Start Free TrialLog in
Avatar of dawnachoe
dawnachoe

asked on

Cable internet works but no connection through netgear wireless router.

I cannot connect to the internet with my PC running Windows XP.  It was just fine. Then I restarted my computer and it will no longer connect.  I have tried resetting the IP address because it wasn't registering.   I got some Spyware recently due to adware attacking my computer.  I have Avast home edition and it is working properly now that I reregistered it.  Please help?
Avatar of IndiGenus
IndiGenus
Flag of United States of America image

Likely damage to the Winsock or LSP stack from the spyware or the fixing of the spyware problem.

Run this tool and hopefully it will restore the connection.

http://www.spychecker.com/program/winsockxpfix.html
reboot the cable modem and then connect the router without connecting anything else at all.

Cable modems bind to mac addresses.  rebooting clears the mac from memory.

Avatar of dawnachoe
dawnachoe

ASKER

I wish that was it but it was not.  I hooked it up just through the cable modem.  Then I can connect.  However, I need it to be connected through the router.  I have tried almost everything because if I had tried everything it would be working.
tried restarting a million times.
unplugged and pluged in several times.
checked all cables and connections
My internet is working on the MAC just not the PC.  I keep running the spydoctor and it does keep finding malware/adware.  It is just the settings I know it.  I have reset both the router and the cable modem.  I have ipconfig/release and renew the ip address.  It will give me a cable modem IP when that is plugged in and it will give me a router ip when that is plugged in.  It still says that I am connected but there is no connection.  Only the MAC works through the router.  None of my printers work either just the MAC.  i even disconnected the MAC and started over with just the PC.  Nothing is working.  I know it is the settings. Something needs to be checked or unchecked.  Can you help?


Okay.  I am going to take everything off and reboot again with nothing attached.  Then I will just hook up the PC and see then.  I should probably just pay and call Netgear.  Any suggestions would be great.
You didn't mention whether or not you tried the winsockfix tool. Did you?

Also, give us a HijackThis log to see if you are still dealing with malware here.

http://www.trendsecure.com/portal/en-US/threat_analytics/HJTInstall.exe

Click on "Do a system scan and save a log file" button. Post the text from the log file. Do not have HJT fix anything at this point.

Please do not post the log into the comment window. Use "Attach File" under the comment window to post the log.
I did try to winsockfix tool!  No it didn't work either.  I am using two different computers unplugging and plugging in to try and fix the other one.  I will see how to attach this from the other computer.  I will try this now and see what I can find out.  Thanks.  I will come back here shortly.
reset the router to fqctory defaults.  More often then not it is just holding the reset button for a few seconds, or holding the reset button as you unplug, plus the power back it.
I tried resetting it also.  I believe it has something to do with NetGear.  I most likely will have to call them and pay them to help me. thanks for trying.  any more suggestions.
you reset the modm to factory default or did you just hit the reset button?  I am talking about resetting the modem to factory default and seeing if it works.  I think it is a configuration issue personally.  

Odds are the first thing netgear will have you do is to reset your modem to factory default settings!!
Oh My Gosh!!!  I got it to work.  Only took 4 days right!  Thank you for all of your help.  What I did was first I restarted windows in the last saved start.  Then I ran a different Adware program the Pro Geeks in IL gave to me last year.  Then I shut off the modem first.  Once completely off I shut off the netgear.  Once completely off I shut down the Sony PC once off completely I shut down the MAC then I shut down the Xerox Laser on the Network.  Unplugged everything.  Walked away for about 30 minutes.  Turned on the Modem first.  Once on all the way turned on the Netgear.  Once on all the Way I turned on the Sony.  Again once on all the Way I did the same with the MAC and the Xerox.  Now it totally works.  I can't say whether it was restarting Windows or using the ADWARE program or if it was the sequence in which I shut down all the equipment and let it be off for awhile.  Whatever it was it is working now!  I hope my problem can help someone else in the future!  Thank you to everyone who helped me!
good to hear!
ASKER CERTIFIED SOLUTION
Avatar of Computer101
Computer101
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial