Link to home
Create AccountLog in
Avatar of Andrew Angell
Andrew AngellFlag for United States of America

asked on

Why is my FileMaker PHP API service suddenly returning "Service Unavailable"???

I've got FMSA9 installed and have for awhile now.  I've got the PHP API setup and I've been building test applications with it for a few weeks now.  I've also been working with the DreamWeaver plugin from FMWebSchools and that works great with it too.  I went ahead and completed an actual project I'd like to take live for my client and that's when I started getting "Service Unavailable" back from the PHP API, of course.  I can't even get the very first step connected:

<?php
# Store credentials for the FM server.  For security reasons, this data
# should be kept in a file outside of the web root.
$FMHost = 'filemaker.domain.com';
$FMUser = 'USER';
$FMPass = 'PASSWORD';

# Open FileMaker.php API
require_once('FileMaker.php');

# Set the file and layout to use
$FMFile = 'Purchase Order Items';
$FMLayout = 'ScansWebApp';

# Instantiate a new FM session
$FMSession = new FileMaker($FMFile, $FMHost, $FMUser, $FMPass);
?>

All I get is big black bold "Service Unavailable" when I try and run that.  It's the same thing that's worked for weeks now.

I tried rebooting the server and that didn't solve the problem.  Any information on what's causing this would be greatly appreciated.
Avatar of Member_2_908359
Member_2_908359
Flag of France image

have you changes anything in your IIS setup? I used to use the php service with the regular fm server and it is very hairy.
and make sure your php runs wihtout fmaker.
Avatar of Andrew Angell

ASKER

Nope.  IIS hasn't been touched.  ODBC connections and scripts that use the XML API directly are still working fine.  Only the PHP API is what's returning Service Unavailable.  When I open up the Admin Panel, though, it shows all green lights for everything.  
what about regular php? "phpinfo" returns what?
Yeah, everything else is working great, and in fact, this has just gotten more confusing.  

The FM server I'm working with is located on-site at my client's building and always has been.  It has a filemaker.ourdomain.com address associated with it.  The production web server for this client is hosted in a DataCenter off-site and I also have my own test server that I run at my home.

I've always used my own test server for testing and then uploaded to the production server of my clietn when I was done.  When this problem started happening I was getting the same thing on my server and the production server.

I'm on-site at my client's location now and I'm working on an XP workstation that I have setup as a test server as well.  On this machine it fired right up first try no problem.  So then I thought, hmmm, I wonder if there's some way that off-site IP's have been blocked or something.  However, it's also working on the production server now!!??

As of right now my test server at my house is the only one that is still giving me this error.  Any ideas at all, cuz I'm lost.

ASKER CERTIFIED SOLUTION
Avatar of Member_2_908359
Member_2_908359
Flag of France image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account