Anonymous Access Site Still Prompting for Credentials

We are using the CMS functionality in MOSS 2007 to create a new web site for a client and have created a server farm. We have wrapped up development, added content, tested the site and we're ready to turn on anonymous access for the WFE. We've done this in the past with no issues. On this specific farm we went through the normal steps for configuring the access (see http://www.ararat.org.il/sharepoint-server-2007-anonymous-access-howto ).

We are currently still getting prompted for credentials when accessing the site through both the IP or domain.  We've tried unchecking the setting and trying to reapply anonymous through MOSS with no success.

We have a case open with Microsoft but the process is moving along very slow. So far we've confirmed that there's nothing in the code of the page that's is causing the prompts. We did this by accessing a .gif file directly inside a site page and still getting the prompt.

- We have tested in both browsers (IE 7 and Firefox) and specifically use Firefox to avoid any IE security or session features.

- We haven't yet been able to test this from a public domain and have had to try and test the page from inside the clients network.

- We've dropped some sample pages/files into another MOSS Farm with anonymous access and we're not receiving any prompts for credentials.

- Microsoft had us create a test site in MOSS in the web farm (publishing site) and we've been able to set anonymous access and test it successfully.

I was curious if anyone has seen a similar issue when apply anonymous access to MOSS on a web farm.

Thanks.

ubertypAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

meverestCommented:
Hi,

check the access rights on the physical files on disk and make sure that the web site anonymous user (IUSR_<computername>) has read access to those files and directories.

cheers.
0
ubertypAuthor Commented:
Just an update on how we solved this:

1. Host Header for the domain was added.
2. On the Central Admin, click on operations tab> select timer job definitions > look for job "provisional job" > Delete this job.

It then stopping prompting for authentication and solved our problem.

Also, the first first time the steps for allowing anonymous access were performed, we received an error message and scren "The path specified cannot be used at this time. (Exception from HRESULT: 0x80070094). We think this is when the provisional job started running and was never killed until we did it manually.
0
Computer101Commented:
PAQed with points refunded (500)

Computer101
EE Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.