Linux NFS clients report 'Unknown Error 526' with certain characters in filenames on Novell Netware NFS server

fncexperts
fncexperts used Ask the Experts™
on
The file server is Novell Netware 6.5 SP5.
The NFS clients are Red Hat Enterprise 3 and Solaris 8

The problem is that when a filename contains certain characters, the Linux clients return the error 'unknown error 526' if you try and list the directory contents.

Solaris clients report the directory as being empty.

Windows clients see the directory perfectly fine.

If I copy said files off the server and onto some removable media using a Windows machine, and then mount that media on the Liunux clients, I get the expected '?' where said characters are.

So although the character support is clearly missing from the NFS clients, it seems to me as though the Netware servers are causing an extra problem that stops the direcory being accessed at all from the NFS clients.

The biggest issue is that if one of these files exists in a fiarly high level directory, it stops users seeing all subdirectories below it.

Any help is much appreciated as I am completely stumped.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Interesting....

Obviously, there's a character in the file or directory names that's giving some of the clients fits.

Winblows is notorious for "bending" standards by "fixing" things on the fly. Gives the illusion of "It just works!" while hiding real problems. Which is what I suspect is happening here.

Have you tried going thru the directory structures and removing oddball characters and spaces?
Also, Solaris 8 is a bit long of tooth, and is probably the NFS client that is most sensitive to variances from standards.
Hanno P.S.IT Consultant and Infrastructure Architect

Commented:
Have you been able to figure out which character(s) actually create
the problems?
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Author

Commented:
I have tried correcting / removing the odd characters and then everything works, but the characters just come back as they seem to originate from the Windows clients.

The characters I have found so far seem to be:
1. A strange slightly 'longer than usual' hyphen
2. A period (...) this is a single character and not three .'s
3. Some international characters with accents over them etc...

1) Any idea what that is?

2) That's strange. *NIX shouldn't be bothered by that.

3) These are quite understandable. I'd definitely try to get rid of those.
PAQed with points refunded (500)

Computer101
EE Admin

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial