Cannot register msxml4.dll, return code 0x80070005. Can't install Quickbooks because of it.

I cannot register msxml4.dll which is causing me to not be able to install and use Quickbooks.  I got an error from Quickbooks last week, and the solution was to register the msxml4.dll.  When that failed, it was to uninstall and run the KB936181 update to reinstall MSXML 4.0.  Did that, and it still doesn't register.  Any help on how to fully clean this then reinstall would be greatly appreciated!
mhickenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

flubbsterCommented:
Try running the windows installer cleanup utility to completely remove failed installations and start over.
http://download.microsoft.com/download/e/9/d/e9d80355-7ab4-45b8-80e8-983a48d5e1bd/msicuu2.exe

also, from what I have seen, there are many cases of people being able to use msxml3.dll but not msxml4.dll, and vice-versa. You may be able to register v3 if needed. Not sure if Quickbooks requires v4 or not.
mhickenAuthor Commented:
I couldn't run that cleanup utility due to the following error:  "Can't find script engine "VBScrip" for script '...\temp\ixp000.tmp\startmsi.vbs" when I try to load that.

Also, I couldn't register msxml3.dll either to try that one.
flubbsterCommented:
try to register the VBScript dll

open a command line (start-run) and type: regsvr32 VBScript

If it sayd file not found, then your VBScript.dll is missing or corrupted.
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

flubbsterCommented:
In case there is a path issue to the dll... type this

regsvr32 %systemroot%\system32\vbscript.dll

If still problematic, you should download and install/re-install the VB Script Engine from here:
http://www.microsoft.com/downloads/details.aspx?familyid=c717d943-7e4b-4622-86eb-95a22b832caa&displaylang=en
mhickenAuthor Commented:
My problem may run deeper than I first thought.  In trying to download the VB Script Engine, I needed to validate Windows which neither IE nor Firefox could do even though the Microsoft Genuine Advantage Diagnostic Tool said it was Genuine.  This prevented me from downloading that file as i couldn't register the vbscript.dll either.  

Help...
flubbsterCommented:
sorry... left work..got home... wife...kids...homework... life is grand  lol

http://support.microsoft.com/kb/916247

click the link. willtake you to the ms validation error link and check your system. Follow the steps and lets see why it will not validate. This will tell you. Post back pls with the results.
flubbsterCommented:
also.. this page has a step by step set of instructions of what to do if xp does not validate.

Follow the section titled: What Can I Do If My Version of Windows XP Does Not Validate?

mhickenAuthor Commented:
When I run the diagnostic tool, I get this:
Passed         Active scripting allowed
Passed       Display images enabled
Passed       Computer time and date correct
Passed       Cookies enabled
Passed       Plug-ins enabled
Failed       Microsoft Genuine Advantage plug-ins are installed and loaded
Passed       Office validation ActiveX loaded
Passed       Validation Self-help ActiveX loaded
Failed       Microsoft Genuine Advantage plug-ins connect with Microsoft validation servers

But when I try to install the plugins, I get a message saying "Installation Error: Installation information data unavailable."

I need the following:  " In the plugins subfolder, verify the presence of the npLegitCheckPlugin.dll file.
# In the components subfolder, verify the presence of the nsILegitCheckPlugin.xpt file"
but I don't have either of those.

I didn't see that section you referred to in the last post on that page.
flubbsterCommented:
flubbsterCommented:
are you using IE or Firefox?
mhickenAuthor Commented:
I got the plugins installed in Firefox, but in using either browser, I get the following messages:

Unknown error encountered during Windows validation. The validation service is unable to determine whether your copy of Windows is genuine. Please validate again. If additional attempts result in validation errors you may want to try again later.
[0x80080101]

Why didn't my machine complete validation?
You have encountered an unknown error. Please contact your local product support team for further assistance with this issue.

[0x80080299]

Ugh, this is frustrating.
flubbsterCommented:
very...

go here, your error code is listed and follow it. It says you need to make sure the tool is enabled in IE addons.

http://support.microsoft.com/kb/919868/en-us
mhickenAuthor Commented:
yup, saw that myself.  I checked it and it is enabled in ie.  I seem to have some other basic problem within the browsers or related to that scripting or xml, yet i can't get to the scripting page to fix it.  

When I try to validate through Firefox, it shows that everything is installed, yet whenever I try to validate it comes back to looking for the plugin.  when I refresh the plugin, it's says its installed correctly, but still won't validate.  I tend to think it has to do with that scripting, but i'm not sure how to fix it.
mhickenAuthor Commented:
I'm posting this if this will help you at all (from the MS Diagnostic Tool)

Diagnostic Report (1.7.0069.0):
-----------------------------------------
WGA Data-->
Validation Status: Genuine
Validation Code: 0
Online Validation Code: N/A
Cached Validation Code: N/A
Windows Product Key: *****-*****-T6DFB-Y934T-YD4YT
Windows Product Key Hash: 3g4CZGFEDgbKmn/oB4pa2FZsssU=
Windows Product ID: 76487-OEM-2211906-00102
Windows Product ID Type: 2
Windows License Type: OEM SLP
Windows OS version: 5.1.2600.2.00010100.2.0.pro
CSVLK Server: N/A
CSVLK PID: N/A
ID: {E9774A24-3550-4139-97B9-B7309ADAD8E1}(3)
Is Admin: Yes
TestCab: 0x0
WGA Version: Registered, 1.7.69.2
Signed By: Microsoft
Product Name: N/A
Architecture: N/A
Build lab: N/A
TTS Error: N/A
Validation Diagnostic: 025D1FF3-171-1_70AFE6BE-1170-800401f3_70AFE6BE-116-800401f3_63BB5E84-433-800401f3_E2AD56EA-234-800401f3_16E0B333-156-800401f3_70AFE6BE-1170-800401f3_70AFE6BE-116-800401f3_63BB5E84-433-800401f3_E2AD56EA-234-800401f3_16E0B333-89-800401f3_78155E4D-305-800401f3
Resolution Status: N/A

WgaER Data-->
ThreatID(s): N/A
Version: N/A

Notifications Data-->
Cached Result: N/A
File Exists: Yes
Version: 1.5.540.0
WgaTray.exe Signed By: Microsoft
WgaLogon.dll Signed By: Microsoft

OGA Data-->
Office Status: 100 Genuine
OGA Version: Registered, 1.6.28.0
Signed By: Microsoft
Office Diagnostics: 025D1FF3-171-1_70AFE6BE-1170-800401f3_70AFE6BE-116-800401f3_63BB5E84-433-800401f3_E2AD56EA-234-800401f3_16E0B333-89-800401f3_B4D0AA8B-888-800401f3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
Default Browser: C:\PROGRA~1\MOZILL~1\FIREFOX.exe
Download signed ActiveX controls: Allowed
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Prompt
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->

Other data-->
Office Details:

flubbsterCommented:
As far as I can tell, everything looks great. I think you need to get that scripting engine somehow also. Do you have another system you can download it to and copy it to a usb stick?

I'm searching sites for alternate downloads...

working on it..
flubbsterCommented:
Found it!!!

Windows Script Engine 5.7
http://www.macropool.com/en/download/scripting/scripten_WinXP.exe

you may to register the vbscript dll again. Probably not though, cause the engine installer should do it. Just in case though....

Reregister vbscript.dll:
On the start menu, click Run and type following command:
regsvr32 c:\Windows\System32\vbscript.dll

reboot after the install... and try yet again....
mhickenAuthor Commented:
unfortunately, that didn't work either.  I still can't register the vbscript.dll, or any of the msxml dll's.

btw, i noticed that my product key in the diagnostic is not the same as the sticker on my computer and I used the product update key to fix it, but it says it couldn't update it.  

Not sure what do do...
flubbsterCommented:
Good mornig.... pls try something

Boot into safe mode. Login as Administrator. If an Admin pswd was never used, just hit enter to continue login
Attempt to register the dll

regsvr32 %systemroot%\system32\msxml4.dll

Also, what happens if you try to install the program in safe mode?

flubbsterCommented:
What version of Quickbooks are you using?

Have you tried this procedure from Intuit to repair MSXML?

http://support.quickbooks.intuit.com/support/pages/knowledgebasearticle/a407cd6c
mhickenAuthor Commented:
yes, I tried the quickbooks fix  as the first try to solve the problem.  reinstalled it and everything, but still got the same problem because the msxml4.dll won't register.  I'm pretty sure i tried it in safe mode with the same result, but i'll try again.
slam69Commented:
Hi just taking a look as requested flubbster def appears to be a more deep seated issue, can you register any dlls?

You could try usin gthe registration facility of dlls within dependancy walker, more used for seeing what other dlls are missing or required but can do it this way.

the issue with the online verification has me leaning towards a possible corruption with the registry though, your having issues with the regestration of dlls, installation of software and teh validation toll cant read it properly, however the same probelm doesnt occur in firefox, also very strange!!

i suppose teh IE issue could be something as simple as a firewall block?

http://www.dependencywalker.com 
mhickenAuthor Commented:
I ran dependency walker before, but I just didn't know what to do with the results.  I've attached the results here which show an error with msxml4.dll -- I just don't know how to proceed from here.
dependencywalker-msxml4.doc
slam69Commented:
The best way to debug a module that fails to register is by opening REGSVR32.EXE in Dependency Walker rather than your DLL. Then choose to start profiling (F7). In the profiling dialog, enter the full path to your DLL in the "Program arguments" field. For "Starting directory", you may wish to enter the directory that the DLL resides in. Check the options you wish to use and press Ok. This will run REGSVR32.EXE and attempt to register your DLL. By actually running REGSVR32.EXE, you can see more types of runtime errors.
mhickenAuthor Commented:
that's what i did.  please check the attachment.
flubbsterCommented:
back... I'll be in and out. Don't you hate it when work interferes with what you REALLY want to do.. been running a test on a Guidance System  :)

anyway...mhicken... you forgot the attachment pal..

and slam... ty for helping out
slam69Commented:
if you search your registry for msxml4.dll do you find anything? Im def leaning towards an actual reg problem here

http://www.microsoft.com/downloads/details.aspx?familyid=3144b72b-b4f2-46da-b4b6-c5d7485f2b42&displaylang=en

can you download the msi of the full parser from teh above and run that?
mhickenAuthor Commented:
attachment is 5 posts up.  but here it is again.

I've reinstalled the parser probably 6 times and it doesn't work.

What am I looking for if I search the registry for msxml4.dll?  It shows an error in this attachment, but again, i don't understand how to fix it.


dependencywalker-msxml4.doc
flubbsterCommented:
sorry about that.. I missed it somehow.

Did you try running regsvr32.exe in Dependency Walker as slam suggested above? I am not familiar with it, but it sounds like if you follow those instructions, it will provide more details when it attempts to register the dll.

I'm beginning to think we may have to find a live chicken somewhere, spin it around over the pc and chant "Windows is wonderful"
slam69Commented:
last thing i can think to try, take this file i have attached, change teh extension to .reg and then aftertakig a backup of your registry double click it an dimport it.

if that doesnt work im fresh outta ideas
reg.txt
mhickenAuthor Commented:
that didn't work either...  I think i have to get the product key to match first then I can work on these other issues.
flubbsterCommented:
Was the pc purchased new from a store or was it a rebuilt? Any warranty work ever done on it? There has to be a reason the keys do not match.
mhickenAuthor Commented:
Purchased directly from Dell, no warranty work ever done.  The only thing I can think of is that I might have used a different Windows disk at work to install some components at some point over the last 3 years.  Would that change the product key?  Doesn't seem like it should.
flubbsterCommented:
No, should not change the product key. I did find a reference to something about fixing validation that talked about downloading a critical update. Supposedly, installing a critical update may fix the validation issue. The problem is that the critical update can't require validation. Have you considered trying to do a system restore to back bfore trying to install quickbooks? Don't know if it will help or not. I am running out of ideas buddy. You may want to call Dell and tell them what you are experiencing with the key. There is no reason the key should not match the sticker at all. It would only c hange if you ran a key-changer.
mhickenAuthor Commented:
How do I run a system restore?  I'm willing to try to that.  It wasn't Quickbooks that caused the problem as that was installed and functioning and then stopped one day. It was some other not as important software installation that must have messed it up.

Thanks for sticking with me through this.
flubbsterCommented:
no problem.
 Microsoft's page on System Restore.
http://www.microsoft.com/windowsxp/using/helpandsupport/getstarted/ballew_03may19.mspx

 I have posted the steps below.
System restore should actually have a restore point noting the last software you installed. It creates one every day and keeps them in order. It is a first-in-first-out type deal. It usually saves as many as roughly 12% of your drive is available. So, the greater the available space, the more restore points there will be. I assume you have tried un-installing the program you think messed it up? If not, do so first and try things.

System Restore is actually very easy to do:

Use System Restore
After you've decided to use System Restore to revert your system to a previous state, start the System Restore Wizard and follow the prompts. To use the System Restore Wizard, make sure you're logged on as an administrator, and then follow these steps. You can go back as far as the calendar shows. Anything installed after the restore date you pick will have to be re-installed.  Good Luck!

1.
 Click Start, point to All Programs, point to Accessories, point to System Tools, and then click System Restore.
 
2.
 On the Welcome screen, click Restore my computer to an earlier time, and then click Next.
 
3.
 On the Select a Restore Point page, select the date from the calendar that shows the point you'd like to restore to, and then click Next.

4.
 On the Confirm Restore Point Selection page, verify that the correct restore point is chosen, and then close any open programs.
 
5.
 Click Next if you are ready to proceed or click Back to change the restore point.
 
6.
 The computer will shut down automatically and reboot. On reboot, you'll see the Restoration Complete page, and then click OK.
 

After reviewing the stability of your system, you can choose another restore point or undo this restoration. Just open System Restore and make the appropriate choice. After you use System Restore, you'll have an additional task, Undo my last restoration, on the System Restore Welcome page. Remember that you'll have to reinstall any programs that were installed after the restore point.

If System Restore doesn't work in Normal Mode, it might work in Safe Mode. To use System Restore in Safe Mode, press the F8 key during reboot and choose Safe Mode. When your computer starts in either Safe Mode or Normal Mode, System Restore can be used to capture a working previous state. System Restore can't be opened unless the system is bootable into one of these modes.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
slam69Commented:
If the system restore doesnt work then do a repair install as you have to reenter the product key then, also make fix someo f these reg problems anyway. make sure you use the disc that came with teh machine and the key on the sticker
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.