troubleshooting Question

How to change LDAP record /how to fix Active Directory Replication problem on Windows 2000 Server

Avatar of gsawan
gsawan asked on
Windows 2000Active Directory
11 Comments1 Solution1486 ViewsLast Modified:
Hi all,

My question : How do i change a LDAP record from :
LDAP/14e0463a-0489-47c2-b25a-245dc5da12a9._msdcs.mydomain.net.au
to:
LDAP/b2494b16-99e1-493b-b95f-f54acb3c86fe._msdcs.mydomain.net.au




? what utility to use ? step-by-step?
i think we can use ldp.exe or ADSIedit.msc

with ldp.exe, i dont know exactly how to do it
with ADSIedit, when i run it, i have an error:" snap-in failed to initialized, Name - not available...."
here are some more info:

I am trouble shooting the Active Replication problem between DCs on Windows 2000 SP4 environment.

Here is the background :

I have all DCs are Windows 2000 Server SP4
at Head office, we have 3 DCs : DC1, DC2, DC3 they are replicating with each other fine.
at  2 remote sites, DCs did not replicate its Active directory database back to Head office at all.

at Remote site 1 we have R-DC1
at Remote site 2 we have R-DC2

here is what i found out on R-DC1



when i run dcdiag on R-DC1



C:\Support Tools>setspn -L DC1
Registered ServicePrincipalNames for CN=DC1,OU=Domain Controllers,DC=mydomain,DC=net,DC=au:
    E3514235-4B06-11D1-AB04-00C04FC2DCD2/b2494b16-99e1-493b-b95f-f54acb3c86fe/mydomain.net.au

    LDAP/14e0463a-0489-47c2-b25a-245dc5da12a9._msdcs.mydomain.net.au -----> this is WRONG

i need to change it to :

LDAP/b2494b16-99e1-493b-b95f-f54acb3c86fe._msdcs.mydomain.net.au

My question is : how do i change it ?
what utility do i need to use ? and how do you do it, step by step ?

i think my ActiveReplication problem is i have a wong LDAP record for DC1
that why when i run dcdiag on R-DC1, i have this error:

[Replications Check,R-DC1] A recent replication attempt failed:
    From DC1 to R-DC1
    Naming Context: DC=mydomain,DC=net,DC=au
    The replication generated an error (8524):
    Win32 Error 8524
    The failure occurred at 2008-04-12 06:53.15.
    The last success occurred at 2008-03-31 21:49.07.
    576 failures have occurred since the last success.
    The guid-based DNS name 14e0463a-0489-47c2-b25a-245dc5da12a9._msdcs.mydomainnet.au is not registered on one or more DNS servers.

that is why i wanted to change this 14e0463a-0489-47c2-b25a-245dc5da12a9._msdcs.mydomainnet.au
to this correct one : b2494b16-99e1-493b-b95f-f54acb3c86fe._msdcs.mydomain.net.au

i updated DNS record, it doesnt update the LDAP record accordingly

what would you do to fix this Active Directory replication problem for R-DC1 ?
does it make sense to you to tackle the problem that way ?
thanks
i will update more info if needed.

on R-DC1 and R-DC2 i have these Event ID logs:

Event ID : 1265, Source : NTDS KCC

The attempt to establish a replication link with parameters
 
 Partition: DC=mydomainDC=net,DC=au
 Source DSA DN: CN=NTDS Settings,CN=R-DC21,CN=Servers,CN=Sydney,CN=Sites,CN=Configuration,DC=sca01,DC=mydomain,DC=net,DC=au
 Source DSA Address: 5688e0c7-b8bc-4a5d-b0b6-d1d6aa26c084._msdcs.mydomain.net.au
 Inter-site Transport (if any): CN=IP,CN=Inter-Site Transports,CN=Sites,CN=Configuration,DC=mydomain,DC=net,DC=au
 
 failed with the following status:
 
 Logon failure: unknown user name or bad password.
 
 The record data is the status code.  This operation will be retried.

and Event ID 1311, source : NTDS KCC:

The Directory Service consistency checker has determined that either (a) there is not enough physical connectivity published via the Active Directory Sites and Services Manager to create a spanning tree connecting all the sites containing the Partition .......









   










ASKER CERTIFIED SOLUTION
Chris Dent
PowerShell Developer
Join our community to see this answer!
Unlock 1 Answer and 11 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 11 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros