Link to home
Create AccountLog in
Avatar of lawaxa
lawaxa

asked on

Internet Connection Problems after Mac OS X Upgrade to 10.4.11

I recently upgraded my iMac to Mac OS X 10.4.11.  As a part of the upgrade package, Safari has also been upgraded to version 3.0.4.  Ever since the upgrade, Safari cannot to the Internet anymore.  The iMac cannot connect to Apples Software Upgrade web site either.  My iTune also has become a victim and it now cannot connect to the iTune Store and I cannot download podcasts or music any longer.

The only browser that can still connect to the Internet is Firefox.  I tried Opera and it didnt work either.
I would like to make my iMac able to connect to the Internet again via Safari and iTune.  Any suggestions would be appreciated.  Thank you.
Avatar of strung
strung
Flag of Canada image

If you updated using software updates, then download and install the standalone combo updater instead:

Combo update for Intel Macs:

http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx10411comboupdateintel.html

Combo update for PPC Macs:

http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx10411comboupdateppc.html
Before doing the above, do a spotlight search for Piclens if you have such a file in a folder called InputManagers, delete the file. That should fix your problem.
Avatar of lawaxa
lawaxa

ASKER

I did a spotlight search for piclens but didn't find anything.  It doesn't even seem to have a folder called InputManagers.

Following your link, I downloaded the combo update for PPC Macs since my iMac is PowerPC G5.  Now, my question is this: "Do I just unpack the combo package and let it overwrite everything?"
Yes. That is what you do. Then re-run Software Update.

There may be another input manager causing the problem.

There should be an InputManagers folder in the Library folder at the root of your hard drive. See if it has anything in it.

There will be another InputManagers folder in the Library folder inside your Home folder.
Avatar of lawaxa

ASKER

Ok, I unpackaged the combo updater and ran Software Update.  After the update, I rebooted the machine.  Unfortunately, however, Safari still cannot connect to the Internet and neither iTune.

I looked into the Library folder at the root of my hard drive, and I did not see any inputManagers.  I also looked into the Library folder under my Home directory and did not find it there either.
You mean there was no InputManagers folders, or the folders were there but they were empty?
Avatar of lawaxa

ASKER

There are no inputManagers folders at all in the Library -- both under the root directory and Home directory.  

That's strange. I am running out of ideas. Problems of the type you have have historically been related to out of date plugins or add ons to Safari found in the InputManagers
Try this:

Go to Spotlight and search for InputManager"

The search will come up blank. Click on Show All

In the resultant window click on File Name instead of Contents. The search will still be blank.

Now click on the plus button on the far right of the Window. This will bring up a new line which has a TYPE button.

Click on TYPE and change it to OTHER. In the box that comes up, scroll down to SYSTEM FILES, and check the Tick box.

Now when you click on TYPE again, you should get an option in the pop up menu for SYSTEM FILES. Click on it. In the right hand box change "don't include" to "include".

If you have and InputManagers folders, they should now appear.

Also search for "piclens" using the same settings.
Oops! I am not sure that the instructions I gave you above work in Tiger. They may be Leopard only
Avatar of lawaxa

ASKER

I don't see the Show All option in my search dialog box.
Sorry, at this point I am about out of ideas. I am really surprised that there is no InputManagers folder in the Library Folder at the root of your hard drive (not the Library folder inside the System Folder).
Avatar of lawaxa

ASKER

Yes, I am looking into Macintosh HD > Library, not the System folder.  There is no inputManagers folder.

Anyway, thank you so much for all your time and efforts trying to help me out with this problem.  I really appreciate your efforts.  Thank you again.
Close Safari (if Open)
Go to /<User>/Library/Preferences and delete "com.apple.Safari.plist"
Reopen Safari.

In your Network settings (Sytem Preferences), make sure "Proxies" are NOT enabled for you internet connection.

If that doesn't work try:

Try repairing permissions (Utilities/Disk Utility) prior to performing the Combo Update.


Actually, I'd try looking at the Network Setting FIRST ... if that works they'll be no need to reset Safari.

Avatar of lawaxa

ASKER

Hi, thank you for checking into this problem.

In the Network settings, We Proxy (HTTP) was checked.  I unchecked the check box and restarted Safari but it didn't help.  Safari still cannot connect to the Internet.

Next, I went into the Home directory/Library/Preferences and deleted "com.apple.safari.plist" and restarted Safari.  This did not help either.

Next, I went into the Utility > Disk Utility and then performed "Repair Disk Permissions" on Macintosh HD.  Safari still cannot connect to the Internet.

You don't by any chance have software called SpeedDownload installed? If so, try uninstalling it using the uninstaller.
Avatar of lawaxa

ASKER

Hi Strung,

No I don't have SpeedDownload installed on my iMac.  Just to double-check, I did a spotlight search in Applications but it didn't find anything with that name.
ASKER CERTIFIED SOLUTION
Avatar of mmconsultant
mmconsultant
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
After checking ALL the proxy settings, I'd restart and check again to make sure the changes stuck.
Avatar of lawaxa

ASKER

Wow, that was it!    Now my Safari and iTune can connect to the Internet!

As you stated, mmconsultant, it was the Proxy settings that had been blocking the Internet access.  The OS X 10.4.11 Upgrade must have changed the settings on its own.

Thank you so much for solving this problem!

Glad to help!