Avatar of tomtcs
Flag for United States of America asked on

Cannot get RPC over HTTPS to work to new setup. Seperate DC and Exchange 2003 Member Server.

Monowall Firewall In place with an internal network of 192.168.x.x address scheme
Ports 443 and 80 Forwarded to the Exchange Server for OWA and RPC
Exchange Server 2003 Running SP2
Windows 2003 Server R2 SP2 running on both DC and Exchange
RPC Over HTTP installed on the exchange server only

I used to have a setup of a single Exchange 2003 and Server 2003 DC all on one box doing RPC over HTTPS and it seemingly worked fine for months.  Since then i have added a new server and completely re-configured the network to be a seperate domain controller and seperate Exchange 2003 server.  Now I'm experiencing problems getting RPC over HTTP to work. Here's what I've done so far.

Started to go through this guide as I used it in the past for the single domain controller and Exchange server and the guide worked flawlessly:  http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm

Now, I've looked at this guid to modify the configuration to allow for the second server (the seperate DC): http://www.amset.info/exchange/rpc-http-server.asp

To no avail does it work.  When i run Outlook /rpcdiag i get only three lstings instead of the normal 5 or 6 that i get when i connect via the VPN (temporarily till RPC is fixed).
I only get three listings for Directory services, but never for mail services.  It looks like it tries to connect but the line appears then disappears too fast that i can't even read what its saying.  

Ive navigated to my external Exchange Website and that works just fine.  Also checked the Https://mail.mydomain/rpc and i get prompted for username /pass and i input them and i get a directory listing not valid, but no prompts about certificate errors, so that seems to work just fine.

Any other information I'm missing please feel free to ask.  Thanks for all your help!
ExchangeWindows Server 2003Hardware Firewalls

Avatar of undefined
Last Comment

8/22/2022 - Mon

you should have SSL certificate on both rpc-http backend and front end .Also you must open all ports between the exchange 2003 front end box and the external firewall as you did before.
try again and post your findinds.

In this case, i'm not using a front end and back-end as I only have one instance of an Exchange server.  All the ports are open as before and rerouted to the new Exchange server internal IP address.

Where would i install the certificate, as i have IIS disabled on the Domain controller.

View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.

After playing around with it, i HAVE NO IDEA...but all the sudden it works now.  Not a clue what i did to fix it, other then restarting both servers.  (which im not sure if that has anything to do with it since i performed the registry changes).  But all is good now. Ill have my clients reconfigure their outlook clients to use the HTTP connection again instead of VPN.  Thanks for your help!
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck