troubleshooting Question

Cisco 1841 ADSL Configuration

Avatar of espoke
espoke asked on
RoutersNetworking Hardware-Other
4 Comments1 Solution6736 ViewsLast Modified:
Dear Experts,

I have an urgent question regarding a Cisco 1841 I am trying to configure. It is causing me PROBLEMS.

Firstly can someone tell me how to remove the 'shutdown' command within the interfaces. I want them to be active!

I have the below configuration. Can you tell me if it looks correct?

I want the router to connect to our ADSL connection
Act as a DHCP server on the 192.168.0.x range

That is all.  

The Router only has one WIC card installed in Slot 0 and only FastEthernet 0/0 needs to be used.

At present the router doesn't seem to be connecting to the ADSL connection and the interface cards seem to be disabled.  

Your help would really be appreciated as it is driving me nuts! I am currently logged into the router using HyperTerminal.

Pete



Current configuration : 3571 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname office
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.11 192.168.0.5 192.168.0.6
!
ip dhcp pool FDN Office
   import all
   network 192.168.0.0 255.255.255.0
   dns-server 192.168.0.1 
   default-router 192.168.0.10
!         
!         
ip name-server 85.189.102.5
ip name-server 85.189.39.5
!         
multilink bundle-name authenticated
!         
!         
!         
!         
username admin privilege 15 secret 5 $1$vVXZ$qlaYQ6QOrYDlcFWZlNTF1.
!         
!         
track 1 interface ATM0/0/0 line-protocol
!         
!         
!         
!         
!         
interface FastEthernet0/0
 description Connection to Office Switch
 ip address 192.168.0.10 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 no ip address
 ip nat outside
 ip virtual-reassembly 
 duplex auto
 speed auto
 no cdp enable
!         
interface ATM0/0/0
 description ADSL connection to Exa
 no ip address
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 no atm ilmi-keepalive
 dsl operating-mode auto 
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1       
!         
interface Dialer0
 no ip address
 no cdp enable
!         
interface Dialer1
 description PPP for ATM0/0/0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
 dialer persistent
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname y5mq-r32a@tdl.broadband
 ppp chap password 0 xxxxxx
!         
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
!         
!         
ip http server
ip http port 8080
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip dns server
!         
access-list 15 permit 192.168.0.0 0.0.0.255
no cdp run
!              
route-map line1 permit 10
 match ip address 15
 match interface Dialer1
!         
!         
!         
control-plane
!         
!         
line con 0
line aux 0
 login local
 transport output none
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
 transport output none
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
 transport output none
!         
scheduler allocate 20000 1000
end
ASKER CERTIFIED SOLUTION
jjmartineziii

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Join our community to see this answer!
Unlock 1 Answer and 4 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros