Avatar of cmsJustin
cmsJustin asked on

Cisco VPN working, but needs internet access and hairpinning

I've been working on setting up a VPN for the laptop users at our company. The VPN works, except for 2 things:

1) Users need to be able to access the internet. I don't want to enable split-tunneling; I want them to access the internet from our connection, not their own.

2) We have a network set up for our conference rooms (Ethernet0/2, dmz, 10.10.10.0/24). I'd like users to be able to VPN back into our "inside" network from this subnet.

I've been searching the internet for a few days and also picking the brain of a Cisco guy at one of our consulting firms, but can't come up with anything. Anyone have a working config of this that they can share?
interface Ethernet0/0
 nameif outside
 security-level 0
 ip address [hidden]
 
interface Ethernet0/1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.248.0
 
interface Ethernet0/2
 nameif dmz
 security-level 50
 ip address 10.10.10.1 255.255.255.0
 
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_20_cryptomap extended permit ip 192.168.0.0 255.255.248.0 192.168.10.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.248.0 192.168.10.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 10.0.0.4 255.255.255.254
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.248.0 192.168.0.0 255.255.248.0
 
icmp unreachable rate-limit 1 burst-size 1
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 1 0.0.0.0 0.0.0.0
access-group inbound in interface outside
route outside 0.0.0.0 0.0.0.0 [hidden] 255
 
aaa-server DOMAIN protocol radius
aaa-server DOMAIN host 192.168.1.64
 timeout 5
 key 12345678911234567892123456789312
 radius-common-pw 12345678911234567892123456789312
 
group-policy DefaultRAGroup internal
group-policy DefaultRAGroup attributes
 wins-server value 192.168.1.61 192.168.1.62
 dns-server value 192.168.1.61 192.168.1.62
 vpn-tunnel-protocol l2tp-ipsec
 default-domain value DOMAIN
 
group-policy Laptops internal
group-policy Laptops attributes
 wins-server value 192.168.1.61 192.168.1.62
 dns-server value 192.168.1.61 192.168.1.62
 vpn-tunnel-protocol IPSec
 default-domain value DOMAIN
 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
 
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs
crypto dynamic-map outside_dyn_map 40 set transform-set TRANS_ESP_3DES_SHA
 
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer [hidden]
crypto map outside_map 20 set transform-set ESP-AES-256-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
 
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption aes-256
 hash sha
 group 5
 lifetime 86400
crypto isakmp policy 30
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  3600
 
tunnel-group DefaultRAGroup general-attributes
 authentication-server-group DOMAIN
 dhcp-server 192.168.1.61
tunnel-group DefaultRAGroup ipsec-attributes
 pre-shared-key *
tunnel-group DefaultRAGroup ppp-attributes
 no authentication chap
 no authentication ms-chap-v1
 authentication ms-chap-v2
 
tunnel-group [hidden] type ipsec-l2l
tunnel-group [hidden] ipsec-attributes
 pre-shared-key *
 
tunnel-group [hidden] type ipsec-l2l
tunnel-group [hidden] ipsec-attributes
 pre-shared-key *
 
tunnel-group Laptops type ipsec-ra
tunnel-group Laptops general-attributes
 authentication-server-group DOMAIN
 default-group-policy Laptops
 dhcp-server 192.168.1.61
tunnel-group Laptops ipsec-attributes
 pre-shared-key *
 
no vpn-addr-assign aaa
no vpn-addr-assign local

Open in new window

VPNCiscoInternet Protocol Security

Avatar of undefined
Last Comment
cmsJustin

8/22/2022 - Mon
ASKER
cmsJustin

Here's the log from the Cisco VPN client:
Cisco Systems VPN Client Version 5.0.03.0530
Copyright (C) 1998-2007 Cisco Systems, Inc. All Rights Reserved.
Client Type(s): Windows, WinNT
Running on: 5.1.2600 Service Pack 2
Config file directory: C:\Program Files\Cisco Systems\VPN Client\
 
1      13:38:39.015  05/21/08  Sev=Warning/2	CVPND/0xE3400013
AddRoute failed to add a route: code 87
	Destination	10.0.0.255 (<-- local network broadcast?)
	Netmask	255.255.255.255
	Gateway	192.168.7.115
	Interface	192.168.7.115
 
2      13:38:39.015  05/21/08  Sev=Warning/2	CM/0xA3100024
Unable to add route. Network: c0a800ff, Netmask: ffffffff, Interface: ada0773, Gateway: ada0773.

Open in new window

mapilch

try to add:

nat (outside) 1 [your vpn address pool and netmask]

[and inside desired tunnel-group attributes add]

split-tunnel-policy tunnelall


Here are details from Cisco (Document ID: 67986) http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a00805734ae.shtml
ASKER
cmsJustin

The address pool comes from our DHCP server, the same one we use for work. Would this command cause an issue with the machines on our network?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
ASKER CERTIFIED SOLUTION
mapilch

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
cmsJustin

I got the internet working through VPN (by luck probably). I moved the VPN IP pool to its own subnet, and ran the following commands. Then to get it working from within the DMZ with the same connection on the client, I added a backup server on the client. So it takes like 5 seconds to timeout and then goes to the DMZ.
ip local pool Laptops 192.168.254.1-192.168.254.254 mask 255.255.255.0
nat (outside) 1 192.168.254.0 255.255.255.0
crypto dynamic-map outside_dyn_map 20 set reverse-route
access-list inside_nat0_outbound extended permit ip any 192.168.254.0 255.255.255.0 
access-list outside_nat0_outbound extended permit ip 192.168.254.0 255.255.255.0 any
group-policy Laptops attributes
    split-tunnel-policy tunnelall
tunnel-group Laptops general-attributes
    address-pool Laptops
crypto map outside_map interface dmz
crypto isakmp enable dmz

Open in new window