troubleshooting Question

RewriteCond not working in httpd.conf

Avatar of hankknight
hankknightFlag for Canada asked on
Apache Web Server
3 Comments1 Solution1365 ViewsLast Modified:
This works when I place it in my .htaccess file:
       Options +FollowSymlinks
       RewriteEngine On
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteRule ^(.*) index.php

However when I add the following (attached) to my http.conf file EVERYTHING is re-written to index.php.

I only want the URL to be re-written if the file or directory does NOT exist.
NameVirtualHost 22.222.222.222:80
<VirtualHost example.org:80>
	ServerName example.org
	ServerAlias *.example.org
	 Options +FollowSymlinks
	 RewriteEngine On
	 RewriteCond %{REQUEST_FILENAME} !-f
	 RewriteCond %{REQUEST_FILENAME} !-d
	 RewriteRule ^(.*) /index.php
	ServerAdmin webmaster@example.com
	DocumentRoot /home/example.org/html/
	ErrorLog logs/example.org-error_log
	CustomLog logs/example.org-access_log common
</VirtualHost>
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 3 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 3 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros