Avatar of ajw_93
ajw_93Flag for United States of America asked on

Contribute Does Not Render Style Sheet in Edit Mode

We have numerous editors on Adobe Contribute 3 and 4.  For some reason, those with Cont. 4 who are using a Key other than "Administrator" (that is, their use is restricted to relevant directories) are able to successfully edit the proper pages, but the Edit mode does not render our stylesheet properly!  Could this be a permissions problem on the web server?  The stylesheet is linked inside a cfinclude in the main template.

Thoughts?!  Thanks!
Web Development

Avatar of undefined
Last Comment
ajw_93

8/22/2022 - Mon
Jason C. Levine

Hi ajw_93,

Older versions of Contribute have problems with includes.  Is the cfinclude statement using a relative or absolute path?
ASKER
ajw_93

A relative path.  It is inside the DWT template.
ASKER CERTIFIED SOLUTION
Jason C. Levine

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
ajw_93

Hmm, neither of these seems to work.  We still have the same issue of Cont. not rendering the style sheets properly in Edit mode.  When I created a new template to test these changes out, Contribute does not download the new template even though it is stored in the Templates folder on the server.  Again, users with an "Admin" key (all permissions) have no problems; users with any sort of group-restricted key have this problem.  Does anyone besides me believe it is a permissions issue?  I am quite new to Contribute and I believe we have an Apache server which I also know virtually nothing about.  Thanks!!
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
Jason C. Levine

Definitely not an apace problem.

It shouldn't be a permissions issue unless the CSS or some other, necessary, include has been placed somewhere that
you've told Contribute is off-limits to the lower user.  Alternately, check the role definition to see if styles are enabled...
ASKER
ajw_93

Jason, thanks for the suggestion.  I changed to absolute path in the wrong place but when I did it correctly, it worked beautifully!  Our problem is solved!  Thanks again.