Avatar of nugentgl
nugentglFlag for United States of America asked on

Robocopy Not Copying File Level Permissions...HELP

I have been using Robocopy for years and recently upgraded to the latest one from the 2k3 res kit.  Anyway, I noticed a very strange problem.  When I use the following command:

source destination     /copyall /s /v /r:1 /w:1 /eta /mir /log:log.log

It will copy all the NTFS permissions for all the folders in the tree but none of the files.  Is my command line incorrect?

Windows Server 2003

Avatar of undefined
Last Comment
nugentgl

8/22/2022 - Mon
Irwin W.

I always include the switch /sec to make sure I am copying NTFS security have you tried that?
ASKER
nugentgl

Thanks for the quick reply, but according to the documentation /copyall includes /sec.

ASKER CERTIFIED SOLUTION
jrittenh

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
nugentgl

BINGO!

The files were already there.  Is there a way to force the replacement of permissions?

I am in a very typical domain with a top level folder and subfolders below it.  And the files are both in the root directory and subdirectories.  Basically all files are not updated with the correct NTFS permissions, whereas, all the folders are.

Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
jrittenh

Shift-3's suggestion to use /is is correct.  The Robocopy documentation mentions this scenario specifically:

"To refresh security information for existing destination files and directories without copying file data, use the /IS switch together with the /COPY switch without the D flag. For example /IS /COPY:SOU would refresh all security information for all selected files, without copying any file data."

I would suggest running a batch script to run your first command and then run it again with /is /copy:sou to get both data and security.
ASKER
nugentgl

That did the trick.  Very annoying that if the file already exists you have to do a refresh after you mirror the files for the last time before going live with the new location.