Avatar of Lexie
LexieFlag for Zambia asked on

Server can ping to workstation but not connect with windows explorer

I am a database developer (currently working as a volunteer computer expert in Zambia), so I do not have much system administrator skills. Installing the server based Kasperksy anti-virus I ran into the problem that the server cannot connect to a workstation in order to copy some files to the workstation.

The server has Windows Server 2003 installed, and is acting as a File Server, Domain Controller and DNS Server. So it has Active Directory on it installed. The firewall is disabled. The workstations are not part of the domain, they use a username/password (in AD) to map a drive on the server.

When I open windows explorer and give the address \\192.168.1.6\ I get the error "Windows Cannot find '\\192.168.1.6\'. Check the spelling and try again, or try searching for the item by clicking the start button and then clicking Search." However, when I open the command prompt I can ping to 192.168.1.6 without a problem. Also the workstation has no problem seeing the server directorry.

When I do the same on my laptop (open windowd explorer and give the address) then I am asked to provide a username and password and then I can see the direcories on that workstation. So it looks like to workstation is open for the outside world.

What do I need to do such that the server can access the workstation's folder  \192.168.1.6\admin? I would rather not add all the workstations to the domain, but I would still like to use the server as a file server. But the anti-virus is more important. The server is not operationel yet, I am just testing with it.
Anti-Virus AppsWindows Server 2003Microsoft Server OS

Avatar of undefined
Last Comment
Lexie

8/22/2022 - Mon
Brian Pierce

If from the RUN command on the start menu you enter
\\192.168.1.6\c$

are you prompted for a username/password ?
Brian Pierce

Have you actually shared a folder to connect to from the server ?
ASKER
Lexie

If I do the run command \\192.168.1.6\c$ or \\192.168.1.6\admin$ then I get the error message: "The network location cannot be reached. For information about network troubleshooting, see windows help".  If I do this from my laptop than I am asked to provide a username/password and I can access both admin$ and c$. There are shared folders on the workstation.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Brian Pierce

c$ and Admin$ are adminstrative shares tou should really share folders properly and set the correct share and NTFS permissions.

That aside, what is the IP address/mask on the computer you are trying to connect from?
Check that its valid for the network.
ASKER
Lexie

Server IP adress 192.168.1.137 (Subnet Mask 255.255.255.0, Gateway 192.168.1.1)
Workstation IP adress 192.168.1.6 (Subnet Mask 255.255.255.0, Gateway 192.168.1.1)
My Laptop IP adress 192.168.1.235 (Subnet Mask 255.255.255.0, Gateway 192.168.1.1)

I checked the shares on the workstation:
C:\ = sharename = c$ [permissions can not be set]
C:\windows = sharename = admin$ [permissions can not be set]

I can ping fro the server, laptop and workstation to the others without any problem, so it seems the network connects them all.
Brian Pierce

No you cannot set the permission on an administative share - but you should not be connectiing to these - you should be setting up user shares

Go to a folder, right click on it and select Sharing, share the folder and set the permissions to Everyone, Full Control.

The right click on the folder and select security and set Everyone, Full control

Thats realy a side issue though...

Try the suggestions here: https://www.experts-exchange.com/Networking/Protocols/Q_22734266.html
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
Lexie

Nope, I tried (again) to make a user-made share C:\Kaspersky with full control to everybody (but read would be enough). Again, my laptop can access it but the server still gets the same error message. However, for Kaspersky I need to be able to access the ADMIN$ share. So I have to connect to a system share, for sure.

From my point of view the problem is somewhere at the server, not at the workstation because I have all the access to the workstation using my laptop.  I think it has to do with may be the server being a domain controller or DNS Server, and that the workstation is not part of the domain.
Brian Pierce

Being a DC or DNS server would not in itself make any difference to accessing a share. Have you double checked that the firewall on the DC is off (or at least configured to allow file and print sharing)
ASKER
Lexie

Yes, the windows firewall is turned off on the server, just checked it again.

The workstation can access the server, I have a script there to map the drives on the server:

ECHO OFF

NET USE U: /DELETE
NET USE X: /DELETE
NET USE Y: /DELETE

NET USE U: \\192.168.1.137\Lex <pwd> /USER:<username>@diocese.com
NET USE X: \\192.168.1.137\IAP\Applications <pwd> /USER:<username>@diocese.com
NET USE Y: \\192.168.1.137\IAP\Projects <pwd> /USER:<username>@diocese.com

So incoming requests from a workstation are not a problem, it is the server that cannot see the workstation's directories.  
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
ChiefIT

@KCTS:
Internet Explorer Enhanced Security?
Brian Pierce

Is the firewall on the workstation off  (or at least configured to allow file and print sharing)
ASKER
Lexie

Yes, the firewell of the workstation is turned off. I also turned off the Internet Explorer Enhanced Security on the server.

Isn't it a problem that the workstation is part of a workgroup?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Lexie

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question