Avatar of Ship2Save
Ship2Save asked on

PIX 501: Unable to forward ports.

Hi,

I have been trying to configure the Cisco PIX 501 for the past couple of days to redirect a few ports and have been unsuccessful so far.

I have two machines which act as the following:

192.168.2.12 = Exchange
192.168.2.13 = Webserver, FTP, SQL Server, DNS

Thus I have the following services which need to be redirected accordingly:

SMTP      TCP      25      192.168.2.12
POP      TCP      110      192.168.2.12
IMAP      TCP      143      192.168.2.12
HTTPS      TCP      443      192.168.2.12

FTP      TCP      21      192.168.2.13
HTTP      TCP      80      192.168.2.13
DNS      UDP      53      192.168.2.13
SQL      TCP      1435      192.168.2.13

Below is the PIX configuration.

I am not sure what else I'm missing. Please, any help would be highly appreciated.

Thanks.
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group service 12-TCP tcp 
  port-object range imap4 imap4 
  port-object eq pop3 
  port-object eq https 
  port-object eq smtp 
object-group service 13-TCP tcp 
  port-object eq www 
  port-object range 1435 1435 
  port-object eq ftp 
object-group service 13-UDP udp 
  port-object eq domain 
access-list outside_access_in permit tcp any any object-group 12-TCP 
access-list outside_access_in permit tcp any any object-group 13-TCP 
access-list outside_access_in permit udp any any object-group 13-UDP 
access-list outside_access_in permit tcp any any 
access-list outside_access_in permit icmp any any 
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.2.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.2.13 255.255.255.255 inside
pdm location 192.168.2.12 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) udp 76.65.246.142 domain 192.168.2.13 domain netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 www 192.168.2.13 www netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 ftp 192.168.2.13 ftp netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 1435 192.168.2.13 1435 netmask 255.255.255.255 0 0 
static (inside,outside) tcp 75.65.246.142 https 192.168.2.12 https netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 smtp 192.168.2.12 smtp netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 pop3 192.168.2.12 pop3 netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 imap4 192.168.2.12 imap4 netmask 255.255.255.255 0 0 
access-group outside_access_in in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname XXXXX
vpdn group pppoe_group ppp authentication pap
vpdn username XXXXX password ********* store-local
dhcpd address 192.168.2.2-192.168.2.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:ab3f132f99917a6974cf6f514e026ce7
: end
[OK]

Open in new window

Cisco

Avatar of undefined
Last Comment
Ship2Save

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
batry_boy

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
Ship2Save

Hi batry_boy,

Thanks for the suggestion. Unfortunately, that did not help.

After digging into the logs, it seems like that the DNS port 53 is being blocked by the access group outside_access_in. I do not understand why because I don't have any denial permissions on that port.

Would you happen to have any ideas?

Thanks.
batry_boy

Can you post the logs?  Do you host your own DNS such that the world performs lookups against your DNS server to resolve hostnames within your domain name?
ASKER
Ship2Save

Hi batry_boy,

It seems like your initial suggestion has resolved the issue (and created another one which I will mention at the end of my post). There was an error on my part where I was testing internally as opposed to externally. This however never caused a problem with our old router, Linksys RV042.

As for your question, yes I am hosting my own DNS to resolve hostnames within my domain name.

Regarding the new issue, all of the services appear to work fine (ie http, https, dns, ftp) except for emails. I can receive external emails but not send to external domains. Additionally, all internal emails can be sent and received successfully. I've tried the "no fixup protocol smtp 25" command but that didn't help.

Does this issue warrant a new thread or can it be continued here?
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
batry_boy

Are you performing any outbound filtering?  What does your current config look like?  Post it and I'll have a look...
ASKER
Ship2Save

Here you go, batry_boy. I don't believe I am performing any outbound filtering.

Thanks.
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
no fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group service 12-TCP tcp 
  port-object range imap4 imap4 
  port-object eq pop3 
  port-object eq https 
  port-object eq smtp 
object-group service 13-TCP tcp 
  port-object eq www 
  port-object range 1435 1435 
  port-object eq ftp 
object-group service 13-UDP udp 
  port-object eq domain 
access-list outside_access_in permit tcp any any object-group 13-TCP 
access-list outside_access_in permit tcp any any object-group 12-TCP 
access-list outside_access_in permit tcp any any 
access-list outside_access_in permit icmp any any 
access-list outside_access_in permit udp any any eq domain 
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.2.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location 192.168.2.13 255.255.255.255 inside
pdm location 192.168.2.12 255.255.255.255 inside
pdm location 76.65.246.142 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) udp 76.65.246.142 domain 192.168.2.13 domain netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 www 192.168.2.13 www netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 ftp 192.168.2.13 ftp netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 1435 192.168.2.13 1435 netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 https 192.168.2.12 https netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 smtp 192.168.2.12 smtp netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 pop3 192.168.2.12 pop3 netmask 255.255.255.255 0 0 
static (inside,outside) tcp 76.65.246.142 imap4 192.168.2.12 imap4 netmask 255.255.255.255 0 0 
access-group outside_access_in in interface outside
route inside 192.168.2.1 255.255.255.255 192.168.2.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server TACACS+ max-failed-attempts 3 
aaa-server TACACS+ deadtime 10 
aaa-server RADIUS protocol radius 
aaa-server RADIUS max-failed-attempts 3 
aaa-server RADIUS deadtime 10 
aaa-server LOCAL protocol local 
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname *****
vpdn group pppoe_group ppp authentication pap
vpdn username ***** password ********* store-local
dhcpd address 192.168.2.2-192.168.2.254 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:3637474bd4d492715721f7523f7769df
: end
[OK]

Open in new window

batry_boy

I don't see any reason why it should not be working, unless it is because you are not using the keyword "interface" when implementing the port redirection syntax of the "static" commands for your traffic.  My initial post had you remove the actual public IP address reference that you obtain through PPPoE and replace it with the keyword "interface".  Have you tried that?
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
Ship2Save

Hi batry_boy,

I did replace the public IP address with the keyword "interface". It seems like the PIX translated the interface to the public IP address?

Also, I resolved the email issue. It was related to Exchange; not PIX. An invalid entry was specified for the external DNS lookup server on the Exchange server.

However the implemention of the PIX has spawned two new issues:

1) Hotmail appears to be rejecting emails from my domain and gives me the following bounce-back message: #"550 OU-002 Mail rejected by Windows Live Hotmail for policy reasons." I have had the same issue before and it was resolved after creating an SPF record. Now it seems to have resurfaced.

2) I am unable to perform any nslookup queries. All DNS requests to external domains (google.com, microsoft.com) timeout.

Thanks.
ASKER
Ship2Save

I was able to resolve the nslookup issue. There was an invalid forwarder entry in our internal DNS server. As for the Hotmail issue, I will start another thread as it seems unrelated to the PIX.

Thanks a lot for your assistance and seeing me through this issue, batry_boy.