Avatar of the_sleeper
the_sleeperFlag for United States of America asked on

Telnet: Unable to connect on localhost with IIS 5.1 XP Pro

I have set-up the SMTP service on my local development machine  running WinXP Pro, SP3, VS2008, IIS 5.1.

1. I can see the service running in services
2. I can stop and restart the service
3.  I cannot however connect to the server using telnet

Debug efforts:
1. I have McAfee Security Center running so I opened up the smtp port: No change.
2. I disabled McAfee completely: No Change.
3. I checked to see if Comcast has telnet blocked. Telnet to remote server: Successful
4. I've tried using IP address i.e. "telnet 123.4.5.6 25" (25 being the port number, and no quotes): Nothing
5. I've tried using 127.0.0.1 25: Nada, zip. zilch.

OK I give up. Little help?
Windows XPMicrosoft IIS Web Server

Avatar of undefined
Last Comment
Hank_74

8/22/2022 - Mon
Hank_74

Ok this may be a stupid question but did you type the IP address like this 123.4.5.6 25 or like this 123.4.5.6 port25?
ASKER
the_sleeper

No, I type 123.4.5.6 25 (no port)
Hank_74

try the port
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
ASKER
the_sleeper

error message reads (in part) "failed on port: port25".
Hank_74

Are you accessing this from outside your network or are both systems internal. Seeing that you've contacted Comcast than I'm guessing the answer is no.

Is this system behind a fire wall or router?
ASKER
the_sleeper

firewall disabled. yes I have a router, but telnet got out to remote server
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
SOLUTION
Hank_74

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
the_sleeper

Ok,

Based on your comments, Here's what I did:

1. I went into my Lynksys router and set-up port forwarding for SMTP like so...

Name: COMM
Ext. Port: 25
Protocol:  TCP
IP Addy: 123.4.5.6
Enable: "Checked"

2. Enabled SMTP Service in the firewall then tried to connect via telnet: Nothing - "Unable to connect"
3. Completely disabled McAfee then tried to connect via telnet: Nothing - "Unable to connect"

...i don't get it?
ASKER
the_sleeper

Bear in mind there is NO server...

I am running Microsoft, Internet Information Server (IIS), 5.1, WinXP Pro Sevice Pack 3 and using (learning) VS 2008 to build web applications locally, I need test smtp (which is what got me here).
Hank_74

Sorry brother I'm stumped. However I did find this about comcast you may want to read it.

http://www.christopherprice.net/comcast-blocking-port-25-without-notice-331.html
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
younghv

What happens if you insert a ":" before the "25"?
telnet 123.4.5.6 :25
Hank_74

I tested that but never got it to work. I did some research and came up with the port25 but try it. I have used ":" to get into other apps and ports but mostly when accessing the though a browser.
ASKER CERTIFIED SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
younghv

You can also try:
telnet FQDN 25

or

telnet actualservername 25
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
the_sleeper

Guess what, Bad IIS install.

I took a look in
 Administrative Tools >  Internet information Services

and there was no reference to "Default SMTP Virtual Server" listed.

Tried un+re-installing SMTP Service: Still did not show

Finally, Un+Re-Installed IIS and SUCCESS!
ASKER
the_sleeper

Points for hangin in there :-> Thanks for all your help!
Hank_74

Good deal and thanks. I am sorry however that I couldn't be more help.
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck