Remote administration (free Terminal Services) not working

I noticed today that one 2003 server is not allowing anyone to connect via Terminal Services Remote Administration.  It's the free one enabled by clicking "Enable Remote Desktop on this computer" on the Remote tab of System Properties.

This server was a Windows 2000 upgrade and it looks like the Terminal Services portion was "missed" in the upgrade.  The Terminal Services service pointed to "%systemroot%\system32\termsvcs.exe" like in Windows 2000 whereas all of my other 2003 servers point to: %systemroot%\system32\svchost.exe -k termsvcs.

The file termsvcs.exe no longer exists in 2003 and the service gave a corresponding message as such when the service was attempted to be started, resulting in failure and the service not running.

Being a hack, I changed the path to the executable in the registry to be the same as other 2003 servers.

Changed in HKLM/System/CurrentControlSet/Services/TermService and the other control sets.

I also had to add termsvcs to the svchost key at HKLM/Software/Microsoft/Windows NT/Current Version/Svchost and to the folder below.

I did all that, rebooted, and still doesn't come up.  I get "The Terminal Services service terminated with the following error: The system cannot find the file specified."   Same as my previous error, but I'm not sure why this time as there is no indication of the file mentioned.  Maybe I will try File Monitor and see what it's pulling up.

Anyone have a super guru way of reinstalling the free Terminal Services without a repair of Windows?

I have Googled until my fingers bleed and can't find any way to "re-install" the free Terminal Services.  I also installed the Terminal Server, which you need a license for, hoping that would iron things out.  It did not.
dil222Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

atereaCommented:
might work if you install terminal server ( the full product )
let that configure itself, then reboot and uninstall it and reboot again.
It might be enough to get you going again.
0
tommy13vCommented:
Have you tried running the SFC /SCANNOW  and reboot.
0
dil222Author Commented:
Thanks, I had already tried installing the full Terminal Server hoping that the shotgum approach would bring it back in line.  It didn't... :(

I'll try the SFC /SCANNOW option and see what happens.

When I ran File Monitor and watched as the service attemped to start, it said not found on svchost.exe.manifest and svchost.exe.local, whatever that tells me... :)
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

dil222Author Commented:
Wow, so I just "accidently" fixed this and I'd been revisiting this on and off for months....
Earlier I had mentioned I created some registry entries to correspond with a working server.  There were a lot of entries so I couldn't verify each and every one.  Finally I got fed up and just decided to do an export from a working server and hope it worked.  I didn't make backups because I really didn't care.

The keys I copied were:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermDD
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\Root\LEGACY_TERMSERVICE - (need to change permissions to import this one)
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost - just the "termsvcs" item
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost\termsvcs

Imported all of these over top of what was in there and miraculously it now works...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
paulviCommented:
I was having the same problem for months as well.  Using the post above, I was able to resolve the problem, but I had to be much more careful as this was a production server.
The key that fixed this issue was
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters]
REG_EXPAND_SZ %systemroot%\system32\termsrv.dll was missing.

I hope this helps someone else having this issue.
0
nskursCommented:

I faced this issue as Terminal Server module itself was missing. When I tried to manually start the Termservice, it used to show an error messege "System can not find the service specified".

-------------------------------------------------------------------
Event Id : 1048

Source : Terminal Service Local session manager

Terminal service start failed.

--------------------------------------------------------------------

Event Id : 7023

Source : Service Control Management

Termservice service terminated with the following error :

Specified module could not be found.

-----------------------------------------------------------------------

I tried to install RDP client and it never worked.

Then ultimately sfc /scannow worked for me.

0
nskursCommented:

Oops, I forgot to mention OS : Windows 2008 standard 64 bit

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.