Avatar of rmmarsh
rmmarshFlag for United States of America asked on

1 Gig NIC card not at full speed on Compaq (HP) machine

I have a Compaq/HP SR5030NX, that I have disabled the onboard LAN and installed a 1 Gig NIC (D-Link)... it will only go to 100 Mbps... I had the same problem with a another machine, disabled the onboard LAN and got it full speed.  However, the Compaq/HP will not go full speed.

Any ideas on how to fix this?  (I will NEVER purchase another Compaq/HP product again!)
Networking Hardware-Other

Avatar of undefined
Last Comment
rmmarsh

8/22/2022 - Mon
txhockey26

Is the port on the switch you are plugging into Gigabit?  Only reason I ask is that you don't mention anything about the switch!
mds-cos

Ummm...stupid question here, but are you plugging into a GB switch?

If the switch is GB, you are most likely having a problem with auto-negotiation.  Go into the properties of the NIC.  There should be an option for link speed and duplex -- by default these will be "auto negoitiate".  Change to 1000Gbps and "half" or "full" duplex depending on which you want.
ASKER
rmmarsh

Oh... yes, the port shows 1 G on a ByteBrothers meter... it should work, but it doesn't...
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
souseran

Right-click on My Network Places. Select Properties. Right-click on the D-Link Network Adapter. Select Properties. On the General tab, under Connect Using, it should show your D-Link NIC. Next to that, click the button labeled Configure. On the Advanced tab on the new screen, look for something like in the left-hand Link Speed & Duplex. In the right-hand window, change the value to one that is correct for your card and network. Save your changes.
jburgaard

To operate at Gig speed the link must meet higher standards than at 100Mb : minimum cat5e.
So cable etc. must be working OK at higher frequencies & all 4 pairs are used (at 100Mb only 2 pairs)
ASKER
rmmarsh

All of the above are satisfied... have the Link Speed set to Auto... the same settings work on other non-HP machines.  
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
mds-cos

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
rmmarsh

1 Gig full duplex gives me "network cable unplugged", which of course it's not.  Going back to "auto" it says 100 Mbps...

SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
rmmarsh

Thank you... sorry for the delay in awarding points.