Avatar of KHM Admin
KHM AdminFlag for United States of America asked on

Cisco Multi-link PPP Virtual Template - more than one?

I have a t1 p2p full mesh network for three sites: Major, minor1 and minor2 (think of a triangle)
Everthing is Cisco 2600's using dsu1t's.  Everything working fine.
Upgrading speed - adding an additional t1-p2p between major site and both minor sites.  the minor to minor site (bottom of triangle) is still single t1.
I worked minor1 this week.  
Programmed in Multilink virtual-template1 ,
loopback0 with ip address,
both serials (s1/0 and s1/1) to no ip address, encap ppp, ppp multilink,
and int vertual-template1 as unnumbered to loopback0, ppp auth chap, ppp multilink

both routers setup and link comes up.  speed is great.
the question now is can I configure a second seperate multilink on the major site?
I know that minor2 site will mirror the minor1site - changes to ip etc understood.
I have pasted clean configs of major and minor1- I kow that minor2 will be very similar to minor1.

any help would be good.  
Thanks
Dan


major:config
multilink virtual-template 1
!
interface Loopback0
 ip address 192.168.255.22 255.255.255.252
!
interface FastEthernet0/0
 ip address 10.10.1.200 255.255.0.0
 speed 100
 full-duplex
!
interface Serial0/0
 description single p2p to minor2
 ip address 192.168.255.5 255.255.255.252
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 description reserved link#2 to minor2 - turned off 5-21-08
 no ip address
 shutdown
 !
interface Serial1/0
 description link#1 to minor1
 no ip address
 encapsulation ppp
 no fair-queue
 pulse-time 3
 ppp multilink
!
interface Serial1/1
 description link#2 to minor1
 no ip address
 encapsulation ppp
 no fair-queue
 pulse-time 3
 ppp multilink
!
interface Virtual-Template1
 description virtual setup for multilink to minor1
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
router eigrp 1
 network 10.0.0.0
 network 192.168.1.0
 network 192.168.255.0
 auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.1.3
ip route 10.0.52.0 255.255.255.0 10.10.1.3
ip route 10.50.0.0 255.255.255.0 10.10.1.3
ip route 10.101.1.0 255.255.255.0 10.10.1.3
ip route 63.138.42.225 255.255.255.255 10.20.1.200
ip route 192.168.2.0 255.255.255.0 10.10.1.3
ip route 192.168.5.0 255.255.255.0 10.10.1.3
ip route 192.168.99.0 255.255.255.0 10.10.1.4
no ip http server
!



Minor1: config
multilink virtual-template 1
!
interface Loopback0
 ip address 192.168.255.21 255.255.255.252
!
interface Ethernet0/0
 description old int- do not use
 ip address 192.168.0.253 255.255.255.0
 ip access-group 140 in
 ip access-group 140 out
 shutdown
 full-duplex
!
interface Serial0/0
 description p2p to minor2
 ip address 192.168.255.9 255.255.255.252
!
interface Ethernet0/1
 ip address 10.30.1.200 255.255.0.0
 full-duplex
!
interface Serial0/1
 description reserved backup interface - turned off 5-21-08
 no ip address
 shutdown
 service-module t1 clock source internal
!
interface Serial1/0
 description new link#1 to major
 no ip address
 encapsulation ppp
 pulse-time 3
 no fair-queue
 ppp multilink
!
interface Serial1/1
 description new link#2 to major
 no ip address
 encapsulation ppp
 pulse-time 3
 no fair-queue
 ppp multilink
!
interface Virtual-Template1
 description virtual interface for bonded pair to major
 ip unnumbered Loopback0
 ppp authentication chap
 ppp multilink
!
router eigrp 1
 network 10.0.0.0
 network 192.168.255.0
 no auto-summary
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 10.30.1.1

RoutersNetwork Architecture

Avatar of undefined
Last Comment
KHM Admin

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
RSLE

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
mikebernhardt

Any reason why you don't want to just leave the T1s independent of each other? EIGRP will automatically load-balance across them and you'll get pretty much the same end result.
ASKER
KHM Admin

I will try what you listed above - thanks.
As for bonding vs independant - I just followed the train of thought about bonding the links to get one virtual pipe.  I did not think about letting the routing take care of things.  Maybe I will try the routing prot. way on minor2 and do some bandwidth tests.

Thanks
Dan
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes