Avatar of TimLaL
TimLaLFlag for United States of America asked on

reinstall XP SP3

Since installing XP SP3 - which locked up before fully installing - but does show under My Computer/System Properties - I can not uninstall any programs.
If I attempt to do so, I get a message telling me that I must be running in safe mode or have Windows installer incorrectly configured.

If I go to the Windows Update site to review recent updates, SP3 is not listed.
Suggestions?
Windows XP

Avatar of undefined
Last Comment
Rob Williams

8/22/2022 - Mon
Rob Williams

I would recommend manually downloading the full XP SP3 install, and re-install.
http://www.microsoft.com/downloads/details.aspx?FamilyID=5b33b5a8-5e76-401f-be08-1e1555d4f3d4&displaylang=en
blimster

Try running the following commands in the command prompt
Start>Run or WindowsButton+R
Type "cmd"

This rerregisters the windows installer.

msiexec /unregister
msiexec /regserver

Or try and download and reinstall Windowshttp://www.microsoft.com/downloads/details.aspx?FamilyID=889482FC-5F56-4A38-B838-DE776FD4138C&displaylang=en

I'd recommend you Take RobWill's advice and reinstall SP3 as well
ASKER
TimLaL

Well I tried both suggestions and am still having trouble - more than before:  Windows will not start - even in safe mode.

I downloaded the SP3 (network version for multiple computers at the link RobWill gave me.
It downloaded and started the install.
It got part way through and then started coming up with error windows (as I recall, that is the same thing that happened when I originally did the install via the Windows Update site),

I got an "Application error" window
Instruction at 0x5a90d46b could not be read - ref memory0x846444b.

If I attempted to close the window, another would open - multiple times - at least 30 -
these all looked the same except that the title of the window would change (drwtsn32.exe, IEXPLORE.exe, etc.)
The instruction & memory references were always the same.

I let the system set overnight in case the processes were just slow -as I could see some disk accessing.
However, by morning, the same error windows were present and still couldn't be closed.

I attempted to shut down processes using Ctrl-Alt-Del, but it wouldn't bring up the task manager window.

I then tried to shut down via START - Restart and START-Shutdown, but neither worked.
I finally had to shutdown by holding the POWER button down.

When I restarted the system, it continued to come up to the black screen stating that windows couldn't start successfully.
I attempted to start it normally, in safe mode & in safe/ command prompt mode.
These each just recycled back to the same screen.

So, I now can't start the computer.
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Rob Williams

That is not good :-(
I have had no problems on any machines as of yet, unlike SP2. However, some digging reveals you are not alone. The following is one of the better sites I came across. You have to read down a far way as the first part deals with preventative measures.
http://msinfluentials.com/blogs/jesper/archive/2008/05/08/does-your-amd-based-computer-boot-after-installing-xp-sp3.aspx
ASKER
TimLaL

Yes, the first time I had installed SP3 via the Windows update site, it had the same errors, but I was able to reboot - AFTER having to power down via the power button & restarting into normal mode.
This time, I continue to come up with the black "windows failed to start" page.

My laptop is a Toshiba Techra A9 using a Core Duo T7.
The website you directed me to primarily listed troubles associated with AMD processors.

However, I followed a couple steps - pressing F8 as the failure screen prepares to open -
selecting the "don't automatically restart on failure" so that I could catch the error screen.
That now shows BAD_SYSTEM_CONFIG_INFO -
after all the standard verbiage, the actual error is -
*** STOP:   0x00000074 (in parenths - several other 0x items)

I have yet to contact Toshiba to see if I should attempt to use their recovery disk, but I hesitate for the risk of fouling up several of the other programs I have installed.
Rob Williams

If you run the Toshiba recovery dis you will lose any data.

You could try booting to the command mode recovery console and run chkdsk. I have seen that work wonders.

The other two options are System File Checker, or a repair install, but they won't work with a Toshiba recovery disk you need a proper windows install disk.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
TimLaL

So, I got my XP CD and booted using it into recovery mode.
However, I got a message that there was no hard drive connected to the system.
Rob Williams

It's possible you have a bad hard drive. That would also explain why XP3 would fail, when it tried to write to bad clusters. One way or the other it sounds like the MBR is corrupt.
If possible, I would try recovering any data before going any further but if the disk is unrecognizable that may not be possible.
I would first download a bootable diagnostic disk from the maker of the hard drive and run a full test on the drive.

If it is OK then from the Windows recovery CD I would run FixMBR but please read the link below first and the warnings about viruses. Presuming the disk is now visible, if not bootable you can run FixBoot, and I would also run chkdsk. An outline of all commands and there uses are included in the same link:
http://support.microsoft.com/kb/314058
ASKER
TimLaL

Well - called Toshiba today - corrupted OS.
Ran the Toshiba recovery disk - lost my data but I had a recent backup on a Maxtor One Touch -
But, it appears that the Maxtor backup software doesn't back up Outlook files - bummer there!

Thanks for the help.
Back to the beginning getting the laptop back to work.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
Rob Williams

If you wanted to install SP3 now would be the time before you reconfigure.
Any chance you backed up the user profile? Outlook files are in hidden folders that would be there if the whole profile was backed up:
Outlook:
C:\Documents and Settings\<UserName>\Local Settings\Application data\Microsoft\Outlook\Outlook.pst
Outlook Express:
C:\Documents and Settings\<UserName>\Local Settings\Application data\Identities\{long number}\Microsoft\Outlook Express

Thanks for the update,
--Rob
ASKER
TimLaL

I am about ready to go back to pencil and paper.
I have had a couple computer crashes over the past couple of years, so had been quite religious about doing backups - every other/ every third day so.
However, from reading some of the discussions on the Maxtor/ Seagate website - forums/ KB, it appears that the latest "one touch" backup software does NOT back up Outlook pst files unless one is horribly creative in how they run the backups - which then is not "One Touch".

I will be checking some of this out a bit closer tomorrow once I get back to the office, but I have a very sinking feeling that the files are GONE.  The last hard pst back I did was just prior to using the Maxtor drive.
If these files are gone, I will be extremely disappointed (aka angry) that yet another MS affiliate has an device and software package on the market that does not live up to its name.
One more step close to jumping the MS garbage barge (in lieu of what SP3 just did to me and what I tried with Vista last year) and investing my time with Mac.  This is insanity!

Since this thread did not resolve my issue, what do I do with the points.
And, save this - I am not alone in having troubles with XP SP3 - nor Maxtor One Touch!  What an extreme disappointment.  
ASKER
TimLaL

P.S.
 As soon as I got the system restored, prior to loading any misc. programs, I did successfully download & install SP3!   I didn't want to encounter that trouble again.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Rob Williams

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
TimLaL

Even though I wasn't able to save the computer w/o a total reinstallation, I greatly appreciate all the guidance.
The learning never stops!  I just wish it weren't quite so painful.
Rob Williams

Thanks TimLaL.
Sorry there wasn't an easier solution.
Cheers !
--Rob