Avatar of taxschool
taxschoolFlag for United States of America asked on

CD ripping software locks system

As of about 2 days ago, any CD ripping software (have tried Audiograbber, CDEx, Musicmatch, EAC) now locks up. The app is locked up, drive becomes locked up (cannot open), and the app cannot be killed via Task Manager. The majority of the time, the system hangs on reboot or shutdown and I have to do a hard shutdown. Happens regardless of which of my two physical drives I have the application pointed to. Sometimes the lockup occurs when the application fires up initially, sometimes it waits until I attempt to extract audio.

I had installed some DVD player software (VLC Player, DVDshrink) in an attempt to convert some PAL DVDs to NTSC, so one of those apps may be the culprit, but I've uninstalled them to no avail...

Stymied as to what to try next.

This is XP Professional SP2.

Thanks!
MultiMedia ApplicationsWindows XPSoftware

Avatar of undefined
Last Comment
Merete

8/22/2022 - Mon
Merete

Hi taxschool,
to assist you please fill in these details
how many rom drives do you have regardless burners and players.
two hard drives?
how they installed?
maybe one of these are faulty, if you get a faulty hard drive onslave, or a faulty rom drive will cause lockups.

I had installed some DVD player software (VLC Player, DVDshrink) in an attempt to convert some PAL DVDs to NTSC<< should make no difference, this sounds like a hardware problem something failing.
How old is your hard drive?
how much ram?
Memtest?

Have you defragged recently ran a disc cleanup clear out the temp folder?<< this very important if you start getting lockups. So please do that first, disc cleanup at start all programs accessories system tools..
then defrag, r/click the C drive properties defrag>analyze how much red/
Same with your slaved hard drive defrag it.

Could you check the administrative tools in control panel>event viewer applications >errors, open one and to copy it click on the white icon below the down arrow and paste just one error please back here.

Might be time to consider removing all the extras such slave hard drive. one rom to find out if one is faulty
Talk soon
Merete
Gareth Pritchard

I would assume that you have booted up your computer and not ran any software or discs ?
If you have and the computer has run normally:

drop in a Retail music disc into each drive, and see if the machine freezes on either one of them.
if it does remove that drive reboot, and try normal operation again.
if not do the same for the other drive.

Make sure your hardware isnt overheating ( nothing is blocking your fans, all fans are clear and spinning freely ( not clogged with dust etc.. ).
ASKER
taxschool

System is a Dell XPS 410, 2GB RAM.

C: drive (boot) is a 160GB Western Digital Raptor (WD1600ADFD)
D: drive is a 300GB Seagate Barracuda 7200.10 (ST3320620AS)

I: drive is Sony CRX310S
J: drive is TSST DVD+/-RW

No overheating or fan blockage issues.

I can drop a music CD into either optical drive and Windows Media Player will autoplay each just fine.

It's only when I try to use ripping software to extract audio that things fall over.

No errors in system event viewer other than indicating that the registry was still in use when I had to do a hard shutdown.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
Gareth Pritchard

I wouldnt think VLC or DVDShrink were at fault - both realy stable programs, been used by a hell of a lot of people for a long time.

Best I can suggest is that Windows Media player is trying to access the disc at the same time as the other apps - have you tried disabling autplay on the drives ?
Merete

C: drive (boot) is a 160GB Western Digital Raptor (WD1600ADFD)<< seagate dont normally play happlily alongside western digital.
D: drive is a 300GB Seagate Barracuda 7200.10 (ST3320620AS)<< this drive is very large may drag the system resources.
Did you add the Seagate recently?

Also one main factor are you burning files from D:\ drive to C drive??

I: drive is Sony CRX310S<< is this master rom? Where is it,
the master rom should be behind the C drive using drive D:\ for the purposes of burning D Drive is normally allocated to the master slave burner.

J: drive is TSST DVD+/-RW<< is this actuall burner then I suggest you swap a few drives around so that you burner is the master slave, and your second rom is true slave
check the jumpers are correct and ide positions are right.
ASKER
taxschool

The only problem I see with relating the problem to which device is master versus slave, is that this hardware configuration has not changed in the 18 months I've owned the computer. The master/slave device configuration is as it shipped from Dell.

Why now all of a sudden would the master/slave configuration introduce a problem, when it's been working all along?...
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Gareth Pritchard

It wouldnt unless the IDE cables were degrading / faulty.

Based on the fact that the issue only arises when running specific software - even if you dont start to rip the disc the system hangs ( possibly the software is set to autorip audio cd's if there is one detected  this would have to be disabled to realy prove that the problem isnt hardware related ).

One thing you might try, is to insert a written CDr and try to copy the data from it to the HDD using nothing but windows explorer and the right click context menu. see if the issue exists in that scenario.
Merete

Drives wear out taxschool, if one of the roms is dying you'll get problems seems it's only happening>>
It's only when I try to use ripping software to extract audio that things fall over<<
empty the temp folder?
Defragged?
ok the lets look at the steps,
steo one
you insert a dvd disc, then you wait right?
Cause as soon as you insert a CD disc the auto run starts up, depending on what you assigned it to do it should open to a folder of choices and that you can close
step two
you open your software to extract the CD to your hard drive
Cdex is the best here in my opinion, remove the others..
MusicMatch jukebox will be no good now unless you bought the full version, it also uses a lot of resources.
EAC is this your default onboard software for your sound card?

>>any CD ripping software (have tried Audiograbber, CDEx, Musicmatch, EAC)

Does it happen with any CD or just this one?
Could be bad CD's
Update the drivers for these roms drives

You know this could also be related to xpsp3, since it started a few days ago sp3 came out around 3 weeks ago.
Is windows updates running in the back ground, before you start to rip the cd
check the task manage close out everything but what you are doing.

ASKER
taxschool

EAC is "Exact Audio Copy" (www.exactaudiocopy.de). I've used it as my default ripper for years. It's very configurable as a front-end for the LAME encoder, and I like that I can rip a 65-second segment of each song on a CD starting 30 seconds into each track, adding a 5-second fadeout, normalizing to 98%, and converting to 112kbps mp3, all in one action. It's the most automated way I've found of creating sound samples for promotional purposes.

I'll do some more experimenting with different discs and using Windows Explorer.
Your help has saved me hundreds of hours of internet surfing.
fblack61
ASKER CERTIFIED SOLUTION
taxschool

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Merete

Are you sure, please explain to me to how you use explorer
>>I'll do some more experimenting with different discs and using Windows Explorer.
When I burn a disc I open NEro, then the folder of the files I wish to burn and drag and drop them onto the Nero interface.
Did I mention Seagate and western digital donot play happlily together, as woek around and test remove your Seagate for the time being, if the files you want to copy/burn are on this drive copy them to a temp folder on the desktop and then shutdown power off complete and pull out the slaved drive.
Then try a burn.
May help to pin point the problem.

C: drive (boot) is a 160GB Western Digital Raptor (WD1600ADFD)
D: drive is a 300GB Seagate Barracuda 7200.10 (ST3320620AS)

Merete

No probs taxschool  sorry to hear you had to go that way.
Glad to know it's all running as it should though.
Regards Merete