Avatar of Rob Samuel
Rob SamuelFlag for United Kingdom of Great Britain and Northern Ireland asked on

Partmgr.sys blue screen on connecting external HDD

Hi,

My director tried to plug his Seagate 500GB external HDD into his Vaio laptop running Vista Business SP1 and was presented with a BSOD error on partmgr.sys. Apparently this has started happening since installing SP1, but apart from that the laptop runs better than before SP1.

Is there a Windows Update fix/patch I can install on his laptop to get rid of this error message which is causing the notebook to restart??

I've run diagnostic software on the notebook drive and the external drive - everything seems ok.

Thanks in advance,

Rob
Windows VistaStorage

Avatar of undefined
Last Comment
Neuromaniac

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
ewavefront

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
Rob Samuel

It's a USB drive. I'll check the model and download the latest drivers.
ASKER
Rob Samuel

There are no driver updates on the Seagate site. Any other sugestions?
Neuromaniac

Problem is with Vista SP1  sill waiting for an update to fix it
Your help has saved me hundreds of hours of internet surfing.
fblack61