troubleshooting Question

TableAdapter SQL Commands not appearing under SQL Profiler

Avatar of djcheeky
djcheekyFlag for United States of America asked on
Microsoft SQL ServerC#ASP.NET
4 Comments1 Solution661 ViewsLast Modified:
Hi.

I am using a TableAdapter in an ASP .NET application (C#) that does a couple of standard queries, namely a GetAll, Create, Update, Delete, GetByID.

The problem I am having is a very strange one.
When I run the GetAll function, data is returned fine and the SQL statement shows under SQL Profiler.

However, when I run the Create, Update or GetByID methods, I get data fine, but the Insert,Update or Select statmenet does NOT appear under SQL Profiler.

Why is this? Data is being retrieved without hassle - but when I want to go to SQL Profiler to view the query that was executed, nothing displays. The only time it ever displays is when the GetAll() query executes.

Thanks
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 4 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 4 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros