Avatar of oonon
oonon asked on

Why am I unable to recieve responses from pings?

Thank you for your time.

I am running a Cisco Pix 501 firewall.  I am trying to ping outside to the internet and I am unable to receive return packets from sites that should be returning.  I am able to view the internet in a browser.  I have attached my config below.
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ******** encrypted
passwd ******** encrypted
hostname ******** 
domain-name ******** 
clock timezone CST -6
clock summer-time CDT recurring 1 Sun May 2:00 last Sun Sep 2:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.20.0 255.255.255.0 
access-list 101 permit ip interface inside 192.168.1.192 255.255.255.224 
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.1.192 255.255.255.224 
access-list 101 permit ip 192.168.1.0 255.255.255.0 10.1.30.0 255.255.255.0 
access-list splitunnel permit ip 192.168.1.0 255.255.255.0 192.168.20.0 255.255.255.0 
access-list intro permit tcp any interface outside eq 8080 
access-list intro permit tcp any interface outside eq 3389 
access-list intro permit tcp any host ******** eq www 
access-list intro permit tcp any interface outside eq pcanywhere-data 
access-list intro permit tcp any any 
access-list nitro permit tcp any any 
access-list recovery_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any 
access-list outside_cryptomap_dyn_30 permit ip any 192.168.1.192 255.255.255.224 
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 10.1.30.0 255.255.255.0 
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside ********  255.255.255.0 pppoe setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.20.1-192.168.20.254
ip local pool ippool2 192.168.1.200-192.168.1.220
pdm location 192.168.1.40 255.255.255.255 inside
pdm location 192.168.1.41 255.255.255.255 inside
pdm location 192.168.1.192 255.255.255.224 outside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.20.0 255.255.255.0 outside
pdm location 10.1.30.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 8080 192.168.1.41 8080 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface 3389 192.168.1.41 3389 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface www 192.168.1.40 www netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface pcanywhere-data 192.168.1.41 pcanywhere-data netmask 255.255.255.255 0 0 
access-group intro in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server RADIUS protocol radius 
aaa-server LOCAL protocol local 
mac-list access permit 000f.fe05.671f ffff.ffff.ffff 
mac-list access permit 0050.da2f.e27b ffff.ffff.ffff 
mac-list access permit 0001.03c5.039a ffff.ffff.ffff 
mac-list access permit 0060.08b0.4bae ffff.ffff.ffff 
mac-list access permit 00b0.d00f.2db1 ffff.ffff.ffff 
mac-list access permit 0004.75e9.f622 ffff.ffff.ffff 
mac-list access permit 000d.566a.d06d ffff.ffff.ffff 
mac-list access permit 0040.2b43.64db ffff.ffff.ffff 
mac-list access permit 0800.4602.22f0 ffff.ffff.ffff 
mac-list access permit 000c.6e73.4e04 ffff.ffff.ffff 
mac-list access permit 000a.e672.7621 ffff.ffff.ffff 
mac-list access permit 00b0.d007.36ff ffff.ffff.ffff 
mac-list access permit 000b.db1f.bb0e ffff.ffff.ffff 
mac-list access deny 0008.0d1d.ce61 ffff.ffff.ffff 
mac-list access permit 0201.0324.f552 ffff.ffff.ffff 
mac-list access permit 001a.a0cb.26a6 ffff.ffff.ffff 
aaa mac-exempt match access
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set myset esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map dynmap 10 set transform-set myset
crypto dynamic-map dynmap 30 match address outside_cryptomap_dyn_30
crypto dynamic-map dynmap 30 set transform-set myset
crypto map mymap 20 ipsec-isakmp
crypto map mymap 20 match address outside_cryptomap_20
crypto map mymap 20 set peer ******** 
crypto map mymap 20 set transform-set ESP-3DES-SHA
crypto map mymap 100 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map mymap client authentication LOCAL
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address ******** netmask 255.255.255.255 no-xauth no-config-mode 
isakmp identity address
isakmp nat-traversal 20
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption 3des
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
vpngroup pixvpn idle-time 1800
vpngroup CVPtunnel address-pool ippool
vpngroup CVPtunnel split-tunnel splitunnel
vpngroup CVPtunnel idle-time 1800
vpngroup CVPtunnel password ********
vpngroup recovery address-pool ippool2
vpngroup recovery dns-server 192.168.1.41
vpngroup recovery wins-server 192.168.1.41
vpngroup recovery split-tunnel recovery_splitTunnelAcl
vpngroup recovery idle-time 1800
vpngroup recovery password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 60
management-access inside
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname ********
vpdn group pppoe_group ppp authentication pap
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP client configuration address local ippool2
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username ******** password ********* 
vpdn username ******** password ********* 
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd wins 192.168.1.41 
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside

Open in new window

Software FirewallsHardware FirewallsCisco

Avatar of undefined
Last Comment
Cyclops3590

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
Cyclops3590

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
oonon

access-list intro permit icmp any any eq echo-reply

was not accepted as a valid command, but using

access-list intro permit icmp any any echo-reply

was accepted and it is now working.  Thanks for your help!
ASKER
oonon

Thanks a lot for your help.  It is greatly appreciated.I am glad to have this resolved.
Cyclops3590

darn it always get the port portion/code portion of the acl and static syntax mixed up.  Glad to here its working.  keep in mind, this won't get traceroute's working though.  since that requires a different icmp code to be let back in than echo-reply, that would also have to be allowed before traceroutes would work.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
ASKER
oonon

Thanks for the heads up.  I hadn't tried traceroute yet.  I was able to get that working by using the following two commands:

access-list outside_access_in permit icmp any interface outside
access-group outside_access_in in interface outside
Cyclops3590

yup that command will allow any icmp code packet to go thru