Avatar of mamadouthiam
mamadouthiam asked on

Help converting existing .html files for server side includes (ssi)

I involved in a rather large project where we plan on upgrading several thousand pages to use ssi for footer, header, nav etc. This is my first experience with this and I am trying to work through the details. A key element to this is that we must keep the .html file extensions.

1. I have read that by using XBitHack on statement on .htaccess file, this can be achieved and I have been told by our server admin that this has been done.
2. I created an ssi with a .html file extension (no html, body, header tags etc.)
3. I used Dreamweaver to insert SSI into about.html with this code:  <!--#include file="../includes/leftnav.html" -->
4. Loaded page to testing server and the include does not show up

Questions:
1. Do I need to save about.html as .shtml and then allow the parsing from .shtml to .html to take place at the server level?
2. Is there a way to test to see if teh server folk did things correctly
3. Any other ideas why this is not working?

Thanks,

mama
Do I have to save teh existing

Web Languages and StandardsApache Web ServerAdobe Dreamweaver

Avatar of undefined
Last Comment
Jason C. Levine

8/22/2022 - Mon
Jason C. Levine

Hi mama,

Without knowing what your guy did on the .htaccess file, it's a little hard to say what you need to do.  Generally speaking, SSI should already be enabled for .shtml pages, so do a test.shtml file and try it.

If the SSI shows up in that file, then you are good to go.  The next issue involves not having to rename all of your HTML.

In the .htaccess file at the web root level, add the following two lines:

AddType text/html .html
AddHandler server-parsed .html  

Those two lines should allow SSI to work on normal .html pages.

The other big thing to check is the paths to the includes.
ASKER
mamadouthiam

jason1178,

The ssi does not show up in the .shtml right now. Is there something that the server folk need to do other than enabling the XBitHack on to allow for ssi?

Thanks,

mama
Jason C. Levine

One of the Apache conf files needs to be checked to make sure SSI is enabled there.  It's been a while since I've done it myself so let me do some googling to figure out which one.
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
ASKER CERTIFIED SOLUTION
Jason C. Levine

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
mamadouthiam

Could have used more follow-up. Much of what was given was stuff that I already found myself. But thanks in any case.

mama
Jason C. Levine

>> Could have used more follow-up

You could also have posted back anytime after 02:23PM on 5.29.08 and asked for more followup, too :)