troubleshooting Question

Dell Inspiron 600m runs at only 600 MHz even on AC power

Avatar of isolditdallas
isolditdallasFlag for United States of America asked on
Windows XPLaptops NotebooksComponents
6 Comments1 Solution2206 ViewsLast Modified:
My four-year-old Dell Inspiron 600m notebook PC should run at 1.5 GHz when on AC power.  However, recently I've discovered that the processor is running only at 600 MHz.  Sometimes it boots up at this speed.  Other times, it will boot up to 1.5 GHz, but later slow down to 600 MHz, and no matter what I do after that, I can't get it to step up back up to full speed.

I've noticed that when I see it step down from 1.5 GHz to 600 MHz, the CPU load always goes to 100%, even if nothing significant is running.  Process Explorer shows the load split among numerous programs, including Explorer.exe, Svchost.exe, etc.  No one process seems to be absorbing an unusual amount of CPU time.  I'm not sure if the CPU load is as a result of the decreased processing capability of the CPU, or rather the cause of it somehow--I suspect the former.

System information:
- Pentium-M CPU
- 2 GB RAM
- BIOS rev. A17
- Windows XP Professional SP2
- SpeedStep enabled in BIOS

I am measuring the CPU speed with Speedswitch XP v. 1.52.  I have Speedswitch configured for "Max. Performance" on AC power.

What I've tried so far:
- Flashed the BIOS to rev. A17 (it was on A11)
- Verified SpeedStep enabled in BIOS (disabling it forces machine to always run at 600 MHz)
- Booting Windows into Safe Mode - launched Speedswitch and watched CPU step down from 1.5 GHz to 600 MHz after about 2-3 minutes.  So it doesn't appear to be a driver-related problem.
- Monitoring CPU temps with I8kfanGUI - temps usually run 43-55 degrees C, peak of 68 under very heavy activity when CPU at 1.5 GHz, but nothing that should cause automatic throttling
- Monitored TM2 throttling with ThrottleWatch.  I captured a log in ThrottleWatch (attached) that showed the processor speed stepping down at the same time the CPU load went to 100%; TM2 Throttling remained at 0% the entire time.  So it's not a temperature problem.
- Tried installing Windows XP Hotfix R56673 ("Microsoft SpeedStep fix for WinXP addresses the following Microsoft issue (Q330512): The Processor Performance State Is Not Restored to the Maximum State If the CPU Runs at 100 Percent.") from the Dell website.  This hotfix was incorporated into XP SP2, so as expected the hotfix would not install on my system.

I've spent lots of time trolling Google for solutions.  I've found many people who describe the same or similar problem, but nobody with a solution (at least one I haven't tried).

Please help before I throw the bleeping computer against the wall! :)
ThrottleWatch-Journal.txt
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 6 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 6 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros