Group Policy Preference Regional Options Not Working in Server 2008

I am trying to convert users time format to HH:MM:SS (Military Time / 24 hour) through Group Policy. When I update the preference to HH:MM:SS and apply, Windows Server does not store the change. When I open up the Regional Option Preference again, it is switched back to h:mm:ss tt. I've tried to change the server time to the time I'm requesting in the policy, but that has failed. Any help on getting this policy to stick is appreciated.  (See attachments for screenshots)
Before.JPG
After.JPG
IDFIAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Netman66Commented:
Where are you making this change?  To an existing policy or a new one?

Try using the dropdown and selecting:  HH:mm:ss



IDFIAuthor Commented:
It is a new policy. I've tried saving both as HH:mm:ss and H:mm:ss, both fail. If you save it, it just reverts back.
Netman66Commented:
Try changing it in the Default Domain Policy.  

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

IDFIAuthor Commented:
That does not work either.
Netman66Commented:
Are you certain you have permissions to change this?  The fact it doesn't hold either means you don't or replication is broken so that another DC is replicating the original back over your last change.

Is there more than one DC? if so, what OSes are they all running?



IDFIAuthor Commented:
Have you tried this for yourself on your own server? I've tried on multiple different machines and the result is always the same. The result is the same on networks with a single DC or multipe DCs w/replication. (All domains I've tested on have 2008 schema).
tigermattCommented:
If you're getting it on multiple networks then I'd put it down to some sort of bug in Windows Server 2008 which is causing it. Might be worth going over to the Microsoft Forums, posting a thread there and alerting them to this.

If I had access to a Server 2008 machine, I would try and replicate this - but at the moment, the network connection to a network running quite a few of these servers is down!

-tigermatt
Netman66Commented:
Confirmed.

I am chasing this now.

The Editor doesn't appear to save a complete XML file.  It partly there, but not any further settings.

Netman66Commented:
Ok, this isn't a bug.

When you select the Time tab and click in the field for Time Format - press F6 to turn that dotted red line into a solid green line to activate the setting.  Change it then apply it.

You won't see it apply on the DC until you log off then back on again.

The following are the controls for these preferences:

F5 - all settings activated (green)  (on the tab you have opened)
F6 - a single setting change from red to green (deactive/active)
F7 - a single setting change from green to red (active/deactive)
F8 - all settings dectivated (red dotted)

Let me know how you make out.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IDFIAuthor Commented:
It worked! Thank you for the help.
Netman66Commented:
Excellent!  Glad to help.
supaconCommented:
That tip with the F5 and F6 keys was a big help to me, but when I change regional options, it doesn't seem to take effect on the PCs that I log into.  Can the user still override these with ease?
Dela-DWindows Systems EngineerCommented:
Wow, can't believe I used the wrong search string in Google all the time trying to find a solution for this.

Finally solved now. This is perfect! Thanks Netman66.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.