[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1138
  • Last Modified:

All messages in mail-enabled public folder stay unread.

We have an Exchange 2003 server with Outlook 2003 and Outlook 2007 clients connecting to it.  They use a mail-enabled public folder for the office e-mail.  They would like it to show when a user has read an e-mail so they know when mail hasn't been read.  I have unchecked the "Maintain per-user read and unread information" box on the public folder, but now all messages show as "Unread" and they cannot be changed.  Even manually trying to mark the message as being read does not work.  If I re-check this box, the users can mark messages as read, but only for their mailbox.  Is there a fix for this?  Thank you
0
OAC Technology
Asked:
OAC Technology
  • 3
  • 3
1 Solution
 
Hypercat (Deb)Commented:
I'm pretty sure that's by design.  You might want to look at using a shared mailbox instead of a public folder for this purpose.  With a shared mailbox, if anyone has read the message, it shows as read to all users.
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
Hmm... I thought that unchecking "maintain per-user..." would do that.  I've seen in a few guides that it works for people.  That's why I was wondering if I've missed something or if public folders just don't do this at all?  I would rather use public folders if this is possible.

Thank you
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
I am in the process of setting up a shared mailbox.  I have Send as and send on behalf of permissions set up, but when I try to send email from this mailbox I can only do this by clicking "From..." and navigating through the global address list and selecting this user.  If I try to type in the address "companyoffice@company.com" it kicks back a failure stating that I do not have permissions.  Is this by design?  
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Hypercat (Deb)Commented:
No, I don't think so.  I can send email from my shared mailboxes by just typing in the FROM email address directly.  Have you initialized the companyoffice@company.com email box by sending an email to it from another address? Have you logged off and back on since you made the change?
0
 
OAC TechnologyProfessional NerdsAuthor Commented:
Yes, I sent a message to that e-mail address and logged off and back on.  It still won't allow me to send an e-mail from that address by typing it in manually.  Odd.  Any other suggestions?
0
 
Hypercat (Deb)Commented:
If you can send an email from that address by picking it from the global address list, then the basic permissions seem to be working properly.  The only thing I can offer is to send a few emails using that method and then try again to type in the address manually.  You may have to wait a day until after the normal mailbox management scripts run.  This appears to be a sort of "quirk" of exchange permissions.  I've had it happen when moving a mailbox from one server to another, and also when trying to resend an email from an old Sent Item that was sent using the shared mailbox.  After a few attempts or a few days, it seems to resolve itself. If that doesn't happen, post back here and we'll see what we can come up with.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now