Solved

Cannot see Google maps in IE7

Posted on 2008-06-09
4
1,958 Views
Last Modified: 2010-04-21
Hi - I have 2 PC's running XP Pro SP2 and IE7. Neither of them can use Google Maps - every graphic (I think they are PNG files) displays as a red X.



0
Comment
Question by:actionco
  • 2
  • 2
4 Comments
 
LVL 1

Expert Comment

by:kazazzz
ID: 21745855
Please see if any of the below help to solve your problem:

If you're having trouble using Google Maps with your Microsoft Internet Explorer browser, please try the steps below to see if any of them resolves the problem:

Clear the browser's cache

Clearing your browser's cache may resolve the problem you're experiencing. To do so in Internet Explorer 6.0 or later version:

Open IE and click Tools.
Select Internet Options.
Click General, if it isn't already selected.
Click Delete Files.... under the heading 'Temporary Internet files.'
Click OK to exit.

Make sure JavaScript, ActiveX, and 'binary behaviors' are enabled

To enable these browser settings in IE:

Click Tools > Internet Options.
Click the Security tab.
Click the Custom Level button.
Verify that the Enable button next to 'Run ActiveX controls and plug-in' is selected.
If you're using XP, verify that the Enable button next to Binary and script behaviors is selected. If you're not using XP, continue to step six.
Verify that the Enable button under 'Active scripting' is selected.
Click OK, then click OK again to save your changes.
The easiest and safest way to enable our maps in your browser is to add Google Maps to your list of trusted sites in Internet Explorer. Here's how:

Click Tools > Internet Options.
Click the Security tab.
Select the 'Trusted sites' icon, and click the Sites button.
Deselect the option 'Require server verification for all sites in this zone.'
In the text field 'Add this Web site to the zone:,' type 'maps.google.com' (without quotes) and click Add.
Repeat step five for 'local.google.com,' 'www.google.com,' and '*.google.com.'
Click OK, then click OK again to save your changes.
Update the 'scripting engine' of your system

Google Maps takes advantage of several advanced browser features. If your browser appears not to load the map properly, you may need to update your scripting engine. You can obtain the latest scripting engine directly from Microsoft:

For Windows XP and 2000:
http://www.microsoft.com/downloads/details.aspx?
FamilyId=C717D943-7E4B-4622-86EB-95A22B832CAA&displaylang=en

You'll probably need to restart your system after performing this update. Then, try Maps again to confirm if this step resolved your problem. Otherwise, try the next step.


Install the latest version of DirectX

Some IE users have reported that installing the latest version (9.0c) of DirectX has resolved the difficulties they've experienced viewing maps. To install DirectX, please visit http://www.microsoft.com/windows/directx/default.aspx 


Check for security settings or browser plug-ins


Some security programs and third-party browser plug-ins are designed to modify webpage content and may interfere with the map display. If applicable, please try temporarily disabling components that may disable our maps in your browser.
 
 
0
 

Author Comment

by:actionco
ID: 21746166
Thanks but I have tried all of those suggestions and I still have the same problem.
0
 
LVL 1

Accepted Solution

by:
kazazzz earned 500 total points
ID: 21746273
Question: Are you using content protection (i.e. netnanny) or third party firewall?

also can you also check this in ie7:
1. On the Tools menu, click Internet Options.  
2. Click the Advanced tab, and then verify that the Show Pictures check box is selected under Multimedia.
3. Click OK.  

lastly,

can you check and see if you have the latest version of java installed:
http://www.java.com/en/download/installed.jsp?detect=jre&try=1


Thanks,
Charlie


0
 

Author Closing Comment

by:actionco
ID: 31465865
Hi - I am embarrassed to say that I had forgotten to mention the PC's are behind an ISA firewall and although I THOUGHT I had allowed PNG files in a content filter I actually hadn't, so your last response prompted to check. Once I explicitly allowed PNG files Googlemaps works fine, thanks for all your help. Much appreciated
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Gmail Account risks 4 79
How to Force Windows XP to Scan for driver update 14 93
Which browser works with XP 16 118
Receipt Printer for web based app 3 36
Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

864 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now