Solved

WebDAV resourse access

Posted on 2008-06-09
1
561 Views
Last Modified: 2013-12-06
I have several web folders created that I try to open via (IE --> File --> Open (check "Open as Web folder") http://webserver.domain.com/webfolder/subdirectory OR through Network Places.

Regardless of the authentication & access control defined for the web folder, e.g. anonymous, IWA, Basic, etc. I receiving an initial logon prompt that will not accept any username/password. After entering username/password the logon prompt reappers, I hit escape, I receive the authentication logon prompt as expected (Basic authentication prompt with warning about clear text).

These are the IIS logs of the virtual directory access.

2008-06-09 19:20:00 192.168.15.251 PROPFIND /webdav - 80 - 192.168.15.51 Microsoft-WebDAV-MiniRedir/5.1.2600 401
2008-06-09 19:20:00 192.168.15.251 PROPFIND /webdav - 80 - 192.168.15.51 Microsoft-WebDAV-MiniRedir/5.1.2600 401
2008-06-09 19:20:00 192.168.15.251 PROPFIND /webdav/<subdirectory> - 80 <username> 192.168.15.51 Microsoft+Data+Access+Internet+Publishing+Provider+DAV 207
2008-06-09 19:20:02 192.168.15.251 PROPFIND /webdav/<subdirectory> - 80 - 192.168.15.51 Microsoft+Data+Access+Internet+Publishing+Provider+DAV 401
2008-06-09 19:20:02 192.168.15.251 PROPFIND /webdav/<subdirectory> - 80 <username> 192.168.15.51 Microsoft+Data+Access+Internet+Publishing+Provider+DAV 207

As you can see the 401 error code is an access denied response.

Thank you for any direction you might give me to troubleshoot this problem.
0
Comment
Question by:aaronremski
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
aaronremski earned 0 total points
ID: 21760459
http://blog.dreamhosters.com/kbase/index.cgi?area=3004
http://www.webdavsystem.com/server/documentation/troubleshooting

A combination of these two resolutions solved my problem.

In summary:
1.XP SP2 disables WebDAV Client BasicAuth
2. Specifying default port of webDAV IIS server solves root authentication issue.

Therefore:
Instead of http://webdav.hostserver.com/webdavfolder/

Use http://webdav.hostserver.com:80/webdavfolder/#
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With the withdrawal of support for Windows Server 2003 this summer, many clients face the issue of moving away from their 2003 installs. There are a few options out there that many people/companies are selling. But the clients I have, haven't wanted…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

717 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question