Windows Live connects - but Remote Assistance Fails DNS Name Resolution

I am trying to help a remote user using Windows Live Messenger.  I've used it before, and it worked great - had the remote desktop and complete control.

Now, I get the message "RemoteAssistance:  a remote assistance connection could not be established because the DNS Name of the remote computer could not be established [Ok]"

I've always had my PC behind a router, and it worked with remote PCs that were not behind routers.  

Is there some way to run this from behind routers?
RobertAsked:
Who is Participating?
 
RobertConnect With a Mentor Author Commented:
Found the problem.  The router at one end is non-uPnP, even though it says it is on the box;  the Connection under Menu\Tools\Options shows it as non-.

Perhaps it needs a firmware upgrade.

0
 
Trilog-StudiosCommented:
hi

I think the main question is, are you connecting to the same computer as before wen you get that message.
(II would suggest to use a program like ultavnc or anyplace remotecontrol for such actions).
0
 
RobertAuthor Commented:
No.

After having the remote user connect from cable modem to PC without a router, I was able to request assistance and the remote connection was made - which is bizarre, since the message indicates that the DNS Name issue is of the remote PC, and mine was still behind a router.

After removing the router at my end, I was able to take control of the remote PC.

However - I'd like to not have to remove my router (or have people whom need help remove their routers) to get this connection going.

I don't see any other similar Windows Live Messenger issues on this site, so if "you" hear of anyone using it, please pass along this problem to them.

ub
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
RobertAuthor Commented:
I have since looked at firewall issues.  Specifically, I disable Windows Firewall.  Then, on the remote PC running McAfee Security Center, I've set the advanced firewall settings to permit all incoming and outgoing traffic.  

What about routers?  I'm behind two routers, actually, and that has not prevented me from remote assisting/taking remote control of another PC.  

But one of the PCs I haven't been able to consistently connect with has a router.  Are there hardware settings that need to be tweaked?  Why would it work one day and then no other days?
0
 
Trilog-StudiosCommented:
hi ..

sorry 4 not repliing so long

you cant actually turn mcaffe firewall totaly of (but thats besidce the point) well the software firewall settings cant be a problem 'cause you could connect wen the remote users connects via modem.

well id say the router firewall of the remote pc is the problem .. many routers build after 2004 actually block specific ports that can be used to control the pc from a remote location. often you will have to set the router to just "access point" to bypass the internal firewall. or if you know the port that is used by ms live you can try to forward the port to a non-blocked port..

hope that helps

TS

 
0
 
RobertAuthor Commented:
I have connected once to this PC.  I helped install MS Office remotely.  That was before dialing down the McAfee firewall settings, too.  And no changes were made to the router settings.

But if it is a port issue, how do I find out what port Windows Live Messenger/Remote Access uses?  and then how would I forward the port?

ub
0
 
RobertAuthor Commented:
Also - I need the Linksys router - as it has my phone & fax ports, and I need those when I'm online.  Especially when providing Remote Assistance.

0
 
Trilog-StudiosCommented:
has the user installed anything that could perhaps have manipulated/hacked the network drivers?
is his MS Windows firewall perhaps open ?? ( wen i used to use the remote desktop connection from MS if the MS firewall wasnt disabled i could not connect..)

as i said the posibility that it is your router is very slim.

to find out what port ms live uses goto: http://support.microsoft.com/kb/927847

now to farward a port: if you open the routers interface there should be a few options under firewall .. ( depending on the router the option looks different) and there forward the incomming port of ms live to letz say 1234.

TS
0
 
RobertAuthor Commented:
I had a response from Microsoft.  Apparently msmgs.exe needs to be up-to-date, as part of the process.  

I miss the days when programs could be maintained and found in one folder or one folder tree.

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.