Solved

Application Context Root

Posted on 2008-06-09
7
646 Views
Last Modified: 2013-12-10
I am using WebLogic 10. My application context path is at C:\workspace\ple\public_html. I have chosen to name the application as "ple". After deploying, I found that I need to access the application this way:

http://localhost:7001/public_html/login.jsp

I thought that since the application name is "ple", I should be able to access it as:

http://localhost:7001/ple/login.jsp

But the above is actually invalid. So how do I configure it so that I can access it as http://localhost:7001/ple/login.jsp ?
0
Comment
Question by:yongsing
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 35

Expert Comment

by:girionis
ID: 21768366
How did you name your war file? WebLogic takes the context root from the name of the war file.
0
 
LVL 9

Author Comment

by:yongsing
ID: 21776638
I did not use a war file. I just put my stuff in C:\workspace\ple\public_html, and in WebLogic's console, under Deployment, I just specify the path of the application as "C:\workspace\ple\public_html".
0
 
LVL 35

Expert Comment

by:girionis
ID: 21783114
Can you not change it from the console? Can you try changing it fromthe weblogic.xml file? There should be a context-root element.
0
What Is Transaction Monitoring and who needs it?

Synthetic Transaction Monitoring that you need for the day to day, which ensures your business website keeps running optimally, and that there is no downtime to impact your customer experience.

 
LVL 9

Author Comment

by:yongsing
ID: 21784640
Yes, I can certainly change it from weblogic.xml. Do you know exactly what is the tag to change? I can't seem to find the description for weblogic.xml for WebLogic 10.
0
 
LVL 35

Accepted Solution

by:
girionis earned 50 total points
ID: 21784666
The tag should be the context-root tag.
0
 
LVL 9

Author Closing Comment

by:yongsing
ID: 31465614
Thanks girionis!

I added the following in weblogic.xml:

ple

and now I can access the application as:

http://localhost:7001/ple/login.jsp 
0
 
LVL 35

Expert Comment

by:girionis
ID: 21784924
Thanks for accepting, glad I was of help :)
0

Featured Post

The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

-Xmx and -Xms are the two JVM options often used to tune JVM heap size.   Here are some common mistakes made when using them:   Assume BigApp is a java class file for the below examples. 1.         Missing m, M, g or G at the end …
Verbose logging is used to diagnose garbage collector problems. By default, -verbose:gc output is written to either native_stderr.log or native_stdout.log.   It is also possible to redirect the logs to a user-specified file. This article will de…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question