• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1072
  • Last Modified:

Server 2003 VPN on One NIC with Stand Alone Router Connection Issues

I am setting up Server 2003 Enterprise to become a VPN Server.  It is not a PDC nor a dhcp server.
It's IP is 10.0.0.9 and I have a router (stand alone router, not a server OS) at 10.0.0.2

The server 2003 machine has one nic.  I am able to setup RRAS on it, however, if someone connects they receive error 738, no protocol.  This is some how related to not getting an IP address, correct?

Please let me know if I need to attach anymore information.

I was able to let it give out IPs by setting static, not sure if it will give out one thats in use on the LAN.
However, if I don't uncheck 'use gateway on remote network' the computer that dials in loses internet connection, I had a 2000 VPN Server and this was never an issue, so I'm sure its a setting on my end.
Which I have intranets I need users to get on so I can't uncheck this.

This is the ipconfig/all from a client trying to connect

 Connection-specific DNS Suffix  . :
 Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
 Physical Address. . . . . . . . . : 00-53-45-00-00-00
 Dhcp Enabled. . . . . . . . . . . : No
 IP Address. . . . . . . . . . . . : 10.0.0.26
 Subnet Mask . . . . . . . . . . . : 255.255.255.255
 Default Gateway . . . . . . . . . :
 DNS Servers . . . . . . . . . . . : 10.0.0.2
 Primary WINS Server . . . . . . . : 10.0.0.2

Thanks in advance.
0
dolemite01
Asked:
dolemite01
  • 2
  • 2
1 Solution
 
dolemite01Author Commented:
I disabled and re setup Remote Access, now I'm able to connect, however, I lose internet connection completely on the machine that connects, same is true if I uncheck use DNS on remote server.

Thanks
0
 
dolemite01Author Commented:
Just too add more, its only giving out 10.0.0.69, I've tried setting it to give out a range of IPs and also have it point to 10.0.0.2 (the router) for DHCP Handling, neither worked.

Thanks
0
 
Rob WilliamsCommented:
The issue with the loss of internet access on the client can be dealt with using the following:
There is a security feature in the VPN client that blocks local connections, including local Internet access, to protect the office/remote network. You can disable this if you wish. To do so on the client/connecting PC, go to:
control panel | network connections | right click on the VPN/Virtual adapter and choose properties | Networking | TCP/IP -properties | Advanced | General | un-check  "Use default gateway on remote network"

as for the 10.0.0.69 address. Try setting up a static address pool as outlined in the following link. You may want to compare your entire configuration as well.
http://www.lan-2-wan.com/vpns-RRAS-1nic.htm

0
 
Rob WilliamsCommented:
Thanks dolemite01.
Cheers !
--Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now