Solved

Multiple site to site VPN

Posted on 2008-06-10
5
291 Views
Last Modified: 2010-04-09
Hello this is my network setup 3 diffrent locations all have 5505 ASA device.

Main office is in norway and all the branch offices needs to be connected to the main office in norway but not to each other.

Currently the main office is connected to the other branch office in a remote location in norway.

What do i need to consider when im going to connect the Norway office with the Shanghai office?

Fixed ip is in place and im able to connect to the shanghai asa device from norway.

Thanks so much.

0
Comment
Question by:daxa78
  • 2
  • 2
5 Comments
 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
Comment Utility
Hi daxa78

You will need access to all three devices - you will need to know their outside IP addresses and you will need to know the subnets in use at each location.
Once you have this you will need to set up 2 VPN site to site connections from Norway and configure both Branch offices to talk back to the main site - the procedure is the same so you will need to do it 4 times

See my website for a walk through:)  http://www.petenetlive.com/Tech/Firewalls/Cisco/s2svpn.htm

0
 
LVL 1

Author Comment

by:daxa78
Comment Utility
Since i already have the VPN connection between the Main office and the branch office in norway up and running i dont have to consider this when setting up the new connection between main office and the shanghai office right? Meaning i only need to to it 2 times, since i did the first 2 already..

Thank you so much for the input.
0
 
LVL 57

Expert Comment

by:Pete Long
Comment Utility
No problems - your set up is quite straight forward - if you were to put in a site to site from branch office to branch office them add the following command

same-security-traffic permit intra-interface

but in a simple hub and spoke architecture like you have you dint need that command


other that that you are good to go :)
0
 
LVL 1

Author Comment

by:daxa78
Comment Utility
Still unable to connect to the shanghai office. Here is my config.

At the main office.

ASA Version 7.2(2)
!
hostname ciscoasa
domain-name sotra
enable password T1wFD.At.xaww6YF encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.10.1.2 255.255.255.0
 ospf cost 10
!
interface Vlan2
 nameif outside
 security-level 0
 pppoe client vpdn group telenor
 ip address pppoe setroute
 ospf cost 10
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
 ospf cost 10
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name sotra
access-list outside_access_in extended permit tcp any host 194.248.213.192 eq smtp
access-list outside_access_in extended permit tcp any host 194.248.213.192 eq https
access-list vpn3000_splitTunnelAcl standard permit 10.10.1.0 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip 10.10.1.0 255.255.255.0 10.10.5.0 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip 10.10.1.0 255.255.255.0 host 213.239.120.44
access-list inside_outbound_nat0_acl extended permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip 10.10.1.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list inside_outbound_nat0_acl extended permit ip 10.10.1.0 255.255.255.0 host 116.228.216.90
access-list outside_20_cryptomap extended permit ip 10.10.1.0 255.255.255.0 host 213.239.120.44
access-list outside_20_cryptomap extended permit ip 10.10.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list outside_40_cryptomap extended permit ip 10.10.1.0 255.255.255.0 host 116.228.216.90
pager lines 24
logging enable
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool vpnpool 10.10.5.230-10.10.5.245
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any echo-reply outside
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface smtp 10.10.1.1 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https 10.10.1.1 https netmask 255.255.255.255
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy vpn3000 internal
group-policy vpn3000 attributes
 dns-server value 10.10.1.1
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value vpn3000_splitTunnelAcl
aaa authentication ssh console LOCAL
http server enable 444
http 10.10.1.19 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set peer 213.239.120.44
crypto map outside_map 20 set transform-set ESP-DES-MD5
crypto map outside_map 40 match address outside_40_cryptomap
crypto map outside_map 40 set pfs
crypto map outside_map 40 set peer 116.228.216.90
crypto map outside_map 40 set transform-set ESP-3DES-SHA
crypto map outside_map 60 set pfs
crypto map outside_map 60 set peer 116.228.216.90
crypto map outside_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 30
 authentication pre-share
 encryption des
 hash md5
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group vpn3000 type ipsec-ra
tunnel-group vpn3000 general-attributes
 address-pool vpnpool
 default-group-policy vpn3000
tunnel-group vpn3000 ipsec-attributes
 pre-shared-key *
tunnel-group 213.239.110.44 type ipsec-l2l
tunnel-group 213.239.110.44 ipsec-attributes
 pre-shared-key *
tunnel-group 116.228.217.90 type ipsec-l2l
tunnel-group 116.228.217.90 ipsec-attributes
 pre-shared-key *
telnet timeout 5
ssh 10.10.1.0 255.255.255.0 inside
ssh timeout 60
console timeout 0
vpdn group telenor request dialout pppoe
vpdn group telenor localname so-grup@online.no
vpdn group telenor ppp authentication pap
vpdn username so-grup@online.no password ********* store-local
dhcpd auto_config outside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:a4c3f03455131d4f85d4940dc4227ad3
: end
asdm image disk0:/asdm-522.bin
no asdm history enable



And here is the config for the shanghai asa

ASA Version 7.2(3)
!
hostname shanghai
domain-name sotra.local
enable password Xr7i5wXJJq5IhbR/ encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 116.228.216.90 255.255.255.252
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 192.168.100.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!

interface Ethernet0/6
!
interface Ethernet0/7
 switchport access vlan 3
!
passwd Xr7i5wXJJq5IhbR/ encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name sotra.local
access-list outside_1_cryptomap extended permit ip 192.168.10.0 255.255.255.0 host 194.248.203.192
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 10.10.1.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.10.0 255.255.255.0 host 194.248.203.192
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp deny any outside
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 116.228.216.89 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 194.248.213.192
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 192.168.10.0 255.255.255.0 inside
ssh 192.168.1.0 255.255.255.0 inside
ssh 82.134.95.2 255.255.255.255 outside
ssh timeout 60
ssh version 2
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.10.110-192.168.10.120 inside
dhcpd dns 202.96.209.6 202.96.209.133 interface inside
dhcpd enable inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
tunnel-group 194.248.213.192 type ipsec-l2l
tunnel-group 194.248.213.192 ipsec-attributes
 pre-shared-key *
prompt hostname context
Cryptochecksum:e6d18ad23162bcd8283af8467ca30ebe
: end
asdm image disk0:/asdm-523.bin
no asdm history enable


Where did it all go wrong :-)
0
 
LVL 25

Expert Comment

by:Cyclops3590
Comment Utility
I'm not sure what or if there exists export laws between those two countries, but I know the US says nothing above 40-bit encryption is allowed (at least last I heard, not sure if they upped it or not).  But since you're connecting sites between different countries, although it is easily technically possible, depending upon the encryption used, it may be illegal.  

Maybe PeteLong knows better than me, but its something I'd be looking into anyway especially since one site sounds like its in China (unless its a different shanghai than I'm thinking).
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

Suggested Solutions

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
When I upgraded my ASA 8.2 to 8.3, I realized that my nonat statement was failing!   The log showed the following error:     %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows It was caused by the config upgrade, because t…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now