Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

how do you connect a cisco 1800 series router to an adsl line?

Posted on 2008-06-10
3
1,647 Views
Last Modified: 2013-12-14
I have been trying for the last day to get a cisco router to connect to an adsl line. i have tried configuring it but it has not connected. The line is pppoa. i have the config below, .I have never configured a cisco router on an adsl line. Any help would be greatly appreaciated.
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname freedom
!
boot-start-marker
boot-end-marker
!
enable secret 5 ********************
enable password ********************
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 85.189.238.254 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.0.12 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
 speed auto
 full-duplex
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no ip route-cache
 no atm ilmi-keepalive
 dsl operating-mode auto 
 pvc 0/1 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer0
 ip unnumbered Loopback0
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp chap hostname **************
 ppp chap password 0 ************
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password ***********
 login
!
scheduler allocate 20000 1000
end

Open in new window

0
Comment
Question by:espoke
  • 2
3 Comments
 
LVL 5

Assisted Solution

by:rslqld
rslqld earned 500 total points
ID: 21756123
First, generally need to tell the dialer what authentication method to use:

enable
conf t
int Dialer0
ppp authentication chap
CTRL+Z

Might also want to set "ip add auto" on the Dialer0 interface.

Then back at the top level of privileged-exec mode do a debug ppp and watch it run for a while, let us know of any errors.

May also want to do a 'show dsl operating-mode' and make sure the sync'd line state is what you expect it to be.
0
 

Author Comment

by:espoke
ID: 21758131
for some reason i dont get the command 'show dsl operating-mode' . but i have phoned the isp and they say the ling is up and that they can ping the router. i cant ping out of the router, or ping from our office(not the same one as the one that the router is in.the pvc settings are correct. i just cant see what is wrong with it any more.

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname freedom
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$FZn0$W78B7qb3kWB2BxVCcUiMn.
enable password elttaeS2008%
!
no aaa new-model
no ip routing
no ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
! 
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.0.12 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 no ip route-cache
 speed auto
 full-duplex
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 no ip route-cache
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no ip route-cache
 no atm ilmi-keepalive
 dsl operating-mode auto 
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer0
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname 4bsh-3qsn@tdl.broadband
 ppp chap password 0 Bridget
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer0 overload
!
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password elttaeS2008
 login
!
scheduler allocate 20000 1000
end                          
 
 
                                                      
freedom#sh int                                                                  
FastEthernet0/0 is up, line protocol is up                                      
  Hardware is Gt96k FE, address is 0017.59bb.84e0 (bia 0017.59bb.84e0)          
  Internet address is 192.168.0.12/24                                           
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,                                 
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation ARPA, loopback not set                                          
  Keepalive set (10 sec)                                                        
  Full-duplex, 100Mb/s, 100BaseTX/FX                                            
  ARP type: ARPA, ARP Timeout 04:00:00                                          
  Last input 00:00:00, output 00:00:00, output hang never                       
  Last clearing of "show interface" counters never                              
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  Queueing strategy: fifo                                                       
  Output queue: 0/40 (size/max)                                                 
  5 minute input rate 1000 bits/sec, 1 packets/sec                              
  5 minute output rate 1000 bits/sec, 1 packets/sec                             
     22224 packets input, 1921924 bytes                                         
     Received 12054 broadcasts, 0 runts, 0 giants, 0 throttles                  
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored                       
     0 watchdog                                                                 
     0 input packets with dribble condition detected                            
     27822 packets output, 3041005 bytes, 0 underruns                           
     0 output errors, 0 collisions, 5 interface resets                          
     0 babbles, 0 late collision, 0 deferred                                    
     0 lost carrier, 0 no carrier                                               
     0 output buffer failures, 0 output buffers swapped out                     
FastEthernet0/1 is administratively down, line protocol is down                 
  Hardware is Gt96k FE, address is 0017.59bb.84e1 (bia 0017.59bb.84e1)          
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,                                 
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation ARPA, loopback not set                                          
  Keepalive set (10 sec)                                                        
  Auto-duplex, Auto Speed, 100BaseTX/FX                                         
  ARP type: ARPA, ARP Timeout 04:00:00                                          
  Last input never, output never, output hang never                             
  Last clearing of "show interface" counters never                              
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  Queueing strategy: fifo                                                       
  Output queue: 0/40 (size/max)                                                 
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     0 packets input, 0 bytes                                                   
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored                       
     0 watchdog                                                                 
     0 input packets with dribble condition detected                            
     0 packets output, 0 bytes, 0 underruns                                     
     0 output errors, 0 collisions, 0 interface resets                          
     0 babbles, 0 late collision, 0 deferred                                    
     0 lost carrier, 0 no carrier                                               
     0 output buffer failures, 0 output buffers swapped out                     
ATM0/0/0 is up, line protocol is up                                             
  Hardware is DSLSAR (with Alcatel ADSL Module)                                 
  MTU 4470 bytes, sub MTU 4470, BW 160 Kbit, DLY 3200 usec,                     
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation ATM, loopback not set                                           
  Encapsulation(s): AAL5  AAL2, PVC mode                                        
  23 maximum active VCs, 256 VCs per VP, 1 current VCCs                         
  VC Auto Creation Disabled.                                                    
  VC idle disconnect time: 300 seconds                                          
  Last input never, output 00:00:04, output hang never                          
  Last clearing of "show interface" counters never                              
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 8         
  Queueing strategy: Per VC Queueing                                            
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     6287 packets input, 126513 bytes, 0 no buffer                              
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort              
     25240 packets output, 314993 bytes, 0 underruns                            
     0 output errors, 0 collisions, 0 interface resets                          
     0 output buffer failures, 0 output buffers swapped out                     
NVI0 is up, line protocol is up                                                 
  Hardware is NVI                                                               
  Interface is unnumbered. Using address of NVI0 (0.0.0.0)                      
  MTU 1514 bytes, BW 10000000 Kbit, DLY 0 usec,                                 
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation UNKNOWN, loopback not set                                       
  Last input never, output never, output hang never                             
  Last clearing of "show interface" counters never                              
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     0 packets input, 0 bytes, 0 no buffer                                      
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort              
     0 packets output, 0 bytes, 0 underruns                                     
     0 output errors, 0 collisions, 0 interface resets                          
     0 output buffer failures, 0 output buffers swapped out                     
Virtual-Access1 is up, line protocol is up                                      
  Hardware is Virtual Access interface                                          
  MTU 1500 bytes, BW 100000 Kbit, DLY 100000 usec,                              
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation PPP, LCP Closed                                                 
  Base PPPoATM vaccess                                                          
  Vaccess status 0x44, loopback not set                                         
  DTR is pulsed for 5 seconds on reset                                          
  Last input never, output never, output hang never                             
  Last clearing of "show interface" counters 1d19h                              
  Input queue: 0/4096/0/0 (size/max/drops/flushes); Total output drops: 0       
  Queueing strategy: fifo                                                       
  Output queue: 0/40 (size/max)                                                 
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     0 packets input, 0 bytes, 0 no buffer                                      
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort              
     0 packets output, 0 bytes, 0 underruns                                     
     0 output errors, 0 collisions, 0 interface resets                          
     0 output buffer failures, 0 output buffers swapped out                     
     0 carrier transitions                                                      
Virtual-Access2 is up, line protocol is up                                      
  Hardware is Virtual Access interface                                          
  MTU 1500 bytes, BW 160 Kbit, DLY 20000 usec,                                  
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation PPP, LCP Open                                                   
  Listen: CDPCP                                                                 
  Open: IPCP                                                                    
  PPPoATM vaccess, cloned from Dialer0                                          
  Vaccess status 0x44                                                           
  Bound to ATM0/0/0 VCD: 4, VPI: 0, VCI: 38, loopback not set                   
  Keepalive set (10 sec)                                                        
  Interface is bound to Di0 (Encapsulation PPP)                                 
  Last input 00:06:03, output never, output hang never                          
  Last clearing of "show interface" counters 17:22:58                           
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  Queueing strategy: fifo                                                       
  Output queue: 0/40 (size/max)                                                 
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     6287 packets input, 126513 bytes, 0 no buffer                              
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort              
     6031 packets output, 84485 bytes, 0 underruns                              
     0 output errors, 0 collisions, 0 interface resets                          
     0 output buffer failures, 0 output buffers swapped out                     
     0 carrier transitions                                                      
Virtual-Access3 is down, line protocol is down                                  
  Hardware is Virtual Access interface                                          
  MTU 1500 bytes, BW 100000 Kbit, DLY 20000 usec,                               
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation PPP, LCP Closed, loopback not set                               
  Last input never, output never, output hang never                             
  Last clearing of "show interface" counters 17:22:58                           
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  Queueing strategy: fifo                                                       
  Output queue: 0/40 (size/max)                                                 
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     0 packets input, 0 bytes, 0 no buffer                                      
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort              
     0 packets output, 0 bytes, 0 underruns                                     
     0 output errors, 0 collisions, 0 interface resets                          
     0 output buffer failures, 0 output buffers swapped out                     
     0 carrier transitions                                                      
Dialer0 is up, line protocol is up (spoofing)                                   
  Hardware is Unknown                                                           
  Internet address will be negotiated using DHCP                                
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,                                   
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation PPP, loopback not set                                           
  Keepalive set (10 sec)                                                        
  DTR is pulsed for 1 seconds on reset                                          
  Interface is bound to Vi2                                                     
  Last input never, output never, output hang never                             
  Last clearing of "show interface" counters 1d19h                              
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  Queueing strategy: weighted fair                                              
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)                    
     Conversations  0/0/16 (active/max active/max total)                        
     Reserved Conversations 0/0 (allocated/max allocated)                       
     Available Bandwidth 42 kilobits/sec                                        
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     6274 packets input, 126244 bytes                                           
     6017 packets output, 84238 bytes                                           
Bound to:                                                                       
Virtual-Access2 is up, line protocol is up                                      
  Hardware is Virtual Access interface                                          
  MTU 1500 bytes, BW 160 Kbit, DLY 20000 usec,                                  
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation PPP, LCP Open                                                   
  Listen: CDPCP                                                                 
  Open: IPCP                                                                    
  PPPoATM vaccess, cloned from Dialer0                                          
  Vaccess status 0x44                                                           
  Bound to ATM0/0/0 VCD: 4, VPI: 0, VCI: 38, loopback not set                   
  Keepalive set (10 sec)                                                        
  Interface is bound to Di0 (Encapsulation PPP)                                 
  Last input 00:06:03, output never, output hang never                          
  Last clearing of "show interface" counters 17:22:59                           
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0         
  Queueing strategy: fifo                                                       
  Output queue: 0/40 (size/max)                                                 
  5 minute input rate 0 bits/sec, 0 packets/sec                                 
  5 minute output rate 0 bits/sec, 0 packets/sec                                
     6287 packets input, 126513 bytes, 0 no buffer                              
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles                      
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort              
     6031 packets output, 84485 bytes, 0 underruns                              
     0 output errors, 0 collisions, 0 interface resets                          
     0 output buffer failures, 0 output buffers swapped out                     
     0 carrier transitions          

Open in new window

0
 
LVL 5

Accepted Solution

by:
rslqld earned 500 total points
ID: 21764356
By the looks of it you're probably suffering from auth issues -- WAN interface isn't getting an IP address.

Try running a debug on ppp requests and monitor it a bit.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Range of IP address for whitelist 8 86
BT Home Hub not receiving emails 4 60
scechduled reboot 4G LTE routers 2 94
Synching 20Gig  file with Google drive 6 104
    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
This solves the problem of diagnosing why an internet connection is no longer working. It also helps identify the likely cause of the lost connection if the procedure fails to re-establish your internet connection. It helps to pinpoint the likely co…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question