Solved

cannot connect to users desktop

Posted on 2008-06-10
18
237 Views
Last Modified: 2008-06-11
We have a single sbs2003 server which we are using with around 10 xppro clients. We have remote access setup for accessing e-mail, which has been working fine. We now need to allow remote users to access their desktops also.
When we login we get the usual screen, and we can access all mail without a problem. When we try to connect to the users desktop, we get the list of workstations available. When we select the users computer, we get a short wait then the error "The client could not connect to the remote computer. Remote connections might not be enabled, or the computer might be to busy to accept new connects.
The local client, ie the one we are trying to access remotely, is using AVG with no firewall present. ie we are using the Microsoft Firewall, I can see that there are exceptions in here to allow remote (RDT) connections.
Does anyone have any ideas why we can access mail OK, but not the desktop?
Any help you can give would be appreciated.
0
Comment
Question by:nigelbeatson
  • 7
  • 6
  • 4
  • +1
18 Comments
 
LVL 13

Expert Comment

by:mrroonie
Comment Utility
i didnt think it mattered when using remote web workplace but you may need to enable connections in My Computer properties - Right Click My Computer>Properties>Remote tab>tick Remote Desktop (halfway down screen)and then select users
0
 
LVL 3

Expert Comment

by:ddanonimity
Comment Utility
The client computer may not be set up to recieve RDP connections. To check this dot the following on the client workstation:

>>Right click on MyComputer
>>Select Properties
>>Select the Remote Tab and make sure that the "Allow users to connect remotely to this computer" check box is checked.

If it's not this I would suggest that it is something to do with user rights. Do you use Active directory. If so make sure you connecting with the following method.

[YourDomain]\[Username]

Let me know how it goes
0
 

Author Comment

by:nigelbeatson
Comment Utility
I have checked that all rights are enabled for remote desktop connections as outlined above.
Could you please expand on the yourdomainname/username entry, as I am unsure as to what format this should be. Logging in using the username and password lets me in ok, but when I try to build in the local domain name, it produces a login error. i tried localdomainname\username and password, but it fails to log in. As I said, when we login using the username and password, it lets me in OK, to the menu, where we can access mail without a problem.
Please advise.
0
 
LVL 3

Expert Comment

by:ddanonimity
Comment Utility
as your connecting via RDP you normally have to log in using a username and password.
 [your domain] = what domain the remote computer is on, (e.g if it's mircosoft.com you may use jsut microsoft).

[Username] = the username you are loggin onto the remote computer with(e.g fred).

In this case it becomes microsoft\Fred in the username box.

If you are using active directory then you need to specify a the domain name beforehand or it will try to log onto a local user profile on the remote machine which probably doesn't even exist if your using Active Directory
0
 

Author Comment

by:nigelbeatson
Comment Utility
we are using active directory, but the domainname\username does not work. One thing that I have just thought of, is that I am setting this up within the domain, ie I am physically connected to the network. This would probably explain why the domain name is not required for this instance. Would this also explain why we cannot access the desktop?
Mail is not a problem, so I presumed I could set the desktop up locally before the user takes it to their remote connection, to ensure that it worked correctly.
Please advise.
0
 
LVL 3

Accepted Solution

by:
ddanonimity earned 250 total points
Comment Utility
e-mail and RDP work on diffrent protocols which explains why one would work and the other wouldn't. You also need to make sure you have the Remote Desktop Users permission in the active directory to allow you to connect.

Do you get an error message when you try? What is the specifc message?
0
 
LVL 25

Expert Comment

by:slam69
Comment Utility
Hi,

Make all users local admin on the machines they are trying ot get to then retest.

i imagine they will then be able to log on, if so remove from admin groups and then add to the rdp group.

if you still cant connect check that teh firewall you are using isnt blocking port 3389 as this is the one RDP routes through
0
 

Author Comment

by:nigelbeatson
Comment Utility
We can connect to our server remotely, using rdt, so I am pretty sure that the port 3389 is open, or we would not be able to do this.
I did not have the users added to the remote desktop user group, but having added them, and re logged on the workstation, we still can connect to the desktop.
The error message produced is that detailed in my question, ie The client could not connect......
All users are configured as local admin on the required workstations.
Could this be down to the fact that we are trying to set this up connected to the network, rather than being at a remote location?? I seem to remember having a similar problem when setting up some other service. ie it worked OK remotely, but would not work when connected locally.
0
 
LVL 25

Expert Comment

by:slam69
Comment Utility
no you should be a ble to have the machiens sat next to each other on same domain and network and remote to them fine as that is what i am doing now between my laptop and desktop!!

Have the machines got windows firewall disabled on them?
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 25

Assisted Solution

by:slam69
slam69 earned 250 total points
Comment Utility
***To Disable Windows XP Firewall***

1.  Open Network Connections (Click Start, click Control Panel, and then double click Network Connections.)
 
2.  Click the Dial up, LAN or High–Speed Internet connection that you want to protect, and then, under Network Tasks, click Change settings of this connection.
 
3.  On the Advanced tab, under Internet Connection Firewall, select the following:  Clear the Protect my computer and network by limiting or preventing access to this computer from the Internet check box. This disables the firewall, your computer and network are then vulnerable to intrusions.
0
 
LVL 25

Expert Comment

by:slam69
Comment Utility
i can see you state in your post actually you are using windows firewall

disable and then try connecting if that works then you know where the problem lies and my guess would be the internet connection firewall
0
 

Author Comment

by:nigelbeatson
Comment Utility
OK, Thanks, I will give that a try. I have just left site and have tried it from a totally remote connection, and, as you said, this does not work either.
Will be back on site tomorrow morning, and will update you then.
Many thanks.
0
 
LVL 25

Expert Comment

by:slam69
Comment Utility
no problem im off soon myself so speak tomorrow im not in till after lunch
0
 

Author Comment

by:nigelbeatson
Comment Utility
OK, here is where we are at.
I have tried your suggestion to dissable the firewall, but I could not see the option you refer to. ie "Protect my computer and network by limiting or preventing access to this computer".
I could not, for some reason dissable the Microsoft firewall, as the settings were greyed out. I did stop the firewall service though, if this acheives the same effect, but unfortunately, we still could not connect to our desktop.
We can connect to the server using RDT, locally and remotely. We can access e-mail locally and remotely. We have port 3389 open, and we have added the user to the RDT group in our active directory. We have (we think) dissabled the firewall by stopping the firewall service, but we are still unable to connect to the users desktop. Do you have any other ideas? This is using SBS2003, surely it should not be this difficult. Am I missing something?
Any help you can would be appreciated.
I have just tried to access the required workstation locally, using RDT, but we get the message that our domain does not contain any Terminal Servers???
0
 

Author Comment

by:nigelbeatson
Comment Utility
I should add that this error only appears when we try to browse for the required workstation. If we enter the local IP address, it connects fine.
0
 
LVL 3

Expert Comment

by:ddanonimity
Comment Utility
Sounds like there may could be the DNS not bieng correct. If the IP address in the DNS list for the computer name is not correct it won't connect.
0
 

Author Comment

by:nigelbeatson
Comment Utility
OK, Thanks everyone, I have now managed to resolve the issue. Whilst we had port 3389 open for RDT, we also needed port 4125 open for RWW. Since we have activated this, it works perfectly.
0
 
LVL 25

Expert Comment

by:slam69
Comment Utility
excellent i just got logged in... close question as you deem appropraie
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

You may have discovered the 'Compatibility View Settings' workaround for making your SBS 2008 Remote Web Workplace 'connect to a computer' section stops 'working around' after a Windows 10 client upgrade.  That can be fixed so it 'works around' agai…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
Saved searches can save you time by quickly referencing commonly searched terms on any topic. Whether you are looking for questions you can answer or hoping to learn about a specific issue, a saved search can help you get the most out of your time o…
Where to go on the main page to find the job listings. How to apply to a job that you are interested in from the list that is featured on our Careers page.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now