Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 378
  • Last Modified:

MS SQL 2005 :: WorkGroup connection

Dear Experts,

I am trying to publish my software on a customers network with a workgroup configuration.
Using Delphi 7 and SQL 2005.

I have set the SQL Server to Mixed Mode Authentication and have also change it to allow remote connection.

My application will not connect to the server unless I right click on it and select the "Run As" administrator options. Where is the problem? I have change settings on SQL but no success.
I am wondering if the security issues is not on Windows itself.

Please!
0
Marius0188
Asked:
Marius0188
  • 6
  • 5
  • 2
1 Solution
 
developmentguruPresidentCommented:
SQL Server communicates on port 1433 through TCP/IP using sockets.  Check to see if the port is being blocked by a firewall or something similar.

http://support.microsoft.com/kb/287932
0
 
Salim FayadCommented:
Try to create a Sql user and use it to connect to the Sql server. I guess it is a security problem.
0
 
Marius0188Author Commented:
But I am using the sa user and it has all the rights and access to the db.
What else can I check for?

Ports is open and all firewalls been disabled, server & client.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
Salim FayadCommented:
I have couple of questions:
1. Are you impersonating your application to one user?
2. Are you using the "sa" user in your connection string to the database, or are you setting "SSPI = true"?
0
 
Marius0188Author Commented:
I am using the sa user in connection string.
Did originally tried Windows Authentication but when it failed I tried "sa" login.
I have create several "Logins" with full rights, did not work.
I have create several "Users" on the relevant db with full rights, did not work.

I have checked the port 1433 is open.
I can connect with SQL Studio Express from the Client to Server with both options:
1. WIndows Authentication
2. Mixed Mode, using any of all the different users and logins I've created.

But interesting, given all the above. I can not connect with telnet to the server on port 1433 but I then used Arez Port Scanner software and it only reported 1 port as closed, port 192.

How can this possible be right?

Can someone please give me the connection string using the following values:
ServerName = "nvsp"
UserID = "sa"
Password = "12345"

as I am thinking that I am going mad and maybe have the connection string totally wrong.
NB: I won't use Windows Authentication.


Pleeeeeeeeassssse Help. :)
0
 
developmentguruPresidentCommented:
 I think the server name is your issue.  If they are not on your domain then they will not get DNS lookup for a server name.  You may need to set up a VPN as this would make them part of your network then, instead using the IP address of your server instad of it's name (removing the need for DNS).  A good test for this is to see if you can ping your database server by name or IP address.
0
 
Salim FayadCommented:
Here is the connection string: (where is your DB?)
Data Source=nvsp; Initial Catalog=DatabaseName;uid=sa;pwd=12345;

Open in new window

0
 
Marius0188Author Commented:
My database is on the server, NVSP.
0
 
Marius0188Author Commented:
BTW: It is on a workgroup not domain.
But with SQL Management Studio Express I can connect to server db from client using Windows or Mixed mode. Why can;t my application do that?
0
 
Salim FayadCommented:
I need to know the following:
- Server Name
- Connection String
0
 
Marius0188Author Commented:
Server Name: NVSP
Database Name: NVS

ConnectionString :=

Provider=SQLOLEDB.1;
Password=mvt0188;
Persist Security Info=True;
User ID=sa;
Initial Catalog=NvS;
Data Source=NVSP
0
 
Salim FayadCommented:
Try to change your connection string to the following:

Provider=SQLOLEDB;
Data Source = NVSP;
Initial Catalog=NVS;
Integrated Security=SSPI

For more information about how to write your connection string:
http://www.connectionstrings.com/
0
 
Marius0188Author Commented:
I have tried that as well, except for the "SQLOLEDB".
Only used "SQLOLEDB.1".

What is the difference?
0

Featured Post

Free recovery tool for Microsoft Active Directory

Veeam Explorer for Microsoft Active Directory provides fast and reliable object-level recovery for Active Directory from a single-pass, agentless backup or storage snapshot — without the need to restore an entire virtual machine or use third-party tools.

  • 6
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now