get this when logging on as a user

Hope someone can help, this was working in our test OU, when we went domain wide this script isn't disableing the usb ports,It will if ran manually under a domain admin account sure it's just a matter of permisions, am attatching a screenshot of the entire error,any help/advice would be greatly appreciated. Thanks in advance
Who is Participating?
raptorjb007Connect With a Mentor Commented:
If by grant access to allow the change in the registry you are mean to modify the permissions for that Key to simply allow your original script to work. Yes, this can be done through group policy in:

Add the key to the policy and grant the "full control" permission to users.

This will allow users to modify that key, thus allow your logon script to work.
it looks like the user does not have access to edit the registry. You could try adding a runas to the login script

see here for details on using the command:
I would recommend applying this script via group policy using a computer policy.
Computer Configuration->Scripts->Startup

If run as a computer startup script the script is run as the computer on instead of the user bypassing the permissions issue with a limited level user account. It will also run when the computer boots up rather than when the user logs on, keep this in mind as it effects all users who log into a computer with this policy applied..

In group policy there are four types of script that can be run, computer(Startup, shutdown) and user(login, logoff). Of these, only the user logon scripts will run as the user, the other three run as Localsystem.

There are also ADM templates that can resolve this issue in group policy without the use of a script. Let me know if you would like additional information regarding this.
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

Toni UranjekConsultant/TrainerCommented:

Standard user has no permissions to edit HKLM part of the registry. If suggestions to run script as startup script don't work for you, use GPO to change security settings on these particular registry keys.


dklahnAuthor Commented:
I had thought of that, the only problem is in each of our ou's,there are a few users who do need to have access to usb devices, mostly cameras with sd cards, as far as I know,theres really no way to pick and choose witch ones allow/deny,thats why I've been trieing to do this with 2 log on scripts one to allow,and one to deny
Toni UranjekConsultant/TrainerCommented:
Group policy alows you to use Security filtering. Assign GPO to OU, create only one global security group, for example "Prohibit use of USB devices" and assign the following policy to this group: Apply Group Policy - Deny.

If you need more information, let me know...
Since most of the solutions for this problem involve modifying the HKLM registry, these will all be computer based solutions rather than user.

You may be able work around this by combining solutions.

-Create a Security group to define the users who need to have USB access.
-Use a GPO to apply the script to resticts access for both the startup(computer) and logoff(user) to the managed OU.
-Use a GPO to grant modify access to the key for the previously defined security group. Be sure to add the default ACL settings for the KEY in GPO as it set the ACL only to what is defined in the GPO.
-Assign a logon script, preferably by an account profile script. However a GPO logon script can work if AD is organized enough to allow you to effect only the target users.

This way when the a unrestricted user logs in, they have permission to modify the key so the script can un-restrict them. The logoff and startup scripts will reset the restriction so another user cannot simply log in after them or reboot to gain access.
dklahnAuthor Commented:
makes sense, is there anyway to just allow the change in the registry through gpo?thanks again
Toni UranjekConnect With a Mentor Consultant/TrainerCommented:
Check this article:

"Apply or modify permission entries for objects using Group Policy"
dklahnAuthor Commented:
thanks alot guys,it works great now, really appreciate all the help
Glad to be of assistance.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.