Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Arabic Text is appearing as ??????

Posted on 2008-06-10
8
Medium Priority
?
917 Views
Last Modified: 2013-11-26
I am facing problem in running my ASP.net Application with Oracle on IIS6.0.
I have installed the MUI, have checked my application also for Unicode and arabic language support also, but the arabic text is appearing as ??????????
Is there any solution to the problem?
0
Comment
Question by:shahzoor
  • 4
  • 3
8 Comments
 
LVL 18

Expert Comment

by:Joel Coehoorn
ID: 21753198
You need to change the encoding for the page used by asp.net:
http://msdn.microsoft.com/en-us/library/39d1w2xf.aspx
0
 
LVL 6

Expert Comment

by:rafayali
ID: 21754496
Have you configured localization in your ASP.NET application? For example, what values are set for Page.UiCulture and Culture attributes of the Page?
0
 
LVL 14

Author Comment

by:shahzoor
ID: 21757114
All cultures are Arabic Saudi Arabia and utf 8
but still the question marks are there
i followed the link sent by coehoorn also
http://msdn.microsoft.com/en-us/library/39d1w2xf.aspx

but still the problem is the same
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
LVL 14

Author Comment

by:shahzoor
ID: 21757732
page ui culture is also ar-sa
i tried windows-1256 and utf-8
both are not working
0
 
LVL 6

Expert Comment

by:rafayali
ID: 21760321
Try adding the language in Internet Explorer and see if that works.

Goto Tools -> Internet Options -> Languages and the Arabic language from Saudi Arabia. Close the browser and restart the IE and browse to web app again. SEe if that works. Also, once you add a language make sure that ar-sa is at the very top of the list.
0
 
LVL 6

Expert Comment

by:rafayali
ID: 21760373
Another thing to try is to check whether codepage attribute is specified in your asp.net page. If not, it should be specified in the Page Declaration as an attribute and it should be set to utf-8.

Also, to achieve the same effect you can place this in your web.config

<globalization requestEncoding="utf-8" responseEncoding="utf-8" />
0
 
LVL 14

Author Comment

by:shahzoor
ID: 21761137
i have checked the configuration
windows-1256 works with the asp.net application using MS Access on IIS6.0
But it stops working when i try to connect it to oracle database.
0
 
LVL 14

Accepted Solution

by:
shahzoor earned 0 total points
ID: 21788089
the problem was due to nls_lang in oracle
thanks for your help
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The article shows the basic steps of integrating an HTML theme template into an ASP.NET MVC project
Simulator games are perfect for generating sample realistic data streams, especially for learning data analysis. It is even useful for demoing offerings such as Azure stream analytics, PowerBI etc.
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…

916 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question