Solved

I have just loaded UBUNTU OS and I cannot get firefox to browse

Posted on 2008-06-10
16
251 Views
Last Modified: 2013-12-07
I have loaded UBUNTU onto a PC. I am not in any way familar with linux. The OS is using firefow as a browser. I have attached the PC to a router which is running DCHP. The network within UBUNTU is picking up a correct IP address and dns. The router has an ip of 192.168.1.1, the PC has ip of 192.168.1.2 with subnet 255.255.255.0.
I can ping any url eg bbc.co.uk, or google.com etc. I cannot browse to bbc.co.uk or any other url. I can however go to google home page by entering its ip address (66.264.93.104 or 64.233.186.99, but cannot browse to bbc.co.uk using 212.58.224.131 or any variation of bbc.co.uk. Also if i search google for bbc it displays the search results but wont let me browse to these. This is true for all sites I have tried.
0
Comment
Question by:wmccourt
  • 8
  • 5
  • 2
  • +1
16 Comments
 
LVL 40

Expert Comment

by:noci
ID: 21757307
From your description i gather that your name resolution is not working.

You might need to setup your modem as a DNS client correctly or you still need to add the DNS to your ubuntu config.

The first depends on your modems configuration options & capabilities. (I assume that if it is setup correctly it will transport the data throught DHCP.)

If the data is not setup by DHCP, then you can configure the setup yourself:

1) Use the modem as DNS server ...

edit /etc/resolv.conf to contain:
---8<---
domain yourprivate.domain       # or local
search 192.168.1.1
---8<---

2) Setup the DNS
---8<---
domain yourprivate.domain       # or local
search <dns.server1.addr.ess>
search <dns.server2.addr.ess>
---8<---

Where <dns.serverX.addr.ess> is replaced with the IP address that your
provider issued.

If this doesn't work out, please provide the original content of these files.
...

You can check the workings of DNS resolution through the 'dig' tool.

dig google.com          - should provide the dns answer & query data.
dig -x 66.264.93.104 - should provide the backward translation.
0
 

Author Comment

by:wmccourt
ID: 21759246
Hi Noci

Thanks for taking the time to reply to my question. I have tried to take your advice - however the text editor tells me I do not have write permissions to alter the resolve.conf file. I have tried to change these permissions however the owner is set to 'root'. I have tried logging in as 'root' but dont know the UBUNTU default password for root.
Any ideas?
0
 
LVL 17

Expert Comment

by:owensleftfoot
ID: 21759343
Just use the sudo command and your own password ie sudo gedit, when it asks for a password put in your own. Thats the way it works for root access in ubuntu.
0
Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

 

Author Comment

by:wmccourt
ID: 21759820
Hi All,

The sudo command did the trick. However still cant browse. Will take me to google.com using the ip but not the name. No other web site available by name. I can browse to the router address for maintnenance.

Contents of resolve.conf is:-
domain mccnet
search 212.85.249.148
search 212.85.249.130 (these are ip of my ISP dns servers)
nameserver 192.168.1.1 (my router IP)

The original contents of this file were as above but without the 'search' lines
I have attached the results of the dig command below.
ubuntu.txt
0
 
LVL 40

Expert Comment

by:noci
ID: 21763686
Please note the name is: resolv.conf
NOT resolve.conf (it's a leftover from the time when names had to be short....)


0
 

Author Comment

by:wmccourt
ID: 21767348
Sorry, just a typo
0
 

Expert Comment

by:andylockran
ID: 21767899
wmccourt.

Now that you have resolv.conf set up correctly - try running the dig tool again.

dig www.google.com

any luck?
0
 

Author Comment

by:wmccourt
ID: 21768891
Hi All,
see attached file of dig results. Also content of resolv.conf. (Both attached files are txt files showing contents). I can receive e-mail, but not sednd, I can ping bbc.co.uk but not browse, i can ping google.com, but not browse, I can browse to googles ip adress and even search on it, but not browse to any resulting sites. I can use firefox to browse to my router and make changes to it. By the way the router also acts as my router on a separate windows sbs network and is fine.

help!!
dig-stuff.txt
resolv.conf.txt
0
 

Expert Comment

by:andylockran
ID: 21768918
Ok, so the dig command makes it look like DNS is working properly.

In Firefox 3 that's:

Edit>Preferences>Advanced>Network>Settings>Auto-detect Network Settings.

Let me know if you can't find the same settings in your version.
0
 

Author Comment

by:wmccourt
ID: 21769251
hi andylockran
It appears I have V1.5.0.5 of firefox.
Under edit - preferences-general-connection settings,
I have the following choices -
direct internet connection
auto-detect proxy settings for this network,
or
manual proxy settings.
I have tried the 1st two with no luck.
0
 

Expert Comment

by:andylockran
ID: 21769311
Which version of ubuntu are you running?  It would appear that you are quite far behind if you're still on version 1 (as version 3.0beta is the current version).

Perhaps it'd be better if you'd upgrade the whole system  - that may go some way to resolving your problem.

If you want help on doing this, feel free to contact me directly.
0
 

Author Comment

by:wmccourt
ID: 21769442
Hi andylockran

I'm using version 6.06lts which I downloaded about a week ago. should I look for a more recent version and if so what version number.

Thanks
0
 

Accepted Solution

by:
andylockran earned 250 total points
ID: 21769487
You've been sensible in downloading a LTS release, however, there was new one released at the beginning of may - Hardy Heron 8.04 LTS.

It'll be better if you do a fresh install, as the upgrade path is via all the intermediate versions.

www.ubuntu.com has the latest news and information.  Also 'loco' teams (localised community support) are fantastically helpful, and I'm a member of #ubuntu-uk to pass back the help they gave me.

Keep me updated on how you're getting on.
0
 

Author Comment

by:wmccourt
ID: 21769600
Ok. I'm downloading V8.04 as we speak. How do I contact you again?. You get the points by way.
I'll close this when I get your contact info.
Thanks

Willy McCourt.
0
 

Expert Comment

by:andylockran
ID: 21769702
email ubuntu@zrmt.com
0
 

Author Comment

by:wmccourt
ID: 21770125
Thanks

I'll get back to you

0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

806 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question