Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Setting up two access points with same SSID

Posted on 2008-06-10
11
15,512 Views
Last Modified: 2013-11-12
I have the following network setup:

Linksys 8 port router (RV082) at the center of my network. DHCP server turned on.
Two linksys wireless g routers (WRT54G and WRT54GS respectively) connected to the main router via a wire. DHCP servers turned off.

Several clients are connected both wired and wirelessly.

Both the wireless routers have identical wireless settings, except one is on channel 1, the other on channel 11.

I expected this to cause the two routers to behave like access points, allowing my computer to connect to whichever one is stronger. But when I do this, computers cannot connect to the network at all (Limited Connectivity warning). If I change the SSIDs around so they are different, I can connect to either one. I hear people on forums suggesting that the routers must be in "AP" mode. But I can't find this setting.

Third party firmware is out of the question.

How do I set up the routers to both have the same SSID and behave as access points?
0
Comment
Question by:Frosty555
11 Comments
 
LVL 8

Accepted Solution

by:
Jeff Perry earned 400 total points
ID: 21753602
Set both to infrastructure mode and make sure security settings on both are identical that way the client set up to poll for XXX SSID will choose the best connection and authenticate to it.

On the client side make sure that you have the SSID and security setting set and have it set to Access Point (infrastructure mode) and check the automatically connect to non-preferred networks.

Getting this to work with residential grade equipment can be hit or miss in any event.
0
 
LVL 31

Author Comment

by:Frosty555
ID: 21755257
I can't find any setting on the linksys routers called "infrastructure" mode. Everyone talks about this setting, "infrastructure" mode, or "AP" mode, or "access point" mode but I can't seem to find it. Do you know where it is?
0
 
LVL 32

Assisted Solution

by:LucF
LucF earned 100 total points
ID: 21764517
Hello Frosty555,

I'll be answering your short summary of your question here, it's a reply to "How do I set up the routers to both have the same SSID and behave as access points?" but as far as I can see suits all of your story.

I'm pretty sure you're making one little mistake.
Turning off the DHCP server doesn't mean the WRT54G and WRT54GS will automatically pass through the DHCP information from the RV082 as there's still a NAT inbetween.

The simplest way of turning the wireless routers you have into access points is to indeed disable the DHCP servers and connect them to the RV082 through one of the LAN ports instead of the WAN port. Note that you will have to change the local IP of both wireless routers so they don't conflict with the RV082's IP.

For example, if the RV082 is till at its default IP of 192.168.1.1, change the WRT54G to 192.168.1.2 and the WRT54GS to 192.168.1.3 and connect them with one of their LAN ports to the RV082.

After setting this up, you can indeed match the wireless network settings on the WRT54G & WRT54GS to get everything up-and-running. Keep in mind that as those routers won't do any routing anymore, any access rules will have to be set on the RV082.

Best regards,

LucF
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 31

Author Comment

by:Frosty555
ID: 21768996
I think I see what you are saying. Do not use the WAN port because I want to bypass the NAT functionality of the router. You're sort of describing this: http://kbserver.netgear.com/kb_web_files/n101496.asp
But this is what I am doing. The routers are connected via the LAN ports, the wan port on the wireless router is not used at all.

Some have suggested that the problem is that the DHCP signals are not being relayed properly from the RV082 through to the wireless routers. I don't know why this would work when they are on different SSIDs, and not when they are on the same SSID... but does it sound possible?

0
 
LVL 31

Author Comment

by:Frosty555
ID: 21769065
I'll post more information about my setup, just so everyone is clear:


Linksys RV082
IP: 192.168.64.1
DHCP: ON, range from 100-150
VPN: OFF
DMZ Host: (none)
WAN Settings: static ip/dns/gateway provided by ISP
    WAN:     Internet Connection
    LAN1:    Computer
    LAN2:    WRT54G
    LAN3:    WRT54GS
 
Linksys WRT54G
IP: 192.168.64.2
SSID: TestNetwork
Mode: Mixed
WEP: 64bit, key 1: 1234001234
DHCP: OFF
DMZ Host: (none)
WAN Settings: Obtain IP Automatically
    WAN:     (none)
    LAN1:    RV082
    LAN2:    (none)
    LAN3:    (none)
 
 
Linksys WRT54GS
IP: 192.168.64.3
SSID: TestNetwork
Mode: Mixed
WEP: 64bit, key 1: 1234001234
DHCP: OFF
DMZ Host: (none)
WAN Settings: Obtain IP Automatically
    WAN:     (none)
    LAN1:    RV082
    LAN2:    (none)
    LAN3:    (none)

Open in new window

0
 
LVL 31

Author Comment

by:Frosty555
ID: 21789737
Still can't seem to get this to work...
0
 
LVL 32

Expert Comment

by:LucF
ID: 21789754
Hello Frosty555,

Sorry for the delay, I think I missed the notification of your previous comment.

The used network setup seems fine to me. Is there anything you change between the working and the non-working situation except for the SSID, if so what is it?
One single suggestion, can you disable UPnP on both wireless routers which you use as access points to prevent issues there?

Regards,

LucF
0
 
LVL 31

Author Comment

by:Frosty555
ID: 21804685
Seems to be that yes, just change the SSIDs and everything starts working. Keep them the same and nobody can connect... Although IT seems when it isn't working, I will change the SSIDs, and STILL nobody can connect for a few reboot cycles, then it suddenly jumps to life.

I will try disabling upnp. Should I do this on the wireless routers AND the main router? or just the wireless? I'll try both out. I'll get back asap, but probably that will be Thursday.
0
 
LVL 32

Expert Comment

by:LucF
ID: 21808184
Hi Frosty555,

Just on the routers which you use as an access point.
Even though I'm wondering if UPnP might cause these issues, I've seen weird issues caused by it before so I wouldn't be surprized if it helps.

Regards,

LucF
0
 
LVL 31

Author Comment

by:Frosty555
ID: 21846520
Nope, disabling upnp did nothing to help...

Strange. Maybe at some low level these routers rely on the uniqueness of the SSID, even though they're not supposed to?

I guess when trhadmin said "Getting this to work with residential grade equipment can be hit or miss in any event." he wasn't kidding. Darn. I will have to just setup all the computers to have both SSIDs as preferred wireless networks.
0
 

Expert Comment

by:siddharthmenon
ID: 21938416
Try these steps for testing :

1. Disable all security WPA etc ..
2. Change channel to 3 an 9 ( could be anything )
3. Now turn off one router and see if you can connect
4. Turn on the 2nd one and see if you can connect
5. Assign static IP to your PC and see if you can ping gateway

If at point no 4 everything works fine with the security disabled then the problem is the WPA settings. Try using WPA-Personal for both.

Suggestion:
If your using similar config for more than one AP/router then its always suggested to type and save it on text file and copy paste when ever configuring the network


Now if everything works fine at point 5 that is on static IP and your able to ping your gateway then the problem might be from DHCP relay. Could be that something is conflicting


Let us know the results
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question