• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5365
  • Last Modified:

"Access is denied" error when accessing any .msc administrative tools or .msi installer

Whenever I attempt to access any "Administrative Tools" (.msc files), I get an "Access is denied." error.

This includes:

Computer Management (compmgmt.msc)
Internet Information Services (iis.msc)
Services (services.msc)
Event Viewer (eventvwr.msc)... etc ...
 
I also get the same error when trying to run ANY .msi install package.

I can access the MSC snap-ins, if I go to an MMC console and add the snap-ins there, so I know that they are installed correctly.

I have given ownership and full permissions of the root directory and (Windows/System32) to my user login which is a member of the Administrators group.

I am using Windows XP Professional.  I am NOT in a domain.

I am at my wit's end, so I thank everybody in advance for their help!

Any thoughts?  
0
TwoHanded
Asked:
TwoHanded
  • 3
  • 3
  • 2
  • +5
1 Solution
 
andyms56Commented:
hi m8 do you have a good antivirus program and ant spyware as this is the normal behaver of a virus or spyware infection it looks you out of the admin tools so you cant disable it the bigest cause i come accross is a program named xp antivirus or vista antivirus both of them are spyware and will give you lots of headpain try downloading spybot s/d from http://www.safer-networking.org/index2.html
update it and run a full scan next do an online scan with this prog http://housecall.trendmicro.com/uk/
post back when done
andy
0
 
orangutangCommented:
0
 
jremy9Commented:
one thing that you might check is if you go

Start > Run > gpedit.msc > User Configuration > Administrative Templates > Windows  Components > Microsoft management Console > Restricted/Permitted Snap-ins.  Make sure that nothing is disabled.  Just change it to not configured.

Also for the Installer follow.

gpedit.msc > Computer Configuration > Windows Installer and make sure the Disable Windows Installer is not configured.
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
TwoHandedAuthor Commented:

andyms56:  I don't suspect that this is a virus, since I work as a developer and run a virus scan every day.   I am in the process of running SpyBot just in case.

orangutang: FixPolicies did not fix the problem.

jremy9:  Good suggestions, but everything is "Not configured" in both the Microsoft Management Console and the Windows Installer sections in gpedit.
0
 
orangutangCommented:
Can you send a screenshot of the error?
0
 
TwoHandedAuthor Commented:
0
 
jremy9Commented:
try this then
Run gpedit.msc
Navigate to User Configuration > Administrative Templates > Windows Components > Windows Explorer and look to see if the following policy is enabled:
Hides the Manage item on the Windows Explorer context menu
You can also check in the registry for the following key:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Make sure the value data for NoManageMyComputerVerb is 0
0
 
TwoHandedAuthor Commented:
orangutang:  YOU THE MAN!!

xp_mscfix.zip solved the MSC problem and msi_assoc.zip solved the MSI problem!!

Thanks alot - nice work!
0
 
grommet4Commented:
I ran into the same issue and fixed the problem by re-associating .msc files with the Microsoft Management Console (mmc.exe).  Navigate to the C:\Windows\System32 folder and right-click the eventvwr.msc file (or any .msc file).  Choose 'Open With'.  If you see the Microsoft Management Console listed at the top of the next window, click on it to highlight.  If you do not see the Microsoft Management Console, click Browse, navigate to C:\Windows\System32, and double-click the mmc.exe file.  With the Microsoft Management Console or mmc highlighted in the Open With box, check the box for 'Always use the selected program to open this kind of file'.  Click OK and see if the issue is resolved.
0
 
chriscady311Commented:
I too ran into this very same issue and was quickly fixed by following the advice given by grommet4. Worked perfectly! It had nothing to do with a virus, missing registry entries, access privileges nor permissions. By simply re-associating .msc files to open using the Microsoft Management Console fixed the problem!
0
 
atifnaeemmalikCommented:
solution 110% works :) Nice Job
0
 
JaimindiwanCommented:
Good Solution
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

  • 3
  • 3
  • 2
  • +5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now