Solved

Acess to Program Files on network drive

Posted on 2008-06-10
10
233 Views
Last Modified: 2012-05-05
I get "access denied" on one of the drive on my LAN when I try to open Program Files Folder.  It works fine on a drive on a different computer on the LAN.  Both drives are mapped to my computer and I can open other folders on each drive.  I am using xp home Service Pack 3 on all of the machines.
0
Comment
Question by:gtbsss57
  • 5
  • 4
10 Comments
 
LVL 12

Expert Comment

by:kadafitcd
Comment Utility
On the computers drive you are trying to access have you checked your permissions on the Program Files Folder?  You may need to change the permissions and make sure you are in a group with permissions to access the folder and all subdirectories and files.  You can do this by clicking advanced in the security tab and checkmarking the box that applies the permissions to all subdirectories and files.  

Also you may check the firewall on that machine as well and make sure its not blocking the connection.
0
 

Author Comment

by:gtbsss57
Comment Utility
I have checked and it says that I have permission to access the entire drive.  I have access to many of the folders but not the Program Files Folder.  The firewall gives me access to the machine and I have tried turning the firewall off with no change in the result.
0
 
LVL 5

Expert Comment

by:rslqld
Comment Utility
Check permissions under the 'Advanced' button of the security tab. The folder in question may not be inheriting permissions.
0
 
LVL 12

Expert Comment

by:kadafitcd
Comment Utility
Just because you have permissions for the entire drive doesn't mean that folders within the drive have the same permissions.  Like I posted above go check the advanced permissions of the program Files folder itself not the drive permissions.  You may need to apply a permission to yourself in here and checkmark the box to replace permissions on all subfolders and subdirectories.  

Good Luck HTH.
0
 

Author Comment

by:gtbsss57
Comment Utility
If I open windows explorer, right click on the Program Files, select Sharing & Security it tells me that "All the options on this tab are disabled because this folder is used by the operating system"  On another computer on the LAN I have access to the Program Files and when I try the same procedure it also shows the same message.
I know I am missing something but I don't know what.

0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 12

Expert Comment

by:kadafitcd
Comment Utility
Like I said you need to go into the advanced button in the security tab.  You are just checking under the sharing tab.  Click security at the top.  Then click advanced towards the bottom right.  Then add your user to the list with the proper permissions then click ok.  Then Checkmark the box next to replace permission entries on all child objects...  Then click apply and when it finishes ok.  Then you should have access.
0
 

Author Comment

by:gtbsss57
Comment Utility
How do I get to the security tab?  I can't find it.
0
 
LVL 12

Expert Comment

by:kadafitcd
Comment Utility
OK I take it you're running this on a Windows XP Home edition tower.  The problem is with XP Home Simple File Sharing restricts sharing of the Program Files folder and it is not accessible.  You can go within program files and individually share the folders that you need to access by right clicking on them going to sharing and security and sharing the folder.  There is not another good way that is 100% reliable to share the program files folder.  There are a couple of ways to do it but there is a risk.  Here is a link to a page where an MS MVP gave some advice on this but heed his warnings and make sure you take the proper precautions before messing with the file system.  
http://www.pcreview.co.uk/forums/thread-235248.php
Good Luck HTH.
0
 

Author Comment

by:gtbsss57
Comment Utility
Thanks.  In looking it appears that the computer that I have full access to is FAT32 and the one I am having trouble getting at is NTFS.
0
 
LVL 12

Accepted Solution

by:
kadafitcd earned 50 total points
Comment Utility
Yeah sounds like your problem is you're running NTFS in Windows XP Home which locks down the Program Files folder within it's simple file sharing feature.  You could try the steps in that link I gave you but make sure you've backed up everything first.  Good Luck HTH.
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

AWS Glacier is Amazons cheapest storage option and is their answer to a ‘Cold’ storage service.  Customers primarily use this service for archival purposes and storage of infrastructure backups.  Its unlimited storage potential and low storage cost …
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now