Barcode Font Does Not Show

Posted on 2008-06-10
Medium Priority
Last Modified: 2010-04-21
I have an ASP.NET website I've built that streams a Crystal Report to pdf format and displays it. One of the fields in the Crystal Report uses a barcode font(3 of 9). If I open the report locally by itself, I see the barcode font. If I run the website locally from my development box, I see the barcode font. When I run the website from the server, I Do Not see the barcode font. The field is displayed as regular readable text. I've tripple checked to make sure the font is installed on the server.

So, a recap... I've got a crystal report that uses a barcode font. By itself, it works great. In my webpage I load the crystal report in code, export it to PDF format and stream it to the browser (Internet Explorer), which then displays the crystal report in pdf format via its Acrobat Reader plug-in.

The problem is that once it's displayed in this fashion... no more barcode.
Help please.
Dim tmpReport As New CrystalDecisions.CrystalReports.Engine.ReportDocument
Dim strFileName As String = Server.MapPath("~/TimeSheet.rpt")
tmpReport.Load(strFileName, OpenReportMethod.OpenReportByDefault)
tmpReport.SetDatabaseLogon("<AccountName>", "<password>")
Dim oStream As New MemoryStream
oStream = tmpReport.ExportToStream(ExportFormatType.PortableDocFormat)
Response.Buffer = True
Response.ContentType = "application/pdf"

Open in new window

Question by:AaronNance
  • 2
  • 2
LVL 101

Accepted Solution

mlmcc earned 2000 total points
ID: 21755298
Same printer available in all 3 cases?
Crystal uses the printer driver to display reports.

Any permission issues with fonts?


Author Comment

ID: 21755414
We made sure we've got the same printer on the server that I've got installed locally. It doesn't seem to matter. The report still displays as a pdf with no barcode... just the text.

As for permission issues with fonts? Not sure what you mean there. We don't get any errors and the "Everyone" group has access to the Fonts directory at the moment.
LVL 101

Expert Comment

ID: 21755512
I wasn't sure how to state the permissions issue.  That should be what you need.

Not sure what the issue is.  I'll see what I can find.


Author Closing Comment

ID: 31465934
Didn't really solve the problem, but I wanted to close the question.
Thanks for the attempt. =)

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Just a quick little trick I learned recently.  Now that I'm using jQuery with abandon in my asp.net applications, I have grown tired of the following syntax:      (CODE) I suppose it just offends my sense of decency to put inline VBScript on a…
Introduction This article shows how to use the open source plupload control to upload multiple images. The images are resized on the client side before uploading and the upload is done in chunks. Background I had to provide a way for user…
The video provides a quick and easy steps to migrate MBOX file to well known Outlook PST and Office 365. Besides this, it also supports and migrates more than 20 email clients of MBOX which include AppleMail, Opera, Thunderbird and SeaMonkey effortl…
If you are looking for an automated solution for backup single or multiple Office 365 user mailboxes to Outlook data file, then you can use Kernel Office 365 Backup & Restore tool. Go through the video to check out the steps to backup single or mult…

588 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question