• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1471
  • Last Modified:

Barcode Font Does Not Show

I have an ASP.NET website I've built that streams a Crystal Report to pdf format and displays it. One of the fields in the Crystal Report uses a barcode font(3 of 9). If I open the report locally by itself, I see the barcode font. If I run the website locally from my development box, I see the barcode font. When I run the website from the server, I Do Not see the barcode font. The field is displayed as regular readable text. I've tripple checked to make sure the font is installed on the server.

So, a recap... I've got a crystal report that uses a barcode font. By itself, it works great. In my webpage I load the crystal report in code, export it to PDF format and stream it to the browser (Internet Explorer), which then displays the crystal report in pdf format via its Acrobat Reader plug-in.

The problem is that once it's displayed in this fashion... no more barcode.
Help please.
Dim tmpReport As New CrystalDecisions.CrystalReports.Engine.ReportDocument
Dim strFileName As String = Server.MapPath("~/TimeSheet.rpt")
 
tmpReport.Load(strFileName, OpenReportMethod.OpenReportByDefault)
tmpReport.SetDatabaseLogon("<AccountName>", "<password>")
 
Dim oStream As New MemoryStream
oStream = tmpReport.ExportToStream(ExportFormatType.PortableDocFormat)
 
Response.Clear()
Response.Buffer = True
Response.ContentType = "application/pdf"
Response.BinaryWrite(oStream.ToArray)
Response.End()

Open in new window

0
AaronNance
Asked:
AaronNance
  • 2
  • 2
1 Solution
 
mlmccCommented:
Same printer available in all 3 cases?
Crystal uses the printer driver to display reports.

Any permission issues with fonts?

mlmcc
0
 
AaronNanceAuthor Commented:
We made sure we've got the same printer on the server that I've got installed locally. It doesn't seem to matter. The report still displays as a pdf with no barcode... just the text.

As for permission issues with fonts? Not sure what you mean there. We don't get any errors and the "Everyone" group has access to the Fonts directory at the moment.
0
 
mlmccCommented:
I wasn't sure how to state the permissions issue.  That should be what you need.

Not sure what the issue is.  I'll see what I can find.

mlmcc
0
 
AaronNanceAuthor Commented:
Didn't really solve the problem, but I wanted to close the question.
Thanks for the attempt. =)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now