Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2927
  • Last Modified:

SSH User can't log in.

I created a new user for someone to log in with but the account can't never log in.  I changed the sshd_config, I gave it a password, he is in the passwd file.  I can see him in webmin and account is enabled, tried adding to a group and still can't log in.

Running Solaris 8 2/02 Sparc.

Every time I try to log in through ssh I get access denied.
0
jremy9
Asked:
jremy9
2 Solutions
 
albuitraCommented:
Maybe the ssh daemon doesn't allow password authentication
check in sshd.config for password_authentication
0
 
jremy9Author Commented:
it is set to yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
0
 
albuitraCommented:
do you assign a valid shell ?
could you look for errors in /var/adm/messages or /var/log/messages ?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Pepino125Commented:
also check his/her ip in the etc/hosts.allow and etc/host.deny
another test is to have him try to connect with the -vvv option. you can also have the sshd with the -vvv option for further troubleshooing in case the etc/host.allow or etc/host.deny dont work.
0
 
jremy9Author Commented:
none of these work and the person is already in the allowusers.  I still am getting access denied and am not seeing anything new in the messages log about it.
0
 
jremy9Author Commented:
so we have may have overlooked the obvious of restartinig the daemon but that was the solutions.  so i think i will pick this as the answer.  points 0.
0
 
albuitraCommented:
Hi,

IMHO, the points have to be assigned to someone who try to colaborate
Pepino125 and me give some solutions, but we can't do the obvius
0
 
unix-issuesCommented:
Check shell the /etc/passwd file.

grep user /etc/passwd

it seems like noshell,

change it in /etc/passwd file

it ll work.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now