?
Solved

Exchange 2007 SMTP Header Sends Private IP Address of Client instead of Server

Posted on 2008-06-10
7
Medium Priority
?
1,858 Views
Last Modified: 2008-09-17
We have officially implemented Exchange 2007 in our network infrastructure, however, we have a few people that can't receive emails from us.  When I attempt to send an email through Outlook using an Exchange Mail Box or even standard pop/smtp settings we get a return undeliverable error as follows (See attached Code Snippets).

We've gotten 2 different errors, both of them sent from the same network client.

Our server is running Windows 2008 with Exchange 2007 SP1.  The system has both an internal nic with a private IP and an external nic with an ip that does perform Reverse DNS.

We have 2 Transport Hubs Setup, one to handle incoming email from the public nic, and one that handles all our internal email from our private nic.

I'm not sure where to look as I've exhausted all of my known ideas to fix the problem, any help would be greatly appreciated.

Daymon

gate17.gate.iad.mlsrvr.com #554 5.7.1 <daymon@themailshoppe.com>: Sender address rejected: ACL mx_access mail server in RFC 1918 private network ##
Original message headers:
Received: from daymonpc (192.168.2.101) by DC2.corp.themailshoppe.com
 (192.168.2.2) with Microsoft SMTP Server id 8.1.278.0; Mon, 9 Jun 2008
 10:48:18 -0500
From: Daymon Capers <daymon@themailshoppe.com>
To: <fran@printimaging.net>
Subject: Quote
Date: Mon, 9 Jun 2008 10:48:39 -0500
Message-ID: <010201c8ca48$49a31620$dce94260$@com>
MIME-Version: 1.0
Content-Type: multipart/mixed;
	boundary="----=_NextPart_000_0103_01C8CA1E.60CD0E20"
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: AcjKSANLZSIgV38KTd+DiNN2kxByug==
Content-Language: en-us
Return-Path: daymon@themailshoppe.com
====================================================================
Sometimes we get this (It's not the same everytime):
====================================================================
gate13.gate.iad.mlsrvr.com #554 5.7.1 <daymon@themailshoppe.com>: Sender address rejected: ACL mx_access mail server in RFC 1918 private network ##
 
Original message headers:
 
Received: from DC2.corp.themailshoppe.com ([::1]) by
 DC2.corp.themailshoppe.com ([::1]) with mapi; Tue, 10 Jun 2008 15:57:31 -0500
From: Daymon Capers <daymon@themailshoppe.com>
To: "fran@printimaging.net" <fran@printimaging.net>
Date: Tue, 10 Jun 2008 15:45:53 -0500
Subject: Quote
Thread-Topic: Quote
Thread-Index: AcjLOeaIdCVMPcrMTOWqKN9WOrdd7Q==
Message-ID: <E7B54D76634E0E40B4196A472D37CFAE90A5BC09@DC2.corp.themailshoppe.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
acceptlanguage: en-US
Content-Type: multipart/mixed;
	boundary="_004_E7B54D76634E0E40B4196A472D37CFAE90A5BC09DC2corpthemails_"
MIME-Version: 1.0

Open in new window

0
Comment
Question by:themailshoppe
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
7 Comments
 
LVL 8

Expert Comment

by:Share-IT
ID: 21755392
This looks like you're connecting to exchange via SMTP instead of MAPI. Is this likely to be the case? If so, reconfigure outlook to connect to Exchange rather than configuring via SMTP and POP3/IMAP.

If you're already using MAPI connection then this is a weird one.
0
 

Author Comment

by:themailshoppe
ID: 21755452
Tell me about it, this is the craziest thing I've scene.  The 2nd of the 2 error messages looks like an incomplete IPv6 network address.  But we've disabled this from the nics, I'm not sure if it should be disabled anywhere else or not.

When we first started to get the errors we were only using POP and SMTP connections to Exchange.  I haven't 100% rolled out exchange mailboxes to the clients as of yet.

So why is our SMTP Server grabbing my local private IP address and using it as the SMTP host header.

Here's another situation, if I'm outside the office lets say at home and I'm connecting using POP/SMTP on the external nic or public ip it works fine.  If I connect to the VPN and try again it fails with the same return errors as above.

Daymon
0
 
LVL 8

Accepted Solution

by:
Share-IT earned 2000 total points
ID: 21755532
Because your using SMTP the originating machine i.e. the client is the first machine to generate the SMTP mail and thus you see that IP address. If you're using MAPI then the mail is effectively created on the exchange server and so the server is the originating machine and you'll see the servers IP address.

As for the external connections working fine - thats weird as you should see the client IP and if you look closely, you probably are. The reason that the mail fails to be delivered if you are connected via the VPN is that mail is seen as coming from a private IP address (probably in the 192.x.x.x range) and the receiving server is rejecting it as spam or spoofed. When you connect externally, you're probably still seeing that client IP address but as it's going to be public address - the receiving server will accept it.
0
 

Author Comment

by:themailshoppe
ID: 21755607
You were correct, I did not have an exchange MAPI transport hub, I must have deleted it.  I created a hub, assigned it the private nic IP address and port 587 as it says.  I restarted the transport service and sent the email again.  This is what was returned:

Original message headers:
Received: from DC2.corp.themailshoppe.com ([::1]) by
DC2.corp.themailshoppe.com ([::1]) with mapi; Tue, 10 Jun 2008 17:19:25 -0500
From: Daymon Capers <daymon@themailshoppe.com>
To: "fran@printimaging.net" <fran@printimaging.net>
Date: Tue, 10 Jun 2008 17:19:24 -0500

So it is using the MAPI service on the 2nd error message but just not assigning an IP address to the headers so external servers can perform DNS Reverse Lookup.  Or at least it's assigning something weird ([::1]).

Daymon

Daymon
0
 
LVL 1

Expert Comment

by:jaraco
ID: 24715093
::1 is the IPv6 equivalent of 127.0.0.1 (i.e. localhost).  When the SMTP server prepares an outgoing message, it attaches the name and IP of itself.  In your case, it appears as if DC2.corp.themailshoppe.com was resolving to ::1 on that machine.

I don't believe this issue was a mail server configuration issue at all.  It was more likely a DNS issue.  It appears that from the perspective of gate13.gate.iad.mlsrvr.com, the mail server DC2.corp.themailshoppe.com resolved to 192.168.x.x, an RFC 1918 private network address.  Therefore, the receiving server could legitimately say that the senders name DC2.corp.themailshoppe.com does not resolve to _only_ routable addresses, so it considers the sender untrusted.

The fix is to ensure that DC2.corp.themailshoppe.com always resolves to only routable internet addresses.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article lists the top 5 free OST to PST Converter Tools. These tools save a lot of time for users when they want to convert OST to PST after their exchange server is no longer available or some other critical issue with exchange server or impor…
A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question